Results 1 to 3 of 3

Thread: Git commands run very slow

  1. #1

    Default Git commands run very slow

    This is a fresh install of TumbleWeed(LXDE) and every package is updated to the latest version. While setting up my install for the first time I installed OhMyZsh and I came across this issue. After I run any command, it takes some time until I am presented with a new shell prompt. I found that it only happened if I have OhMyZsh enabled. So I used the following command to see what was happening:

    Code:
    zsh -xv
    I found out that the time was taken in running the following commands before prompting me with a new prompt:

    Code:
    git symbolic-ref HEAD
    
    git rev-parse --short HEAD
    So, I independently ran the commands and the message shown to me was:

    Code:
    fatal: Not a git repository (or any parent up to mount parent /home) Stopping at filesystem boundary
    
    (GIT_DISCOVERY_ACROSS_FILESYSTEM not set)
    Now, I understand that the error was shown to me because I was not inside a git folder. But the main problem is that even if I am inside a git folder, the commands take a much longer time (~20 more seconds) compared to my ArchLinux install.

    Did I not install something that resulted in the above slowness? Do I have to set any variable? Please help me with this if possible. I am unable to work with such a slow git. Thank You!

  2. #2
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    11,475
    Blog Entries
    2

    Default Re: Git commands run very slow

    You're not very clear what you've done and trying to do.

    But,
    From what I read about Oh-My-Zsh, the following install page (which IMO is one of the worst organized installs I've ever seen)
    https://github.com/robbyrussell/oh-m...Installing-ZSH

    You should(warning - I've not spent time to do the following myself, so this is all according to the Author)
    1. Install zsh. You can use YAST or run the following in an elevated console
    Code:
    zypper install zsh
    2. Set zsh as your default shell
    Code:
    chsh -s $(which zsh)
    Then, it seems that you should go to the project's home page to install Oh-My-Zsh itself
    https://github.com/robbyrussell/oh-my-zsh

    It seems that the the next step is to use the provided curl or wget commands to download an install script.
    Although nothing says to do so, I assume the next logical step is to execute that script you just downloaded which should download and install the Oh-My-Zsh framework.

    At that point, you should have the basic configuration installed, and you should then proceed to enable plugins, customize the look and do anything else you wish.

    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

  3. #3

    Default Re: Git commands run very slow

    Quote Originally Posted by tsu2 View Post
    You're not very clear what you've done and trying to do.

    But,
    From what I read about Oh-My-Zsh, the following install page (which IMO is one of the worst organized installs I've ever seen)
    https://github.com/robbyrussell/oh-m...Installing-ZSH

    You should(warning - I've not spent time to do the following myself, so this is all according to the Author)
    1. Install zsh. You can use YAST or run the following in an elevated console
    Code:
    zypper install zsh
    2. Set zsh as your default shell
    Code:
    chsh -s $(which zsh)
    Then, it seems that you should go to the project's home page to install Oh-My-Zsh itself
    https://github.com/robbyrussell/oh-my-zsh

    It seems that the the next step is to use the provided curl or wget commands to download an install script.
    Although nothing says to do so, I assume the next logical step is to execute that script you just downloaded which should download and install the Oh-My-Zsh framework.

    At that point, you should have the basic configuration installed, and you should then proceed to enable plugins, customize the look and do anything else you wish.

    TSU
    Thank You for the reply. And sorry that I didn't make it clear but I posted the issue after I had installed and configured everything to run OhMyZsh. To be precise I used my previous configs from my other install on a fresh install of OhMyZsh. Also, I have already debugged the issue and pin-pointed the command with which I was having the issue.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •