Quote Originally Posted by arvidjaar View Post
Then you probably need to explain how did you hibernate in the first place. Hibernation requires some disk space to save memory. Normally it is either swap or unused disk partition.
Sorry, my bad! The partitioning is as follows:

Code:
# fdisk -l
Disk /dev/sda: 37.3 GiB, 40007761920 bytes, 78140160 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0x20a0209f


Device     Boot    Start      End  Sectors  Size Id Type
/dev/sda1           2048  2105343  2103296    1G 82 Linux swap / Solaris
/dev/sda2  *     2105344 18876415 16771072    8G 83 Linux
/dev/sda3       18876416 78139391 59262976 28.3G 83 Linux

Quote Originally Posted by deano_ferrari View Post
That could be a backlight issue. I've seen suggestions to use a custom Xorg config file (eg /etc/X11/xorg.conf.d/20-intel.conf) with the following

Code:
Section "Device"
        Identifier  "Default Device"
        Driver      "intel"
        Option      "Backlight"  "intel_backlight"
        BusID       "PCI:0:2:0"
EndSection
It will take effect next time the X-server is started. See if that helps.
I added this file and rebooted. X won't start at all.

BTW, what do your current boot parameters look like? (Just in case tweaking is needed)
Code:
cat /proc/cmdline
Code:
BOOT_IMAGE=/boot/vmlinuz-4.9.0-1-default root=UUID=.....(not sure if this should be public, so I remove it) resume=/dev/sda1 splash=verbose quiet showopts plymouth.enable=0