Results 1 to 8 of 8

Thread: 13.1 VirtualBox does not run anymore

  1. #1

    Default 13.1 VirtualBox does not run anymore

    Dear opensuse members,
    I have some days now starting my virtual box. It looks like that after some kernel update the Virtual box required some updates and somehow I created a big mess.

    Now when I try to run virtualbox I get
    Code:
    RTR3InitEx failed with rc=-1912 (rc=-1912)
    
    The VirtualBox kernel modules do not match this version of VirtualBox. The installation of VirtualBox was apparently not successful. Executing
    
    '/etc/init.d/vboxdrv setup'
    
    may correct this. Make sure that you do not mix the OSE version and the PUEL version of VirtualBox.
    and when I try to compile it
    Code:
    /etc/init.d/vboxdrv setup
    Recompiling VirtualBox kernel module, NOT. It has been packaged.
    My issue returns
    Code:
    cat /etc/issue
    Welcome to openSUSE 13.1 "Bottle" - Kernel \r (\l).

    This is what installed related to virtualbox

    Code:
    rpm -qa  | grep ualbox
    virtualbox-host-kmp-default-4.2.36_k3.12.62_52-2.64.4.x86_64
    virtualbox-qt-4.2.36-2.64.4.x86_64
    virtualbox-4.2.36-2.64.4.x86_64
    virtualbox-guest-kmp-default-4.2.36_k3.12.62_52-2.64.4.x86_64
    and my install related kernel files

    Code:
    rpm -qa  | grep kernel
    kernel-default-devel-3.12.59-47.1.x86_64
    kernel-debug-devel-3.12.53-40.1.x86_64
    kernel-source-3.12.53-40.1.noarch
    kernel-debug-devel-3.12.57-44.2.x86_64
    texlive-l3kernel-doc-2013.81.svn_4469svn29409-10.5.3.noarch
    kernel-desktop-3.12.53-40.1.x86_64
    kernel-devel-3.12.57-44.1.noarch
    kernel-firmware-20140807git-2.24.2.noarch
    kernel-desktop-devel-3.12.59-47.1.x86_64
    texlive-l3kernel-2013.81.svn_4469svn29409-10.5.3.noarch
    kernel-syms-3.12.57-44.1.x86_64
    kernel-desktop-3.12.57-44.2.x86_64
    kernel-devel-3.12.53-40.1.noarch
    kernel-devel-3.12.62-52.1.noarch
    kernel-desktop-devel-3.12.57-44.2.x86_64
    kernel-syms-3.12.53-40.1.x86_64
    kernel-source-3.12.59-47.1.noarch
    kernel-debug-devel-3.12.59-47.1.x86_64
    kernel-xen-devel-3.12.53-40.1.x86_64
    kernel-default-devel-3.12.53-40.1.x86_64
    kernel-macros-3.12.59-47.1.noarch
    kernel-desktop-3.12.62-52.1.x86_64
    kernel-devel-3.12.59-47.1.noarch
    kernel-default-devel-3.12.57-44.2.x86_64
    kernel-xen-devel-3.12.57-44.2.x86_64
    kernel-xen-devel-3.12.59-47.1.x86_64
    kernel-default-3.12.62-52.1.x86_64
    kernel-desktop-3.12.59-47.1.x86_64
    kernel-source-3.12.62-52.1.noarch
    kernel-source-3.12.57-44.1.noarch
    kernel-syms-3.12.59-47.1.x86_64
    kernel-desktop-devel-3.12.53-40.1.x86_64

    What would you suggest me to try now to solve this situation?

    Thanks a lot in advance
    Regards
    Alex

  2. #2

    Default AW: 13.1 VirtualBox does not run anymore

    Please post which kernel you are actually using from the few you have installed:
    Code:
    uname -a
    In particular, you have both kernel-default and kernel-desktop, but only virtualbox-host-kmp-default.
    I'd find it likely that you are using kernel-desktop, which would need virtualbox-host-kmp-desktop instead.

  3. #3

    Default Re: AW: 13.1 VirtualBox does not run anymore

    Quote Originally Posted by wolfi323 View Post
    Please post which kernel you are actually using from the few you have installed:
    Code:
    uname -a
    In particular, you have both kernel-default and kernel-desktop, but only virtualbox-host-kmp-default.
    I'd find it likely that you are using kernel-desktop, which would need virtualbox-host-kmp-desktop instead.

    I knew I forgot to report something:
    uname -a
    Linux caracus 3.12.62-52-desktop #1 SMP PREEMPT Wed Aug 10 18:37:26 UTC 2016 (069dc39) x86_64 x86_64 x86_64 GNU/Linux

  4. #4

    Default Re: 13.1 VirtualBox does not run anymore

    Quote Originally Posted by alaios View Post
    I knew I forgot to report something:
    uname -a
    Linux caracus 3.12.62-52-desktop #1 SMP PREEMPT Wed Aug 10 18:37:26 UTC 2016 (069dc39) x86_64 x86_64 x86_64 GNU/Linux
    As suspected.
    You need virtualbox-host-kmp-desktop in that case.
    So install it, and virtualbox should work again after a reboot:
    Code:
    sudo zypper in virtualbox-host-kmp-desktop
    Actually I would recommend to remove kernel-default completely, unless you have a specific reason to have both...
    Code:
    sudo zypper rm virtualbox-host-kmp-default virtualbox-guest-kmp-default kernel-default

  5. #5

    Default Re: 13.1 VirtualBox does not run anymore

    thanks a lot for the reply
    I tried both commands and it had to remove packages and install new ones.
    Now when I issue:
    Code:
    /etc/init.d/vboxdrv setup
    Recompiling VirtualBox kernel module, NOT. It has been packaged.
    I get exactly the same message.
    When starting virtualbox I also get

    Code:
    Result Code: NS_ERROR_FAILURE (0x80004005)
    Component: Machine
    Interface: IMachine {22781af3-1c96-4126-9edf-67a020e0e858}
    How I should proceed now?
    Regards
    Alex

  6. #6

    Default Re: 13.1 VirtualBox does not run anymore

    Quote Originally Posted by alaios View Post
    Now when I issue:
    Code:
    /etc/init.d/vboxdrv setup
    Recompiling VirtualBox kernel module, NOT. It has been packaged.
    I get exactly the same message.
    That's normal if you use openSUSE's packages.
    "vboxdrv setup" would normally compile the kernel module for your kernel, but the openSUSE packages do contain the kernel module in pre-compiled form and no source code (that's also why they have to match the kernel).

    Did you reboot after running the zypper commands?

    Which exact packages do you have installed now?
    Code:
    rpm -qa | egrep -i "virtualbox|kernel"
    And which kernel are you using?
    Code:
    uname -a
    Is your user member of the "vboxusers" group?
    Code:
    groups

  7. #7

    Default Re: 13.1 VirtualBox does not run anymore

    omg! I logged in back to say
    THANK YOU:
    You made my day. It was the restart missing and the BOOM
    everything works again.
    Alex

  8. #8

    Default Re: 13.1 VirtualBox does not run anymore

    Ok, great!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •