Results 1 to 4 of 4

Thread: Issue with Yast system language / keyboard input language

  1. #1

    Default Issue with Yast system language / keyboard input language

    Hello,

    I usually set my system language to English, and add French and Japanese as secondary input languages.

    I have found the experience out of the box to be somewhat buggy.

    Basically, I went over to Yast > keyboard > input

    I selected to add French and Japanese,

    Somehow what's happened is my system language has changed to a strange blend of french and Japanese.

    This is annoying, because I'm used to english keywords and would really prefer to use my system in English.

    To make matters more awkward, that input selection menu did not prompt me to setup the input language switcher, and the input language switcher is nowhere to be found on my desktop:



    this is where I was mucking about with the language settings and I don't see the possibility to select more than one language:



    If I'm forgetting any diagnostic info, do mention it!

    BTW there's a bug in the crash feedback reporting app, where would I open a ticket for that?

    Much love <3

    Khan

  2. #2
    Join Date
    Oct 2014
    Location
    Italy
    Posts
    1,674

    Default Re: Issue with Yast system language / keyboard input language

    Hi and welcome to the Forums! I'm not a regular KDE user, but I think you are looking in the wrong place with Yast.
    Please check the "Configure Desktop" (AKA "System Settings") in the KDE Desktop, then in "Personalization" > "Regional Settings" and I think you'll be able to configure what you need.
    AFAIK Yast "System Language" is for X-Windows / Console setup and might be overridden by the desktop settings (it surely is that way with Gnome).
    Main: Leap 15 Gnome on i7 4720HQ + Geforce GTX960M
    Test: Leap 42.3 (& others) on Core2Duo + GM965

  3. #3

    Default Re: Issue with Yast system language / keyboard input language

    Yup, perfect!

    For anyone who may have a similar issue setting up input languages, here's the steps visually:







    I then set the input switcher to a familiar key combination (ALT + SHIFT)

    And specified global use for simplicity sake.

    No reboot required, works like a charm!

    Only issue now is with the Japanese input. Currently it's basically only accepting Katakana input using some no longer used input method.

    Would anyone happen to know about inputting romaji similar to the OS X input system?

    The macintosh input system listed in OpenSUSE 42.2 is severely deprecated.

  4. #4
    Join Date
    Jun 2008
    Location
    NZ
    Posts
    1,546

    Default Re: Issue with Yast system language / keyboard input language

    Quote Originally Posted by TrooperKhan View Post

    Only issue now is with the Japanese input. Currently it's basically only accepting Katakana input using some no longer used input method.

    Would anyone happen to know about inputting romaji similar to the OS X input system?

    The macintosh input system listed in OpenSUSE 42.2 is severely deprecated.
    for Japanese input you'll want to install an IME.
    The most trouble free one in openSUSE is the FCITX / MOZC combination
    Mark F.
    openSUSE Leap 15.1 / Plasma 5.12



Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •