Results 1 to 7 of 7

Thread: How do I play flash videos under Leap 42.1

  1. #1

    Default How do I play flash videos under Leap 42.1

    I used to be able to play flash videos using vlc and I believe other video
    players. This seems no longer to be the case. Any solution greatly
    appreciated. By the way the same videos play with vlc under windows.

    Allan

  2. #2
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,703

    Default Re: How do I play flash videos under Leap 42.1

    Installed flash?

    And all codecs must come from packman did you do a vendor change??

  3. #3
    Join Date
    Jun 2008
    Location
    West Yorkshire, UK
    Posts
    3,448

    Default Re: How do I play flash videos under Leap 42.1

    A friend who has everything set up as recommended by gogalthorp still found some sites which claimed he did not have the lastest flash installed and refused to play. Then a number of them updated their sties and the videos play fine. So you may still hit a problem with some badly configured sites even after you have done everything correctly. My friend commented that these tended to be thoe ones with the less good content anyway.

  4. #4
    Join Date
    Sep 2008
    Posts
    2,997

    Default Re: How do I play flash videos under Leap 42.1

    I think he's asking about flv files which usually use vp6 or mpeg4 asp compression for the video stream and mp3 for the audio stream
    you don't need flash for that but you do need the patented codecs from packman
    do you have the packman repo, have you done a full vendor change to it?
    tell us your repo list
    Code:
    zypper lr -d

  5. #5

    Default Re: How do I play flash videos under Leap 42.1

    I A wrote:

    >
    >
    > I think he's asking about flv files which usually use vp6 or mpeg4 asp
    > compression for the video stream and mp3 for the audio stream
    > you don't need flash for that but you do need the patented codecs from
    > packman
    > do you have the packman repo, have you done a full vendor change to it?
    > tell us your repo list
    >
    > Code:
    > --------------------
    > zypper lr -d
    > --------------------
    >
    >

    For what its worth here is the list.

    | Alias | Name
    | Enabled | GPG Check | Refresh | Priority | Type | URI
    | Service
    ---+-------------------------------+-----------------------------------------+---------+-----------+---------+----------+--------+------------------------------------------------------------------------------------+--------
    1 | ftp.gwdg.de-suse | Packman Repository
    | Yes | (r ) Yes | Yes | 99 | rpm-md |
    http://ftp.gwdg.de/pub/linux/packman...USE_Leap_42.1/
    |
    2 | google-chrome | google-chrome
    | Yes | (r ) Yes | Yes | 99 | rpm-md |
    http://dl.google.com/linux/chrome/rpm/stable/x86_64
    |
    3 | linuxdownload.adobe.com-linux | Adobe Flash Plugin
    | Yes | ( p) Yes | Yes | 99 | rpm-md |
    http://linuxdownload.adobe.com/linux/x86_64/
    |
    4 | openSUSE-42.1-0 | openSUSE-42.1-0
    | Yes | (r ) Yes | No | 99 | yast2 |
    cd:///?devices=/dev/disk/by-id/ata-DVD_RW_DRU-820A
    |
    5 | openSUSE_42.1-0 | openSUSE 42.1-0
    | Yes | (r ) Yes | No | 99 | yast2 |
    dvd:///?devices=/dev/sr1
    |
    6 | openSUSE_42.2-0 | openSUSE 42.2-0
    | Yes | (r ) Yes | No | 99 | yast2 | iso:///?iso=openSUSE-
    Leap-42.2-DVD-x86_64.iso&url=dir%3A%2Fhome%2Faemau%2FDownload |
    7 | opensuse-guide.org-repo | Libdvdcss Repository
    | Yes | (r ) Yes | Yes | 99 | rpm-md | http://opensuse-guide.org/repo/openSUSE_Leap_42.1/ |
    8 | repo-debug | openSUSE-Leap-42.1-Debug
    | No | ---- | Yes | 99 | NONE |
    http://download.opensuse.org/debug/d...42.1/repo/oss/
    |
    9 | repo-debug-non-oss | openSUSE-Leap-42.1-Debug-Non-Oss
    | No | ---- | Yes | 99 | NONE |
    http://download.opensuse.org/debug/d.../repo/non-oss/
    |
    10 | repo-debug-update | openSUSE-Leap-42.1-Update-Debug
    | No | ---- | Yes | 99 | NONE |
    http://download.opensuse.org/debug/update/leap/42.1/oss
    |
    11 | repo-debug-update-non-oss | openSUSE-Leap-42.1-Update-Debug-Non-Oss
    | No | ---- | Yes | 99 | NONE |
    http://download.opensuse.org/debug/u.../42.1/non-oss/
    |
    12 | repo-non-oss | openSUSE-Leap-42.1-Non-Oss
    | Yes | (r ) Yes | Yes | 99 | yast2 |
    http://download.opensuse.org/distrib.../repo/non-oss/
    |
    13 | repo-oss | openSUSE-Leap-42.1-Oss
    | Yes | (r ) Yes | Yes | 99 | yast2 |
    http://download.opensuse.org/distrib...42.1/repo/oss/
    |
    14 | repo-source | openSUSE-Leap-42.1-Source
    | No | ---- | Yes | 99 | NONE |
    http://download.opensuse.org/source/...42.1/repo/oss/
    |
    15 | repo-update | openSUSE-Leap-42.1-Update
    | Yes | (r ) Yes | Yes | 99 | rpm-md |
    http://download.opensuse.org/update/leap/42.1/oss/
    |
    16 | repo-update-non-oss | openSUSE-Leap-42.1-Update-Non-Oss
    | Yes | (r ) Yes | Yes | 99 | rpm-md |
    http://download.opensuse.org/update/leap/42.1/non-oss/
    |
    17 | tumoss | tumoss
    | No | ---- | Yes | 99 | yast2 |
    http://download.opensuse.org/tumbleweed/repo/oss
    |
    linux-k5dz:/home/aemau #



    I deleted any vlc and flash player packages then reinstalled from the
    packman repository. Still cannot view flv files.

    Allan

  6. #6
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,003

    Default Re: How do I play flash videos under Leap 42.1

    As said, youmust do the full vendor change to Packman. Not installing just some packages you might think are interesting.

    In your case
    Code:
    zypper dup --from 1
    Henk van Velden

  7. #7

    Default Re: How do I play flash videos under Leap 42.1

    Problem solved. Apparently I had both vlc and vlc-qt installed. Deleted
    vlc and now everything works. Installation process gave no indication that
    the two packages couldn't co-exist.

    Allan



Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •