Results 1 to 4 of 4

Thread: icewm-session doesn't load fcitx applet to the icewmtray

  1. #1

    Default icewm-session doesn't load fcitx applet to the icewmtray

    a. openSUSE Leap 42.2, up-to date system, official repos + packman (for codecs only)
    b. IceWM 1.3.12, fcitx version: 4.2.9.1
    c. System was installed without X, minimal X was installed by hand, icewm-session is started with xinitrc, fcitx daemon intended to start the tray icon is prefixed in the xinitrc file with sleep interval.
    nm-applet, notification-daemon applet both load to the icewmtray as they should (for purpose of testing the icewmtray viability altogether).
    fcitx applet would load to stalonetray added to xinitrc (for purpose of testing if the applet is missing altogether).
    fcitx applet would load to the icewmtray on default arch linux install on my separate drive.
    could it possibly be some sort of blacklisting on the opensuse side of things? i wouldn't mind that as long as it's an expected behavior. if not, will be more then happy to further investigate matters and provide additional info when needed.
    starting fcitx daemon by hand from the terminal doesn't seem to cause any errors.
    Thanks in advance

  2. #2
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    11,380
    Blog Entries
    2

    Default Re: icewm-session doesn't load fcitx applet to the icewmtray

    Although I'm not familiar with fcltx,
    A little research suggests that unless you install a real Desktop you'll probably need to do some manual configurations for whatever you're trying to accomplish.

    I'd recommend you take a look at the following Arch Wiki on fcltx, taking special note of the parts that describe configuration for non-Desktop environments
    https://wiki.archlinux.org/index.php/fcitx

    And then you'll likely need to apply that information to the IceWM documentation on configuring the "toolbar"
    http://www.icewm.org/manual/icewm-12.html#toolbar

    Things might work better if you instead install an LXDE or XFCE Desktop, then run fcltx... At least, that's according to the first link above. Then, your options would be tied to whatever Display Manager you're using.

    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

  3. #3

    Default Re: icewm-session doesn't load fcitx applet to the icewmtray

    Quote Originally Posted by tsu2 View Post
    Although I'm not familiar with fcltx,
    A little research suggests that unless you install a real Desktop you'll probably need to do some manual configurations for whatever you're trying to accomplish.

    I'd recommend you take a look at the following Arch Wiki on fcltx, taking special note of the parts that describe configuration for non-Desktop environments
    https://wiki.archlinux.org/index.php/fcitx

    And then you'll likely need to apply that information to the IceWM documentation on configuring the "toolbar"
    http://www.icewm.org/manual/icewm-12.html#toolbar

    Things might work better if you instead install an LXDE or XFCE Desktop, then run fcltx... At least, that's according to the first link above. Then, your options would be tied to whatever Display Manager you're using.

    TSU
    thanks a lot for the quickest reply!
    i do follow those guides for non-DE's and i am somewhat familiar with icewm and its configs. As far as i remember, if not enabled by default, it's usually a matter of making sure TaskBarShowTray=1 # 0/1 is uncommented in icewm preferences config file. All in all it's the first time i see that icon not loading under icewm-session altogether. not a show-stopper by any means, but something to report on i suppose

  4. #4

    Default Re: icewm-session doesn't load fcitx applet to the icewmtray

    after a little research, looking at the version number (1.3.12 for LEAP), it appears icewm package for LEAP 42.2 is taken from the fork (https://github.com/bbidulock/icewm/) of the IceWM CVS on sourceforge (http://icewm.sourceforge.net/), which not only distincts it from my given example of arch installation, but from opensuse tumbleweed as well (which with the version number 1.3.7 from the looks of it is also still reliant on the sourceforge source). Just out of curiosity, could anyone using Tumbleweed check if fcitx applet would appear in icewm-session? i'm planning of giving it a go myself, but would love some feedback

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •