Results 1 to 4 of 4

Thread: Problems with Okular in Opensuse leap 42.2.

Hybrid View

  1. #1

    Default Problems with Okular in Opensuse leap 42.2.

    As a new member I do not know whether I am in the right section here, but I would like to post this anyhow.
    I used Okular in opensuse 13.2 to open image files, with good results I might add. It worked with jpeg, jpg, png, the lot.
    In 42.2 Okular gives me an error message stating: Can not find a plugin which is able to handle the document being passed.
    If I click on that the following message is: Could not open /filename/.
    The thing is, that if I present Okular with a folder, only containing images in diverse formats, it opens that folder and displays all images, albeit in a sort of pdf format.
    I can scroll from image to image, like in a pdf document from chapter to chapter.
    As I need Okular for my work, I use this work around to get what I want, but I hope someone on here can show me the way to fix this behaviour.
    It is quite annoying.

    Cheers.

  2. #2
    Join Date
    Jun 2008
    Location
    West Yorkshire, UK
    Posts
    3,448

    Default Re: Problems with Okular in Opensuse leap 42.2.

    I see the problem but I have never had it because I use Gwenview for images and Okular for documents, though the image format which Okular does open is EPS. Perhaps because Gwenview has now matured as a program, the Okular developers have decided that continuing to support images is not worth it. You could try asking on the KDE forums.
    Last edited by john_hudson; 08-Jan-2017 at 14:42. Reason: typo

  3. #3

    Default Re: Problems with Okular in Opensuse leap 42.2.

    Quote Originally Posted by john_hudson View Post
    Perhaps because Gwenview has now matured as a program, the Okular developers have decided that continuing to support images is not worth it.
    That's not the case.

    But okular requires libkexiv2 to support image files (except EPS which are actually Postscript files).
    The problem is that libkexiv2 has been ported to KDE Frameworks5 a while ago, while okular is still a KDE4 application, so it cannot be built with image support any more.

    Okular 1.0 (part of KDE Applications 16.12.0) has been ported to KF5 too though, so this is actually "fixed" already in Factory/Tumbleweed.
    You could get that from the additional KDE:Applications repo, the URL is:
    http://download.opensuse.org/reposit...USE_Leap_42.2/

    The default image viewer in KDE is gwenview though.

    If you open Okular with a folder, it probably just displays *previews* of the contained images using the standard thumbnailer I suppose.

  4. #4

    Default Re: Problems with Okular in Opensuse leap 42.2.

    Thank you both for your replies.
    I have downloaded and installed from the repo and added Mobipocket because that package contains libqmobipocket, needed by Okular.
    Tried it out and it works!
    Thank you so much!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •