Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: Не запускается гуй на видеокарте nvidia

  1. #1

    Default Не запускается гуй на видеокарте nvidia

    openSUSE-Leap-42.2
    На дискретной видеокарте intel запускается корректно.
    Драйвер устанавливается корректно, хоть из репозиториев, хоть ручками.
    При запуске nvidia-xconfig возвращает ошибку:
    Code:
    Package xorg-server was not found in the pkg-config search path. Perhaps you should add the directory containing 'xorg-server.pc' to the PKG_CONFIG_PATH environment variable
    No package xorg-server found
    New X configuration file written to 'etc/X11/xorg.conf'
    Решения, предложенные здесь, здесь и здесь ничего не исправили.
    Yast на запрос возвращает пакеты xorg-X11-xserver*.
    Предполагаю, что причина проблемы в том, что в ядре 4* пакет xorg-xserver обновлён до xorg-X11-xserver, а драйвер nvidia об этом не знает.
    Возможное решение: откатить систему до той, в которой использовался xorg-xserver.
    Есть ли лучшие идеи?

  2. #2
    Join Date
    Jan 2011
    Location
    Vladivostok
    Posts
    634

    Default Re: Не запускается гуй на видеокарте nvidia

    >>На дискретной видеокарте intel запускается корректно.

    может, на интегрированной?

    а зачем запускать nvidia-xconfig ? можно и без него, ну и ругань на отстутсвие xorg-server - не совсем ошибка, ибо:
    New X configuration file written to 'etc/X11/xorg.conf'


    PS ядро и версия иксов в данном случае никак не связаны

  3. #3

    Default Re: Не запускается гуй на видеокарте nvidia

    Вы правы, на интегрированной.
    Почему тогда не работает? Других ошибок нет.

  4. #4
    Join Date
    Jan 2011
    Location
    Vladivostok
    Posts
    634

    Default Re: Не запускается гуй на видеокарте nvidia

    не работает вывод на нвидии?

    покажите содержимое
    /var/log/Xorg.0.log

    и вывод команды
    lsmod|grep nvidia

  5. #5

    Default Re: Не запускается гуй на видеокарте nvidia

    При открытии окна nvidia-settings явно требует запустить nvidia-xconfig.
    Вывод lsmod:
    Code:
    nvidia_drm             57344  0 
    nvidia_modeset        790528  1 nvidia_drm
    nvidia_uvm            798720  0 
    nvidia              11960320  2 nvidia_modeset,nvidia_uvm
    drm_kms_helper        155648  2 i915,nvidia_drm
    drm                   393216  4 i915,drm_kms_helper,nvidia_drm
    Содержание файла Xorg.0.log:
    Code:
    [    27.175] 
    X.Org X Server 1.18.3
    Release Date: 2016-04-04
    [    27.175] X Protocol Version 11, Revision 0
    [    27.175] Build Operating System: openSUSE SUSE LINUX
    [    27.175] Current Operating System: Linux linux-utxo 4.4.27-2-default #1 SMP Thu Nov 3 14:59:54 UTC 2016 (5c21e7c) x86_64
    [    27.175] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-4.4.27-2-default root=UUID=0ac0347e-3453-4079-a8d1-25721f6baa58
    [    27.175] Build Date: 18 October 2016  08:58:39PM
    [    27.175]  
    [    27.175] Current version of pixman: 0.34.0
    [    27.175]     Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
    [    27.175] Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
    [    27.175] (==) Log file: "/var/log/Xorg.0.log", Time: Mon Jan  9 15:44:14 2017
    [    27.177] (==) Using config file: "/etc/X11/xorg.conf"
    [    27.177] (==) Using config directory: "/etc/X11/xorg.conf.d"
    [    27.177] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
    [    27.183] (==) ServerLayout "Layout0"
    [    27.183] (**) |-->Screen "Screen0" (0)
    [    27.183] (**) |   |-->Monitor "Monitor0"
    [    27.183] (**) |   |-->Device "Device0"
    [    27.183] (**) |-->Input Device "Keyboard0"
    [    27.183] (**) |-->Input Device "Mouse0"
    [    27.183] (==) Automatically adding devices
    [    27.183] (==) Automatically enabling devices
    [    27.183] (==) Automatically adding GPU devices
    [    27.183] (==) Max clients allowed: 256, resource mask: 0x1fffff
    [    27.202] (WW) The directory "/usr/share/fonts/misc/sgi" does not exist.
    [    27.202]     Entry deleted from font path.
    [    27.203] (==) FontPath set to:
        /usr/share/fonts/misc:unscaled,
        /usr/share/fonts/Type1/,
        /usr/share/fonts/100dpi:unscaled,
        /usr/share/fonts/75dpi:unscaled,
        /usr/share/fonts/ghostscript/,
        /usr/share/fonts/cyrillic:unscaled,
        /usr/share/fonts/truetype/,
        built-ins
    [    27.203] (==) ModulePath set to "/usr/lib64/xorg/modules"
    [    27.203] (**) Extension "XFree86-DGA" is disabled
    [    27.203] (WW) Hotplugging is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.
    [    27.203] (WW) Disabling Keyboard0
    [    27.203] (WW) Disabling Mouse0
    [    27.203] (II) Loader magic: 0x80fce0
    [    27.203] (II) Module ABI versions:
    [    27.203]     X.Org ANSI C Emulation: 0.4
    [    27.203]     X.Org Video Driver: 20.0
    [    27.203]     X.Org XInput driver : 22.1
    [    27.203]     X.Org Server Extension : 9.0
    [    27.206] (++) using VT number 7
    
    [    27.206] (II) systemd-logind: logind integration requires -keeptty and -keeptty was not provided, disabling logind integration
    [    27.208] (II) xfree86: Adding drm device (/dev/dri/card0)
    [    27.209] (II) xfree86: Adding drm device (/dev/dri/card1)
    [    27.211] (--) PCI:*(0:0:2:0) 8086:22b1:17aa:3801 rev 33, Mem @ 0x92000000/16777216, 0xa0000000/268435456, I/O @ 0x00003000/64
    [    27.211] (--) PCI: (0:1:0:0) 10de:1299:17aa:3801 rev 161, Mem @ 0x93000000/16777216, 0x80000000/268435456, 0x90000000/33554432, I/O @ 0x00002000/128, BIOS @ 0x????????/524288
    [    27.211] (II) LoadModule: "glx"
    [    27.213] (II) Loading /usr/lib64/xorg/modules/extensions/libglx.so
    [    27.234] (II) Module glx: vendor="X.Org Foundation"
    [    27.234]     compiled for 1.18.3, module version = 1.0.0
    [    27.234]     ABI class: X.Org Server Extension, version 9.0
    [    27.234] (==) AIGLX enabled
    [    27.234] (II) LoadModule: "nvidia"
    [    27.235] (II) Loading /usr/lib64/xorg/modules/drivers/nvidia_drv.so
    [    27.290] (II) Module nvidia: vendor="NVIDIA Corporation"
    [    27.290]     compiled for 4.0.2, module version = 1.0.0
    [    27.290]     Module class: X.Org Video Driver
    [    27.308] (II) NVIDIA dlloader X Driver  375.26  Thu Dec  8 17:37:15 PST 2016
    [    27.308] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
    [    27.308] (EE) No devices detected.
    [    27.308] (EE) 
    Fatal server error:
    [    27.308] (EE) no screens found(EE) 
    [    27.308] (EE) 
    Please consult the The X.Org Foundation support 
         at http://wiki.x.org
     for help. 
    [    27.308] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
    [    27.308] (EE)
    Обычно на это отвечают: "Вот же у вас ясно написано..." Увы, "no devices detected" объясняет не очень много 'sorry'

  6. #6
    Join Date
    Jan 2011
    Location
    Vladivostok
    Posts
    634

    Default Re: Не запускается гуй на видеокарте nvidia

    хм, покажите вывод
    lspci

  7. #7

    Default Re: Не запускается гуй на видеокарте nvidia

    Code:
    00:00.0 Host bridge: Intel Corporation Device 2280 (rev 21)00:02.0 VGA compatible controller: Intel Corporation Device 22b1 (rev 21)
    00:13.0 SATA controller: Intel Corporation Device 22a3 (rev 21)
    00:14.0 USB controller: Intel Corporation Device 22b5 (rev 21)
    00:1a.0 Encryption controller: Intel Corporation Device 2298 (rev 21)
    00:1b.0 Audio device: Intel Corporation Device 2284 (rev 21)
    00:1c.0 PCI bridge: Intel Corporation Device 22c8 (rev 21)
    00:1c.1 PCI bridge: Intel Corporation Device 22ca (rev 21)
    00:1c.2 PCI bridge: Intel Corporation Device 22cc (rev 21)
    00:1c.3 PCI bridge: Intel Corporation Device 22ce (rev 21)
    00:1f.0 ISA bridge: Intel Corporation Device 229c (rev 21)
    00:1f.3 SMBus: Intel Corporation Device 2292 (rev 21)
    01:00.0 3D controller: NVIDIA Corporation GK208M [GeForce 920M] (rev a1)
    02:00.0 Network controller: Qualcomm Atheros QCA9565 / AR9565 Wireless Network Adapter (rev 01)
    03:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 15)
    04:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. RTS5229 PCI Express Card Reader (rev 01)

  8. #8
    Join Date
    Jan 2011
    Location
    Vladivostok
    Posts
    634

    Default Re: Не запускается гуй на видеокарте nvidia

    ёпрст, так у вас ноут с гибридной графикой?
    если так, то у меня с таким опыта нет, знаю, что можно юзать bumblebee с проприетарным драйвером и prime с nouveau

    http://en.opensuse.org/SDB:NVIDIA_Bumblebee
    https://www.google.ru/search?q=suse+prime

  9. #9

    Default Re: Не запускается гуй на видеокарте nvidia

    Ну да.
    Я думал, что слова "на интегрированной карте intel всё запускается корректно" означают именно это.

  10. #10
    Join Date
    Jan 2011
    Location
    Vladivostok
    Posts
    634

    Default Re: Не запускается гуй на видеокарте nvidia

    да не совсем, на обычных компах бортовые видюхи - скорее правило, чем исключение, ну да ладно...
    а в биосе можно переключать видюхи?

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •