Page 1 of 4 123 ... LastLast
Results 1 to 10 of 33

Thread: 42.2 fails to start KDE

  1. #1
    Join Date
    Aug 2008
    Location
    Mexico and Sweden
    Posts
    1,288

    Default 42.2 fails to start KDE

    After a 42.2 upgrade from 42.1 that went smoothly the startup fails with the error on a text screen...

    Code:
    sddm[1166]:segfault at 0 ip(long number) sp(long number) erro 4 in libQt5core.so.6.1
    ...and after a reboot...

    Code:
    sddm[1210] segfault at 780 ip(long number) sp(long number) error 14 in sddm
    I didn't think the ip and sp numbers were significant to a solution. If needed I will copy them. I can still open text consoles and log in but startx fails.

    Thanks in advance

  2. #2
    Join Date
    Sep 2008
    Posts
    2,997

    Default Re: 42.2 fails to start KDE

    what hardware and which repo's?

  3. #3
    Join Date
    Aug 2008
    Location
    Mexico and Sweden
    Posts
    1,288

    Default Re: 42.2 fails to start KDE

    Quote Originally Posted by I_A View Post
    what hardware and which repo's?
    GeForce 6100 nForce 430

    Code:
    # | Alias                             | Name                              | Enabled | GPG Check | Refresh--+-----------------------------------+-----------------------------------+---------+-----------+--------
    1 | Jacobs                            | PACKMAN-Jacobs                    | No      | ----      | No     
    2 | download.nvidia.com-leap          | nVidia Graphics Drivers           | No      | ----      | No     
    3 | http-download.nvidia.com-511e98f1 | nVidia Graphics Drivers           | No      | ----      | Yes    
    4 | http-opensuse-guide.org-6b0c11f1  | libdvdcss repository              | No      | ----      | No     
    5 | http-packman.inode.at-6dad5200    | Packman Repository                | No      | ----      | Yes    
    6 | repo-non-oss                      | openSUSE-Leap-42.2-Non-Oss        | Yes     | (r ) Yes  | Yes    
    7 | repo-oss                          | openSUSE-Leap-42.2-Oss            | Yes     | (r ) Yes  | Yes    
    8 | repo-update                       | openSUSE-Leap-42.2-Update         | Yes     | (r ) Yes  | Yes    
    9 | repo-update-non-oss               | openSUSE-Leap-42.2-Update-Non-Oss | Yes     | (r ) Yes  | Yes
    And here is some of the Xorg.log, and I wonder why it's trying to load an Nvidia module. Doesn't the update force a switch to nouveau? Or do I need to rerun the Nvidia *run file?

    Code:
    [   364.115] (==) AIGLX enabled[   364.115] (II) LoadModule: "nvidia"
    [   364.116] (WW) Warning, couldn't open module nvidia
    [   364.116] (II) UnloadModule: "nvidia"
    [   364.116] (II) Unloading nvidia
    [   364.116] (EE) Failed to load module "nvidia" (module does not exist, 0)
    [   364.116] (EE) No drivers available.
    [   364.116] (EE) 
    Fatal server error:
    [   364.116] (EE) no screens found(EE) 
    [   364.116] (EE) 
    Please consult the The X.Org Foundation support 
         at http://wiki.x.org
     for help. 
    [   364.116] (EE) Please also check the log file at "/home/ion/.local/share/xorg/Xorg.0.log" for additional information.
    [   364.116] (EE)

  4. #4
    Join Date
    Sep 2008
    Posts
    2,997

    Default Re: 42.2 fails to start KDE

    you have the nvidia repo but it's disabled did you install the driver and then disable the repo?
    that's a bad idea because after every kernel update we get a driver update re-enable the nvidia repo and try to do an update (you can do it in text mode)
    Code:
    zypper mr -e -rk 2
    zypper ref
    zypper up
    also post your repo's with the -d switch so we can see the url's as you seam to have 2 nvidia repos and reoo #2 has autorefresh disabled this is a bad idea as you won't get updates
    Code:
    zypper lr -d
    did you install nvidia the hard way?
    in that case you need to reinstall it after every kernel update
    if you are nor sure if you have installed any nvidia packages try running this
    Code:
    zypper se -si nvidia
    that searches for installed only packages with nvidia in their name

  5. #5
    Join Date
    Aug 2008
    Location
    Mexico and Sweden
    Posts
    1,288

    Default Re: 42.2 fails to start KDE

    Quote Originally Posted by I_A View Post
    you have the nvidia repo but it's disabled did you install the driver and then disable the repo?
    that's a bad idea because after every kernel update we get a driver update re-enable the nvidia repo and try to do an update (you can do it in text mode)
    Code:
    zypper mr -e -rk 2
    zypper ref
    zypper up
    also post your repo's with the -d switch so we can see the url's as you seam to have 2 nvidia repos and reoo #2 has autorefresh disabled this is a bad idea as you won't get updates
    Code:
    zypper lr -d
    did you install nvidia the hard way?
    in that case you need to reinstall it after every kernel update
    if you are nor sure if you have installed any nvidia packages try running this
    Code:
    zypper se -si nvidia
    that searches for installed only packages with nvidia in their name
    I was working with instructions in http://www.2daygeek.com/how-to-upgra...e-leap-42-2/2/ as they were the clearest I could find. It instructed me to disable all repos except the four for 42.2 which I did. I assumed that the upgrade would default to the nouveau driver so it made sense to disable the Nvidia repos.

    And yes I installed the Nvidia driver the hard way as it has to be an earlier version than current. And yes I disabled the repo as updating to a newer version does not work.

    Running zypper se -si nvidia produced...

    Code:
    Loading repository data...
    Reading installed packages...
    No matching items found.
    Are you suggesting I should just re-run the Nvidia *.run file again. But if, as the above zypper reports there is no Nvidia item installed what is the driver it is trying to use? Not nouveau?

    Sorry it's late here and I have to keep rebooting to a different drive to connect with the forum. It's time consuming. I will answer the other questions tomorrow.

  6. #6
    Join Date
    Sep 2008
    Posts
    2,997

    Default Re: 42.2 fails to start KDE

    you need to reinstall the driver the hard way
    just re-run the run file
    I haven't seen that site but the repo way is much simpler to maintain, we get updates automatically whenever the kernel is updated the nvidia driver is updated, one of the reasons I stay with LEAP is the fact that TW does not have an nvidia repo and I don't want to mess with the run file

  7. #7
    Join Date
    Aug 2008
    Location
    Mexico and Sweden
    Posts
    1,288

    Default Re: 42.2 fails to start KDE

    Quote Originally Posted by I_A View Post
    you need to reinstall the driver the hard way
    just re-run the run file
    I haven't seen that site but the repo way is much simpler to maintain, we get updates automatically whenever the kernel is updated the nvidia driver is updated, one of the reasons I stay with LEAP is the fact that TW does not have an nvidia repo and I don't want to mess with the run file
    Yes but the updated Nvidia drivers do NOT work with my card. Not with 13.2 not with 42.1. That's why I do it the hard way.I'll run the *run file tomorrow and report.

  8. #8
    Join Date
    Sep 2008
    Posts
    2,997

    Default Re: 42.2 fails to start KDE

    it's the same driver
    what card do you have as the issues wore not the driver but X
    my old 5200 worked on 13.1 but not 13.2 the reason wasn't the driver or kernel but the X server was updated
    if your card is that old I'd suggest you install openbox and openbox-kde then use plasma5 with openbox not with kwin5
    it will be faster and you can use noveaou and won't mess with the propitiatory driver
    http://software.opensuse.org/package/openbox
    http://software.opensuse.org/package/openbox-kde

    there is a bug with http://software.opensuse.org/ it doesn't show the packages from the 42.2 oss repo someone should report it at bugzilla I'm too lazy to do it
    my point was even if the package is not shown for 42.2 it's there and you can install it with yast or zypper

  9. #9
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    3,981

    Default AW: 42.2 fails to start KDE

    there is a bug with http://software.opensuse.org/ it doesn't show the packages from the 42.2 oss repo someone should report it at bugzilla I'm too lazy to do it
    https://bugzilla.opensuse.org/show_bug.cgi?id=1011485

  10. #10
    Join Date
    Aug 2008
    Location
    Mexico and Sweden
    Posts
    1,288

    Default Re: 42.2 fails to start KDE

    [QUOTE=I_A;2802770]you need to reinstall the driver the hard way
    just re-run the run file[/QUOTE$]

    I blacklisted nouveau, ran mkinitrd and rebooted. I executed the *run file and it errored out with "Unable to load the kernel module 'nvidia.ko" with many possibilities for the cause. I'm really sorry I started this upgrade as I now have a useless box. Well, text only.

Page 1 of 4 123 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •