Results 1 to 8 of 8

Thread: Problems on Bumblebee in Nvidia driver in Optimus notebook

  1. #1

    Default Problems on Bumblebee in Nvidia driver in Optimus notebook

    Hi,
    As I follow the instructions from https://forums.opensuse.org/showthre...timus-notebook
    I run these two commands. But the messages have shown that "Failed to execute operation: No such file or directory"
    sudo systemctl enable bumblebeed.service
    sudo systemctl start bumblebeed.service

    Can anyone help me on this? Thanks

    Chris

  2. #2
    Join Date
    Oct 2014
    Location
    Italy
    Posts
    1,674

    Default Re: Problems on Bumblebee in Nvidia driver in Optimus notebook

    Hi, apparently the bumblebee daemon has not been installed or started for some reason. Maybe a reboot is needed.
    You may check with Yast Services manager, a line reading "bumblebeed" should be there; if so, you can enable and start the bumblebeed service from there.
    Otherwise, something might be wrong in the guide you followed or you might have done something wrong.

    PS: please be aware that double posting is not welcomed here; consider asking an admin to close your other thread.
    Main: Leap 15 Gnome on i7 4720HQ + Geforce GTX960M
    Test: Leap 42.3 (& others) on Core2Duo + GM965

  3. #3

    Default Re: Problems on Bumblebee in Nvidia driver in Optimus notebook

    Quote Originally Posted by OrsoBruno View Post
    Hi, apparently the bumblebee daemon has not been installed or started for some reason. Maybe a reboot is needed.
    You may check with Yast Services manager, a line reading "bumblebeed" should be there; if so, you can enable and start the bumblebeed service from there.
    Otherwise, something might be wrong in the guide you followed or you might have done something wrong.

    PS: please be aware that double posting is not welcomed here; consider asking an admin to close your other thread.
    I have asked the admin to delete the thread in Application session. Sorry about this.

    You suggestion works, but after rebooting the machine, it can not get into X-window mode and the screen froze. How do I fix this problem? Thanks.

  4. #4
    Join Date
    Oct 2014
    Location
    Italy
    Posts
    1,674

    Default Re: Problems on Bumblebee in Nvidia driver in Optimus notebook

    Quote Originally Posted by cymed2 View Post
    I have asked the admin to delete the thread in Application session. Sorry about this.

    You suggestion works, but after rebooting the machine, it can not get into X-window mode and the screen froze. How do I fix this problem? Thanks.
    Please be aware that after installation of nvidia-bumblebee the system needs as long as 3 to 5 minutes to build and install the nvidia kernel modules, during which the system might appear as "frozen".
    Allow at least that time after reboot; if that doesn't work, try booting to text mode by just adding "3" to the boot command line (press "E" at the grub screen and look for a line beginning with "linux" or "linuxefi").
    Login, then try "dmesg | less" and see if there is any clue about the reason for not starting X and write back if you need more assistance.
    Main: Leap 15 Gnome on i7 4720HQ + Geforce GTX960M
    Test: Leap 42.3 (& others) on Core2Duo + GM965

  5. #5

    Default Re: Problems on Bumblebee in Nvidia driver in Optimus notebook

    Quote Originally Posted by OrsoBruno View Post
    Please be aware that after installation of nvidia-bumblebee the system needs as long as 3 to 5 minutes to build and install the nvidia kernel modules, during which the system might appear as "frozen".
    Allow at least that time after reboot; if that doesn't work, try booting to text mode by just adding "3" to the boot command line (press "E" at the grub screen and look for a line beginning with "linux" or "linuxefi").
    Login, then try "dmesg | less" and see if there is any clue about the reason for not starting X and write back if you need more assistance.
    After staring and enabling dkms, my laptop can log in in X-window mode and bumblebee is running. For example, "optirun glxspheres" shows several concentric spheres rotating. But the screen has frozen easily. Is something wrong with driver? What can I do? Thanks.

  6. #6
    Join Date
    Oct 2014
    Location
    Italy
    Posts
    1,674

    Default Re: Problems on Bumblebee in Nvidia driver in Optimus notebook

    Quote Originally Posted by cymed2 View Post
    After staring and enabling dkms, my laptop can log in in X-window mode and bumblebee is running. For example, "optirun glxspheres" shows several concentric spheres rotating.
    Nice to read that, so bumblebee is definitely working.

    But the screen has frozen easily. Is something wrong with driver? What can I do? Thanks.
    What does exactly mean "the screen has frozen easily"? What desktop are you using? What HW are you running on?
    Generally speaking, with bumblebee the Nvidia driver is not in use unless explicitly invoked by the optirun or primusrun commands, so it is very unlikely that it is involved in freezing the base X server: please check /var/log/Xorg.0.log for clues.
    If, for instance, the spheres window freezes easily, check /var/log/Xorg.8.log for clues, since bumblebee starts an auxiliary Xserver (:8) to run on the Nvidia GPU.

    Also, if you are using KDE, there are still some instances of the desktop freezing on some HW, but this is generally independent of bumblebee.
    And there are some Nvidia chips that might require tweaking the default configuration: please post the result of the following command between [CODE] tags (click the # button while editing your post in the web interface):
    Code:
    sudo lspci -nnk |grep -e VGA -e NVIDIA
    Main: Leap 15 Gnome on i7 4720HQ + Geforce GTX960M
    Test: Leap 42.3 (& others) on Core2Duo + GM965

  7. #7

    Default Re: Problems on Bumblebee in Nvidia driver in Optimus notebook

    Quote Originally Posted by OrsoBruno View Post
    Nice to read that, so bumblebee is definitely working.



    What does exactly mean "the screen has frozen easily"? What desktop are you using? What HW are you running on?
    Generally speaking, with bumblebee the Nvidia driver is not in use unless explicitly invoked by the optirun or primusrun commands, so it is very unlikely that it is involved in freezing the base X server: please check /var/log/Xorg.0.log for clues.
    If, for instance, the spheres window freezes easily, check /var/log/Xorg.8.log for clues, since bumblebee starts an auxiliary Xserver (:8) to run on the Nvidia GPU.

    Also, if you are using KDE, there are still some instances of the desktop freezing on some HW, but this is generally independent of bumblebee.
    And there are some Nvidia chips that might require tweaking the default configuration: please post the result of the following command between [CODE] tags (click the # button while editing your post in the web interface):
    Code:
    sudo lspci -nnk |grep -e VGA -e NVIDIA
    After reinstalling Leap 42.2 and installing Bumblebee and CUDA 8.0 by following the instructions from DB:NVIDIA Bumblebee.
    Since then, the KDE has been stable. Below is my laptop information after sudo lspci -nnk |grep -e VGA -e NVIDIA
    00:02.0 VGA compatible controller [0300]: Intel Corporation Skylake Integrated Graphics [8086:191b] (rev 06)
    01:00.0 3D controller [0302]: NVIDIA Corporation GM107M [GeForce GTX 960M] [10de:139b] (rev ff)

  8. #8
    Join Date
    Oct 2014
    Location
    Italy
    Posts
    1,674

    Default Re: Problems on Bumblebee in Nvidia driver in Optimus notebook

    Quote Originally Posted by cymed2 View Post
    After reinstalling Leap 42.2 and installing Bumblebee and CUDA 8.0 by following the instructions from DB:NVIDIA Bumblebee.
    Since then, the KDE has been stable. Below is my laptop information after sudo lspci -nnk |grep -e VGA -e NVIDIA
    00:02.0 VGA compatible controller [0300]: Intel Corporation Skylake Integrated Graphics [8086:191b] (rev 06)
    01:00.0 3D controller [0302]: NVIDIA Corporation GM107M [GeForce GTX 960M] [10de:139b] (rev ff)
    OK, as long as the system is stable don't touch anything (as the Wise Man said, "If it ain't broke, don't fix it!").
    I had no problems at all so far on the GM107M [GeForce GTX 960M] with current proprietary drivers, so definitely don't touch anything there.
    I did not install or use the full CUDA package, so cannot say anything related; but nvidia-compute (AKA OpenCL) works fine here.
    Just in case you notice desktop graphics instability or freezes, be aware that with Bumblebee the desktop runs on the Intel Corporation Skylake Integrated Graphics.
    Some of those Skylake integrated GPUs require the i915.preliminary_hw_support=1 boot parameter to run smoothly on 4.4.x kernels.
    This is just in case of trouble, if your kernel is up to date to 4.4.36-8-default and you don't have significant freezes anymore, assume that your system is OK as it is.
    Be aware that there are still some problems with KDE that might be independent of HW: if you meet an occasional hiccup or freeze, please ask in the forums but try to be very specific as to what you did, what you witnessed etc.

    Meanwhile, have fun with your new system!
    Main: Leap 15 Gnome on i7 4720HQ + Geforce GTX960M
    Test: Leap 42.3 (& others) on Core2Duo + GM965

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •