Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Login screen resolution

  1. #1

    Unhappy Login screen resolution

    Hello and a happy new year to all!

    I've a fresh installation of Tumbleweed on a Dell XPS 13". The laptop has a wonderful high resolution monitor of 3200 x 1800. As everything was initially appearing tiny at the beginning, I scaled the desktop with a factor of x2 and now everything looks great. However, my login screen remains tiny. I changed the options in the bootloader with Yast and I scaled my splash screen for grub2 to 1600x1200 but still I haven't found an option to scale just the login screen. Any ideas?

    Info
    ----
    KDE Plasma: 5.8.4
    KDE Framework: 5.29.0
    Qt: 5.7.1
    Kernel: 4.9.0-2-default

  2. #2

    Default Re: Login screen resolution

    You don't mention the Display Manager your using, but assuming its the default sddm, then within /etc/sddm.conf file:
    • you could set a script (containing an xrandr command for the settings you want) to be run or
    • you could set the DPI in the server arguments to whatever you want


    see man sddm.conf for more info

  3. #3
    Join Date
    Feb 2016
    Location
    Berlin
    Posts
    354

    Default Re: Login screen resolution

    i have same screen:
    GRUB_GFXPAYLOAD_LINUX=keep in grub (cant remember what this does now!)
    ServerArguments=-dpi 180 in sddm
    tip: check your tty fonts <ctrl-alt> F1 etc - if they are readable

  4. #4

    Default Re: Login screen resolution

    Quote Originally Posted by ndc33 View Post
    GRUB_GFXPAYLOAD_LINUX=keep in grub (cant remember what this does now!)
    This is a setting for the video mode used for the console framebuffer (maybe only applicable to the kernel vesafb driver??) ... its supposed to replace the vga= boot option.

    That won't carry over to the DM greeter screen though --> the greeter runs atop a display server (i.e. X is this case), so you need to config the display server's res.

  5. #5

    Default Re: Login screen resolution

    Quote Originally Posted by Tyler_K View Post
    You don't mention the Display Manager your using, but assuming its the default sddm, then within /etc/sddm.conf file:
    • you could set a script (containing an xrandr command for the settings you want) to be run or
    • you could set the DPI in the server arguments to whatever you want


    see man sddm.conf for more info
    Apologies, yes it's sddm. I had tried to set some dpi settings in the past but I messed my fonts globally. I'm a newbie and I had to reinstall everything since I couldn't get back to the resolution I had. Could you help me out with the exact setting? My current sddm.conf contains:

    Code:
    [Theme]
    Current=breeze-openSUSE
    CursorTheme=breeze_cursors
    
    [XDisplay]
    ServerPath=/usr/bin/X
    SessionCommand=/etc/X11/xdm/Xsession
    DisplayCommand=/etc/X11/xdm/Xsetup
    MinimumVT=7

  6. #6
    Join Date
    Feb 2016
    Location
    Berlin
    Posts
    354

    Default Re: Login screen resolution

    [Theme]
    Current=breeze-openSUSE
    CursorTheme=breeze_cursors


    [XDisplay]
    ServerPath=/usr/bin/X
    SessionCommand=/etc/X11/xdm/Xsession
    DisplayCommand=/etc/X11/xdm/Xsetup
    ServerArguments=-dpi 180
    MinimumVT=7

    [as stated earlier]

  7. #7

    Default Re: Login screen resolution

    Quote Originally Posted by ndc33 View Post
    [Theme]
    Current=breeze-openSUSE
    CursorTheme=breeze_cursors


    [XDisplay]
    ServerPath=/usr/bin/X
    SessionCommand=/etc/X11/xdm/Xsession
    DisplayCommand=/etc/X11/xdm/Xsetup
    ServerArguments=-dpi 180
    MinimumVT=7

    [as stated earlier]
    If I go to Yast Settings -> Fonts the value for Force fonts DPI is set to 192. Does your setting change the value globally or just the login screen?And if something is messed up how do I revert to previous settings?

  8. #8

    Default Re: Login screen resolution

    Quote Originally Posted by dimk1 View Post
    Does your setting change the value globally or just the login screen?
    Its global -- your passing an argument to the display server.

    However, when you log into a user session, your desktop (via the settings YOU select) may introduce its own configuration.

    And if something is messed up how do I revert to previous settings?
    umm, revert the same change you just made ??? (i.e. delete it or comment it out)

    Quote Originally Posted by dimk1 View Post
    If I go to Yast Settings -> Fonts the value for Force fonts DPI is set to 192.
    I'd imagine that's the global setting for FONTS on the display server ... but these aren't the droids your looking for

  9. #9

    Default [SOLVED] Re: Login screen resolution

    Quote Originally Posted by ndc33 View Post
    [Theme]
    Current=breeze-openSUSE
    CursorTheme=breeze_cursors


    [XDisplay]
    ServerPath=/usr/bin/X
    SessionCommand=/etc/X11/xdm/Xsession
    DisplayCommand=/etc/X11/xdm/Xsetup
    ServerArguments=-dpi 180
    MinimumVT=7

    [as stated earlier]
    That did the trick, thanks!

  10. #10
    Join Date
    Jun 2008
    Location
    Como, Italy
    Posts
    2

    Unhappy Re: Login screen resolution

    Tried, but DPI scaling doesn't do the magic.


    Problem is that SDDM insists using 3840x2160 screen size with very poor pictures.


    Log file: https://pastebin.com/6bw67EQV Monitor data: https://pastebin.com/b9U51WET


    How can I configure SDDM to start in 1920x1080? I tried to set GRUB_GFXMODE in /etc/default/grub with no result and now I need some help in changing /etc/X11/xorg.conf.d/50-monitor.conf which contain the #Section "Monitor" of X11 configuration.


    Someone can send me a working example of X11 configuration with more than 1 mode listed? The example found so far contains only one resolution.


    openSUSE 42.3 (x86_64)
    VERSION = 42.3
    CODENAME = Malachite

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •