Page 1 of 3 123 LastLast
Results 1 to 10 of 26

Thread: Could not get USB reconised_mucked up (KDE)

  1. #1

    Default Could not get USB reconised_mucked up (KDE)

    Hello All
    The other day I wanted to check my camera's photos and for a while I could not get it(USB) recognized til I figured that I need to go through " Configure Desktop". While trying I think I added 'mount' to a partition(Mint). Anyway I didn't need to and now I have to confirm the mount with password every time I boot. Would someone be able to tell me where I can turn this off(unmount)? Thanks

  2. #2
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,760

    Default Re: Could not get USB reconised_mucked up (KDE)

    Did you add it to mount at boot?? is it encrypted???

    Really need more info
    Like when do you see this message???

    look in /etc/fstab and see if that is were it is added.

  3. #3
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,754
    Blog Entries
    3

    Default Re: Could not get USB reconised_mucked up (KDE)

    My experience was that the KDE device notifier did not work at all well in 42.1. It is working fine in 42.2.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  4. #4
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,549
    Blog Entries
    1

    Default Re: Could not get USB reconised_mucked up (KDE)

    The device you show in the image appears to be reported as an internal SSD (Micron M600 device, /dev/sda2), so that would explain why root privileges (via polkit) are needed to access it. It is not a removable device as such, but check that it is not somehow listed in System Settings > Removable Devices

  5. #5

    Default Re: Could not get USB reconised_mucked up (KDE)

    Quote Originally Posted by deano_ferrari View Post
    The device you show in the image appears to be reported as an internal SSD (Micron M600 device, /dev/sda2), so that would explain why root privileges (via polkit) are needed to access it. It is not a removable device as such, but check that it is not somehow listed in System Settings > Removable Devices
    @ deano_ferrari;2806415, Thanks
    Look here, nothing there. I just can't remember where I changed to mount it at boot. It should've been obvious that it wasn't the right thing to do.

  6. #6

    Default Re: Could not get USB reconised_mucked up (KDE)

    Quote Originally Posted by gogalthorp View Post
    Did you add it to mount at boot?? is it encrypted???

    Really need more info
    Like when do you see this message???

    look in /etc/fstab and see if that is were it is added.
    thanks@ gogalthorp;2806401]
    I must've added it to mount at boot. Thinking that that would help. It wasn't the right drive anyway . Don't think it is encrypted.
    I see the message when the desktop is loaded, after boot.

    Code:
    UUID=fd0aaaab-fb1b-4c31-9bf2-a29427595e95 swap swap defaults 0 0
    UUID=99bb14d9-f816-47a9-8b0a-7699da005b87 / btrfs defaults 0 0
    UUID=99bb14d9-f816-47a9-8b0a-7699da005b87 /boot/grub2/i386-pc btrfs subvol=@/boot/grub2/i386-pc 0 0
    UUID=99bb14d9-f816-47a9-8b0a-7699da005b87 /boot/grub2/x86_64-efi btrfs subvol=@/boot/grub2/x86_64-efi 0 0
    UUID=99bb14d9-f816-47a9-8b0a-7699da005b87 /opt btrfs subvol=@/opt 0 0
    UUID=99bb14d9-f816-47a9-8b0a-7699da005b87 /srv btrfs subvol=@/srv 0 0
    UUID=99bb14d9-f816-47a9-8b0a-7699da005b87 /tmp btrfs subvol=@/tmp 0 0
    UUID=99bb14d9-f816-47a9-8b0a-7699da005b87 /usr/local btrfs subvol=@/usr/local 0 0
    UUID=99bb14d9-f816-47a9-8b0a-7699da005b87 /var/crash btrfs subvol=@/var/crash 0 0
    UUID=99bb14d9-f816-47a9-8b0a-7699da005b87 /var/lib/libvirt/images btrfs subvol=@/var/lib/libvirt/images 0 0
    UUID=99bb14d9-f816-47a9-8b0a-7699da005b87 /var/lib/mailman btrfs subvol=@/var/lib/mailman 0 0
    UUID=99bb14d9-f816-47a9-8b0a-7699da005b87 /var/lib/mariadb btrfs subvol=@/var/lib/mariadb 0 0
    UUID=99bb14d9-f816-47a9-8b0a-7699da005b87 /var/lib/mysql btrfs subvol=@/var/lib/mysql 0 0
    UUID=99bb14d9-f816-47a9-8b0a-7699da005b87 /var/lib/named btrfs subvol=@/var/lib/named 0 0
    UUID=99bb14d9-f816-47a9-8b0a-7699da005b87 /var/lib/pgsql btrfs subvol=@/var/lib/pgsql 0 0
    UUID=99bb14d9-f816-47a9-8b0a-7699da005b87 /var/log btrfs subvol=@/var/log 0 0
    UUID=99bb14d9-f816-47a9-8b0a-7699da005b87 /var/opt btrfs subvol=@/var/opt 0 0
    UUID=99bb14d9-f816-47a9-8b0a-7699da005b87 /var/spool btrfs subvol=@/var/spool 0 0
    UUID=99bb14d9-f816-47a9-8b0a-7699da005b87 /var/tmp btrfs subvol=@/var/tmp 0 0
    UUID=99bb14d9-f816-47a9-8b0a-7699da005b87 /.snapshots btrfs subvol=@/.snapshots 0 0
    UUID=34C6-E029       /boot/efi            vfat       umask=0002,utf8=true  0 0
    UUID=38b1d867-7fd6-4c2a-8e53-c6dba24d97af /home                xfs        defaults              1 2

  7. #7
    Join Date
    Sep 2008
    Posts
    2,997

    Default Re: Could not get USB reconised_mucked up (KDE)

    that's not a real issue
    your device is recognized as an external hdd and root privileges are required to access it, you can use polkit to give all users write privileges to external partitions
    see
    https://forums.opensuse.org/showthre...75#post2805475
    that won't auto-mount the device but dolphin (or any other file manager) won't ask for root password when you do mount it

  8. #8
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,549
    Blog Entries
    1

    Default Re: Could not get USB reconised_mucked up (KDE)

    Quote Originally Posted by I_A View Post
    that's not a real issue
    your device is recognized as an external hdd and root privileges are required to access it, you can use polkit to give all users write privileges to external partitions
    see
    Yes, but as I pointed out ( and the OP now realises) the device concerned had nothing to do with the camera/external media.

  9. #9

    Default Re: Could not get USB reconised_mucked up (KDE)

    Update; By configuring, Application Manu-settings-configuring desktop- removable devices, untick "Enable automatic mounting of removable devices" I have been able to stop the popup request for password.
    It is not really removable media. It is the partition where Mint is. It means I cannot attach a usb without having to enter a password and/or undo the tick again.
    It feels it isn't quite right yet?

  10. #10
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,549
    Blog Entries
    1

    Default Re: Could not get USB reconised_mucked up (KDE)

    Quote Originally Posted by kiwig View Post
    Update; By configuring, Application Manu-settings-configuring desktop- removable devices, untick "Enable automatic mounting of removable devices" I have been able to stop the popup request for password.
    It is not really removable media. It is the partition where Mint is. It means I cannot attach a usb without having to enter a password and/or undo the tick again.
    It feels it isn't quite right yet?
    Yes, probably a bug report is required to get that fixed. Following a quick search, I did find a bug report describing similar behaviour here.

    Some users have found that they have a BIOS setting to enable/disable hot-plugging of certain storage devices which then causes them to be detected as removable or not.

    If you execute the following
    Code:
    udisksctl info -b /dev/sda2
    you'll probably get output showing that it is flagged as a removable device
    Code:
    MediaRemovable:                     true
    A udev rule targeting the problem device could be used to set the environment flag 'ENV{UDISKS_SYSTEM_INTERNAL}="1"', but better to get it fixed properly IMO.

    FWIW, I don't usually use "Enable automatic mounting of removable devices", but just use the notifier to mount external media when needed. I have Dolphin configured to show the devices available, so that can also be used to 'mount on demand'.

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •