Results 1 to 8 of 8

Thread: KDE Desktop Sharing

  1. #1
    Join Date
    Mar 2010
    Location
    Ontario, Canada
    Posts
    32

    Default KDE Desktop Sharing

    Some years ago, probably using OpenSuse 12.*, I was able to open KDE Desktop sharing (I'm very sure that is what it was), and allow a remote Windows computer to access my desktop. We did this several times actually.

    However, I'm trying to give a person access to my desktop - they on Windows using Tiger VNC Viewer - and while they are able to connect to my computer, all they can view is a login splash screen. That is all there is - there is no option to even login.

    I would think the expected behaviour would in fact be... desktop sharing and that is what I'm trying to achieve. Would anyone be able to explain how to configure KDE Desktop Sharing (Krfb) such that I give a remote computer the password and then accept the connection, that they would be able to view my desktop?

    I also see there is an option to automatically accept connections with a password; we tried that as well but still the same problem.

    The odd (to me) thing is that they can control my mouse cursor - I can see it moving, but they can see nothing but the green splash screen with the light bulb.

    Thanks so much!

  2. #2
    Join Date
    Mar 2010
    Location
    Ontario, Canada
    Posts
    32

    Default Re: KDE Desktop Sharing

    Quote Originally Posted by WeeHughie View Post
    However, I'm trying to give a person access to my desktop - they on Windows using Tiger VNC Viewer - and while they are able to connect to my computer, all they can view is a login splash screen. That is all there is - there is no option to even login.
    I should clarify - it's not the login splash screen, rather it is that green screen with the light bulb on the right hand side that appears AFTER normal logging in while the desktop is loading. So that is all that can be seen with a remote VNC connection, yet that remote VNC connection is able to move the mouse cursor around.

  3. #3
    Join Date
    Mar 2010
    Location
    Ontario, Canada
    Posts
    32

    Default Re: KDE Desktop Sharing

    Some further research indicates that in earlier versions of KDE, one could turn off Desktop Effects, but I see no option to do that in KDE Plasma or Plasma 5.

  4. #4
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    3,952

    Default AW: KDE Desktop Sharing

    Maybe try another Displaymanager:
    https://forums.opensuse.org/showthre...25#post2804025

  5. #5
    Join Date
    Mar 2010
    Location
    Ontario, Canada
    Posts
    32

    Default Re: AW: KDE Desktop Sharing

    Quote Originally Posted by Sauerland View Post
    Thanks for the suggestion - however, installed kdm - set displaymanager to kdm, rebooted into both Plasma and KDE Plasma - but still not working.

    Another suggestion was to try turning off Compositor in "Display & Monitor" settings. That has not helped.

    VNC connections still only see the green screen with the light bulb.

  6. #6
    Join Date
    Mar 2010
    Location
    Ontario, Canada
    Posts
    32

    Default Re: KDE Desktop Sharing

    Okay, on a hunch, I deleted the ~/.vnc directory and restarted Kfrb (KDE Desktop Sharing).

    That got me beyond the "green screen of death" that the remote client could only get to previously. So, a little bit closer but still not where it should be. Now, on the remote client, one of the open applications on the Desktop server can be seen. Clicking on any of the other open applications in the taskbar opens that app's window on the Desktop server, but cannot be seen on the remote client. In other words, the remote client can control the server Desktop, but can't see what it's actually doing.

  7. #7
    Join Date
    Mar 2010
    Location
    Ontario, Canada
    Posts
    32

    Default Re: KDE Desktop Sharing

    Ignore that last comment. Wrong thread. Just realized or would have removed it but can't seem to do that now.

  8. #8
    Join Date
    Mar 2010
    Location
    Ontario, Canada
    Posts
    32

    Default Re: KDE Desktop Sharing

    I am really fighting with this - and still cannot get desktop sharing working.

    With Krfb - I can connect to the remote OpenSuse box now that I have changed the Display Manager to kdm.

    On the client (viewer) machine, the screen is a bit messed up (probably need to adjust some settings as the monitor display sizes are quite different).

    On the client, I can control the mouse on the server.

    But all I can view is Konsole (which I have open on the Krfb server) even though it is not actually the open window on the server. On the Krfb server, Firefox is open, Konsole is minimized.

    I can use the mouse to click on open applications in the task bar, but I cannot see them open on the client. On the server, an application will open however (but it's the incorrect one - the mouse on the client clicks on say... Chrome, but on the server, the mouse is actually pointing at Kate). So Kate will open on the Krfb server but I cannot see that from the laptop running the viewer.

    The viewer (client) is running Tiger VNC Viewer.

    So, I decided to try vncviewer from the command line.

    So I stopped (killed) Krfb.

    Deleted ~/.vnc

    Ran vncviewer.

    It asked for a password. I provided a very simple password for testing.

    Now when I try to connect to the server running vncserver on OpenSuse, using Tiger VNC Viewer from Windows, I can connect, but get an error "password check failed!"

    But I absolutely know I am using the correct password - it is 7 characters and there is no way I am typing it incorrectly 10 times in a row from the remote client.

    In previous version of OpenSuse & KDE (some years ago), I had no problems at all with VNC using Krfb (and also, VNC as a client with KRDC).

    I've spent hours on this, Googling, experimenting - making sure I have the right packages installed... and I'm stumped.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •