Results 1 to 4 of 4

Thread: I don't know if TLP is working properly

  1. #1

    Default I don't know if TLP is working properly

    I installed TLP. After running
    Code:
    tlp-stat -s
    to see if it's working, I see the following lines at the bottom of the output:
    Code:
    Notice: tlp.service is not enabled -- invoke "systemctl enable tlp.service" to correct this!
    Notice: tlp-sleep.service is not enabled -- invoke "systemctl enable tlp-sleep.service" to correct this!
    Notice: systemd-rfkill.service is not masked -- invoke "systemctl mask systemd-rfkill.service" to correct this!
    What's going on? I've never seen this on different distros.

  2. #2
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    11,708
    Blog Entries
    2

    Default Re: I don't know if TLP is working properly

    Quote Originally Posted by 2k17user View Post
    I installed TLP. After running
    Code:
    tlp-stat -s
    to see if it's working, I see the following lines at the bottom of the output:
    Code:
    Notice: tlp.service is not enabled -- invoke "systemctl enable tlp.service" to correct this!
    Notice: tlp-sleep.service is not enabled -- invoke "systemctl enable tlp-sleep.service" to correct this!
    Notice: systemd-rfkill.service is not masked -- invoke "systemctl mask systemd-rfkill.service" to correct this!
    What's going on? I've never seen this on different distros.
    You're being told to configure the TLS service in a way that prevents it from being invoked during bootup (I don't know why this is, there must be a reason).

    Normally, because a systemd Unit file has been created, the app it controls (TLS in this case) can be started up even if it's not configured to be started up automatically on boot.

    If I were to wildly speculate, because you didn't invoke TLP using the systemd Unit file, something recognized that you invoked the executable directly so is instructing you that if this is what you regularly want to do, then do the described steps to prevent automatic starting.

    Maybe someone can come up with a better explanation...

    Speculating,
    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

  3. #3
    Join Date
    Feb 2016
    Location
    Berlin
    Posts
    357

    Default Re: I don't know if TLP is working properly

    quick check: install powertop - check when unplugged
    (tlp is a bit funny dosnt run itself as a daemon), if powertop shows not working, just enable.

  4. #4
    Join Date
    Nov 2014
    Location
    Argentina
    Posts
    111

    Default Re: I don't know if TLP is working properly

    Quote Originally Posted by 2k17user View Post
    I installed TLP. After running
    Code:
    tlp-stat -s
    to see if it's working, I see the following lines at the bottom of the output:
    Code:
    Notice: tlp.service is not enabled -- invoke "systemctl enable tlp.service" to correct this!
    Notice: tlp-sleep.service is not enabled -- invoke "systemctl enable tlp-sleep.service" to correct this!
    Notice: systemd-rfkill.service is not masked -- invoke "systemctl mask systemd-rfkill.service" to correct this!
    What's going on? I've never seen this on different distros.
    It seems that the tlp service is not enabled when installed.
    I did as tlp suggests:
    Code:
    systemctl enable tlp.service
    systemctl enable tlp-sleep.service
    systemctl mask systemd-rfkill.service
    systemctl mask systemd-rfkill.socket
    The addition of the last command is suggested here:
    https://github.com/linrunner/TLP/issues/166

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •