Page 2 of 2 FirstFirst 12
Results 11 to 18 of 18

Thread: Wireless cannot connect after dup to kernel 4.9.0-{1|2} yesterday

  1. #11

    Default Re: Wireless cannot connect after dup to kernel 4.9.0-{1|2} yesterday

    In case anyone else encounters this problem, here is some update.

    I find out the only option caused this problem is `fwslp`. I also notice that the original options cause a very large latency of my wireless connection (from output of `ping 192.168.1.1`). So replacing the original entry of,

    Code:
    options rtl8192ce ips=0 fwlps=0
    with,

    Code:
    options rtl8192ce fwlps=0
    could be much better.

    Or following options,

    Code:
    options rtl8192ce ips=1 fwlps=0 swlps=1
    will also work.

    CnZhx
    openSUSE Tumbleweed (usually the latest snapshot) w/ KDE Plasma 5

  2. #12

    Default Re: Wireless cannot connect after dup to kernel 4.9.0-{1|2} yesterday

    I am still experiencing a large latency (4~1500ms) and a high package loss(15~50%) which make my wireless connection barely usable. All these happen after the update of snapshot containing the 4.9.0 kernel. But I am not sure whether it is the kernel or the new NetworkManager 1.4.4 who causes these, or any package else.
    openSUSE Tumbleweed (usually the latest snapshot) w/ KDE Plasma 5

  3. #13

    Default Re: Wireless cannot connect after dup to kernel 4.9.0-{1|2} yesterday

    Quote Originally Posted by cnzhx View Post
    I am still experiencing a large latency (4~1500ms) and a high package loss(15~50%) which make my wireless connection barely usable. All these happen after the update of snapshot containing the 4.9.0 kernel. But I am not sure whether it is the kernel or the new NetworkManager 1.4.4 who causes these, or any package else.
    `kernel-default` seems to be the reason.

    I installed `kernel-default` ver 4.9.3 and ver 4.8.14 (the last good kernel for me) from here: https://software.opensuse.org/package/kernel-default

    `kernel-default` 4.9.3 won't solve my problem.

    `kernel-default` 4.8.14 makes my wireless connection return to previous perfect state. I would keep using this kernel-default if there were not a new problem with my VirtualBox. My VirtualBox installation is from the openSUSE-Tumbleweed-Oss repository. If a new kernel is installed, I cannot start the virtual OS in VirtualBox.

    Should I issue a bug report of the new kernel 4.9? If yes, where should I submit the bug report?

    Regards,
    CnZhx
    openSUSE Tumbleweed (usually the latest snapshot) w/ KDE Plasma 5

  4. #14

    Default Re: Wireless cannot connect after dup to kernel 4.9.0-{1|2}yesterday

    Am Sat, 14 Jan 2017 20:46:01 GMT
    schrieb cnzhx <cnzhx@no-mx.forums.microfocus.com>:


    >
    > Should I issue a bug report of the new kernel 4.9?


    Yes.

    > If yes, where should I submit the bug report?
    >


    https://bugzilla.opensuse.org

    AK
    --
    Never attribute to malice that which can be adequately explained by stupidity.
    (R.J. Hanlon)


  5. #15

    Default Re: Wireless cannot connect after dup to kernel 4.9.0-{1|2}yesterday

    Quote Originally Posted by Akoellh View Post
    > If yes, where should I submit the bug report?
    >[/color]

    https://bugzilla.opensuse.org

    AK
    Thank you, AK.

    And I found somebody already reported on 29/12/2016. It's odd that I have not found this bug report before. I searched before I came here :-

    Here is the link: https://bugzilla.opensuse.org/show_bug.cgi?id=1017471
    openSUSE Tumbleweed (usually the latest snapshot) w/ KDE Plasma 5

  6. #16

    Default Re: Wireless cannot connect after dup to kernel 4.9.0-{1|2} yesterday

    In the Debian wiki they also have a hint about this issue (this helped me fix the problem on a Thinkpad X220): https://wiki.debian.org/rtl819x#rtl8192ce

  7. #17

    Default Re: Wireless cannot connect after dup to kernel 4.9.0-{1|2} yesterday

    Quote Originally Posted by benediktg View Post
    In the Debian wiki they also have a hint about this issue (this helped me fix the problem on a Thinkpad X220): https://wiki.debian.org/rtl819x#rtl8192ce
    Yes, it does. I did not see this result when search for this problem with Google though.

    But I found it's better to keep "ips" enabled as default. That means only `fwlps` in the extra configuration file.
    Code:
    options rtl8192ce fwlps=0
    However, I doubt this is the ultimate solution because the connection encounter large latency sometimes especially when the signal is not very strong, although it does make the wireless connection usable. Have your connection experienced a large latency with this solution?
    openSUSE Tumbleweed (usually the latest snapshot) w/ KDE Plasma 5

  8. #18

    Default Re: Wireless cannot connect after dup to kernel 4.9.0-{1|2} yesterday

    Larry Finger caught the bug and solved the problem now, at least for my current test (tested with the default parameters on kernel 4.9.5 in openSUSE Tumbleweed in my work place).

    Here is the statement: [1] or [2].

    [1] https://github.com/lwfinger/rtlwifi_...ment-275967189
    [2] https://bugzilla.opensuse.org/show_b...id=1017471#c13
    openSUSE Tumbleweed (usually the latest snapshot) w/ KDE Plasma 5

Page 2 of 2 FirstFirst 12

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •