Page 1 of 2 12 LastLast
Results 1 to 10 of 18

Thread: Wireless cannot connect after dup to kernel 4.9.0-{1|2} yesterday

  1. #1
    Join Date
    Jan 2016
    Location
    Manchester, UK
    Posts
    240

    Default Wireless cannot connect after dup to kernel 4.9.0-{1|2} yesterday

    Hi there,

    Anyone experiences a broken wireless connection after the snapshot 20161226 update?

    Tumbleweed released snapshot 20161226 yesterday. After the `zypper dup --no-allow-vendor-change` update, the NetworkManager could not connect to wireless network, throwing out message of `Cannot find IP configuration` or something like that.

    Please forgive me that I cannot provide the exactly message it threw out. I am currently using my Android phone to host a USB tethering for this system to look for possible solution. I will update this post to provide more detailed information later after I submitting this post to gain some attentions :-)

    In case it helps:
    I am using TW with KDE Plasma on a laptop.
    dGPU is disabled from BIOS.
    Wireless card has following information during boot,
    Code:
    [   12.716960] rtl8192ce:rtl92ce_read_eeprom_info [rtl8192ce]:<0-0> Chip Version ID: B_CHIP_88C
    [   12.726811] rtl8192ce: Using firmware rtlwifi/rtl8192cfwU.bin
    [   13.102157] ieee80211 phy0: Selected rate control algorithm 'rtl_rc'
    [   13.102373] rtlwifi: rtlwifi: wireless switch is on
    [   13.103467] rtl8192ce 0000:03:00.0 wlp3s0: renamed from wlan0
    Wireless connection should be available during boot, but I could not find any information on IPv4.
    Code:
    dmesg | grep IPv4
    shows nothing.

    Although IPv6 is set to be ignored in NetworkManager, it has some information in dmesg output:
    Code:
    dmesg | grep IPv6
    [   29.658623] IPv6: ADDRCONF(NETDEV_UP): enp0s25: link is not ready
    [   29.897530] IPv6: ADDRCONF(NETDEV_UP): enp0s25: link is not ready
    [   29.902051] IPv6: ADDRCONF(NETDEV_UP): wlp3s0: link is not ready
    [   30.247900] IPv6: ADDRCONF(NETDEV_UP): wlp3s0: link is not ready
    [   30.596681] IPv6: ADDRCONF(NETDEV_UP): wlp3s0: link is not ready
    [   31.132398] IPv6: ADDRCONF(NETDEV_UP): wlp3s0: link is not ready
    [  197.080746] IPv6: ADDRCONF(NETDEV_UP): enp0s29u1u2: link is not ready
    [  374.731345] IPv6: ADDRCONF(NETDEV_UP): wlp3s0: link is not ready
    [  690.749584] IPv6: ADDRCONF(NETDEV_UP): wlp3s0: link is not ready
    [ 1006.747362] IPv6: ADDRCONF(NETDEV_UP): wlp3s0: link is not ready
    [ 1322.750764] IPv6: ADDRCONF(NETDEV_UP): wlp3s0: link is not ready
    [ 1638.712372] IPv6: ADDRCONF(NETDEV_UP): wlp3s0: link is not ready
    [ 1954.744808] IPv6: ADDRCONF(NETDEV_UP): wlp3s0: link is not ready
    [ 2270.746936] IPv6: ADDRCONF(NETDEV_UP): wlp3s0: link is not ready
    [ 2586.766039] IPv6: ADDRCONF(NETDEV_UP): wlp3s0: link is not ready
    [ 2902.723010] IPv6: ADDRCONF(NETDEV_UP): wlp3s0: link is not ready
    I also remember there is a `Reason: 15=4WAY_HANDSHAKE_TIMEOUT` error in `dmesg` output when I ask NetworkManager to connect.

    Tricks I've done to try to bring the wireless network back:
    • `sudo systemctl restart network`
    • `sudo systemctl restart NetworkManager`
    • Delete WiFi configuration and re-create.
    • Change WiFi connection from system-wide to current-user-only, and vise versa.
    • I lost the chance to try an old working kernel (4.8.14) because I updated to the 4.9.0-2 kernel from update repo. I thought the new 4.9.0-2 kernel could resolve my problem, but it could not. And later, I found I have only 2 kernel versions reserved (I changed `multiversion.kernel` in `/etc/zypp/zypp.conf` now).


    I am a newbie to Linux DE, but I am eager to learn from solving problems. Any hint is appreciated.

    TIA.

    Regards,
    CnZhx
    openSUSE Tumbleweed (usually the latest snapshot) w/ KDE Plasma 5

  2. #2
    Join Date
    Jan 2016
    Location
    Manchester, UK
    Posts
    240

    Default Re: Wireless cannot connect after dup to kernel 4.9.0-{1|2} yesterday

    Information updated.

    After I submitted the post, I tried to connect the wireless network through NM. Surprisingly, it worked. Here is the dmesg output:
    Code:
    [ 3487.179551] IPv6: ADDRCONF(NETDEV_UP): wlp3s0: link is not ready
    [ 3488.180078] wlp3s0: authenticate with ec:22:80:10:b7:2f
    [ 3488.198841] wlp3s0: send auth to ec:22:80:10:b7:2f (try 1/3)
    [ 3488.201683] wlp3s0: authenticated
    [ 3488.202237] wlp3s0: associate with ec:22:80:10:b7:2f (try 1/3)
    [ 3488.211240] wlp3s0: RX AssocResp from ec:22:80:10:b7:2f (capab=0x411 status=0 aid=8)
    [ 3488.211594] wlp3s0: associated
    [ 3488.211606] IPv6: ADDRCONF(NETDEV_CHANGE): wlp3s0: link becomes ready
    Then, I pulled out the USB tethering. But the network was barely usable -- I cannot open any webpage. And After a while, the signal of my wireless connection turned to 0%. And it connected again in short time later. But the network was not usable.
    Code:
    [ 3537.947569] usb 4-1.2: USB disconnect, device number 4
    [ 3537.949817] rndis_host 4-1.2:1.0 enp0s29u1u2: unregister 'rndis_host' usb-0000:00:1d.0-1.2, RNDIS device
    [ 3541.083278] SFW2-INext-DROP-DEFLT IN=wlp3s0 OUT= MAC=ec:55:f9:bf:20:7a:ec:22:80:10:b7:2f:08:00 SRC=46.229.52.198 DST=192.168.1.3 LEN=382 TOS=0x00 PREC=0x00 TTL=53 ID=56348 PROTO=UDP SPT=33445 DPT=33445 LEN=362 
    [ 3543.170208] SFW2-INext-DROP-DEFLT IN=wlp3s0 OUT= MAC=ec:55:f9:bf:20:7a:ec:22:80:10:b7:2f:08:00 SRC=80.144.73.87 DST=192.168.1.3 LEN=382 TOS=0x00 PREC=0x00 TTL=51 ID=17977 PROTO=UDP SPT=33445 DPT=33445 LEN=362 
    [ 3543.732091] SFW2-INext-DROP-DEFLT IN=wlp3s0 OUT= MAC=ec:55:f9:bf:20:7a:ec:22:80:10:b7:2f:08:00 SRC=76.74.170.181 DST=192.168.1.3 LEN=382 TOS=0x00 PREC=0x00 TTL=53 ID=7522 PROTO=UDP SPT=33445 DPT=33445 LEN=362 
    [ 3545.385635] SFW2-INext-DROP-DEFLT IN=wlp3s0 OUT= MAC=ec:55:f9:bf:20:7a:ec:22:80:10:b7:2f:08:00 SRC=83.13.139.6 DST=192.168.1.3 LEN=141 TOS=0x00 PREC=0x00 TTL=111 ID=29216 PROTO=UDP SPT=8050 DPT=33445 LEN=121 
    [ 3547.035961] SFW2-INext-DROP-DEFLT IN=wlp3s0 OUT= MAC= SRC=fe80:0000:0000:0000:4fbf:d959:a74c:c290 DST=ff02:0000:0000:0000:0000:0000:0000:0001 LEN=81 TC=0 HOPLIMIT=1 FLOWLBL=965817 PROTO=UDP SPT=33445 DPT=33445 LEN=41 
    [ 3547.194282] SFW2-INext-DROP-DEFLT IN=wlp3s0 OUT= MAC=ec:55:f9:bf:20:7a:ec:22:80:10:b7:2f:08:00 SRC=205.185.116.116 DST=192.168.1.3 LEN=382 TOS=0x00 PREC=0x00 TTL=50 ID=0 PROTO=UDP SPT=33445 DPT=33445 LEN=362 
    [ 3565.795001] rtlwifi:rtl_watchdog_wq_callback [rtlwifi]:<0-0> AP off, try to reconnect now
    [ 3565.795065] wlp3s0: Connection to AP ec:22:80:10:b7:2f lost
    [ 3569.037910] SFW2-INext-DROP-DEFLT IN=wlp3s0 OUT= MAC= SRC=fe80:0000:0000:0000:4fbf:d959:a74c:c290 DST=ff02:0000:0000:0000:0000:0000:0000:0001 LEN=81 TC=0 HOPLIMIT=1 FLOWLBL=965817 PROTO=UDP SPT=33445 DPT=33445 LEN=41 
    [ 3575.875045] rtlwifi:rtl_watchdog_wq_callback [rtlwifi]:<0-0> AP off, try to reconnect now
    [ 3580.037073] SFW2-INext-DROP-DEFLT IN=wlp3s0 OUT= MAC= SRC=fe80:0000:0000:0000:4fbf:d959:a74c:c290 DST=ff02:0000:0000:0000:0000:0000:0000:0001 LEN=81 TC=0 HOPLIMIT=1 FLOWLBL=965817 PROTO=UDP SPT=33445 DPT=33445 LEN=41 
    [ 3582.639170] wlp3s0: Connection to AP 00:00:00:00:00:00 lost
    [ 3598.043895] IPv6: ADDRCONF(NETDEV_UP): wlp3s0: link is not ready
    [ 3600.517222] rtl8192c_common:rtl92c_firmware_selfreset(): 8051 reset fail.
    [ 3600.974861] IPv6: ADDRCONF(NETDEV_UP): wlp3s0: link is not ready
    [ 3602.782299] IPv6: ADDRCONF(NETDEV_UP): wlp3s0: link is not ready
    [ 3603.800567] wlp3s0: authenticate with ec:22:80:10:b7:2f
    [ 3603.820536] wlp3s0: send auth to ec:22:80:10:b7:2f (try 1/3)
    [ 3603.923246] wlp3s0: send auth to ec:22:80:10:b7:2f (try 2/3)
    [ 3604.027203] wlp3s0: send auth to ec:22:80:10:b7:2f (try 3/3)
    [ 3604.041653] wlp3s0: authenticated
    [ 3604.043235] wlp3s0: associate with ec:22:80:10:b7:2f (try 1/3)
    [ 3604.147211] wlp3s0: associate with ec:22:80:10:b7:2f (try 2/3)
    [ 3604.251238] wlp3s0: associate with ec:22:80:10:b7:2f (try 3/3)
    [ 3604.287882] wlp3s0: RX AssocResp from ec:22:80:10:b7:2f (capab=0x411 status=0 aid=8)
    [ 3604.292018] wlp3s0: associated
    [ 3604.292029] IPv6: ADDRCONF(NETDEV_CHANGE): wlp3s0: link becomes ready
    [ 3610.696810] wlp3s0: deauthenticated from ec:22:80:10:b7:2f (Reason: 15=4WAY_HANDSHAKE_TIMEOUT)
    [ 3611.783778] wlp3s0: authenticate with ec:22:80:10:b7:2f
    [ 3611.803901] wlp3s0: send auth to ec:22:80:10:b7:2f (try 1/3)
    [ 3612.835285] wlp3s0: send auth to ec:22:80:10:b7:2f (try 2/3)
    [ 3613.827292] wlp3s0: send auth to ec:22:80:10:b7:2f (try 3/3)
    [ 3614.819300] wlp3s0: authentication with ec:22:80:10:b7:2f timed out
    [ 3616.799886] wlp3s0: authenticate with ec:22:80:10:b7:2f
    [ 3616.819787] wlp3s0: send auth to ec:22:80:10:b7:2f (try 1/3)
    [ 3616.876093] wlp3s0: authenticated
    [ 3616.879309] wlp3s0: associate with ec:22:80:10:b7:2f (try 1/3)
    [ 3617.121427] wlp3s0: RX AssocResp from ec:22:80:10:b7:2f (capab=0x411 status=0 aid=8)
    [ 3617.137453] wlp3s0: associated
    [ 3623.254776] wlp3s0: deauthenticated from ec:22:80:10:b7:2f (Reason: 15=4WAY_HANDSHAKE_TIMEOUT)
    [ 3628.078550] wlp3s0: authenticate with ec:22:80:10:b7:2f
    [ 3628.422567] wlp3s0: send auth to ec:22:80:10:b7:2f (try 1/3)
    [ 3628.523468] wlp3s0: send auth to ec:22:80:10:b7:2f (try 2/3)
    [ 3628.627522] wlp3s0: send auth to ec:22:80:10:b7:2f (try 3/3)
    [ 3628.731461] wlp3s0: authentication with ec:22:80:10:b7:2f timed out
    [ 3653.039138] IPv6: ADDRCONF(NETDEV_UP): wlp3s0: link is not ready
    [ 3653.389447] IPv6: ADDRCONF(NETDEV_UP): wlp3s0: link is not ready
    [ 3678.805369] IPv6: ADDRCONF(NETDEV_UP): wlp3s0: link is not ready
    [ 3679.792829] wlp3s0: authenticate with ec:22:80:10:b7:2f
    [ 3679.813216] wlp3s0: send auth to ec:22:80:10:b7:2f (try 1/3)
    [ 3679.831082] wlp3s0: authenticated
    [ 3679.831839] wlp3s0: associate with ec:22:80:10:b7:2f (try 1/3)
    [ 3679.852536] wlp3s0: RX AssocResp from ec:22:80:10:b7:2f (capab=0x411 status=0 aid=4)
    [ 3679.852899] wlp3s0: associated
    [ 3679.852908] IPv6: ADDRCONF(NETDEV_CHANGE): wlp3s0: link becomes ready
    [ 3735.973578] wlp3s0: deauthenticating from ec:22:80:10:b7:2f by local choice (Reason: 14=MIC_FAILURE)
    [ 3777.044525] IPv6: ADDRCONF(NETDEV_UP): wlp3s0: link is not ready
    [ 3779.534971] rtl8192c_common:rtl92c_firmware_selfreset(): 8051 reset fail.
    [ 3779.891041] IPv6: ADDRCONF(NETDEV_UP): wlp3s0: link is not ready
    [ 3781.708844] IPv6: ADDRCONF(NETDEV_UP): wlp3s0: link is not ready
    [ 3807.039104] IPv6: ADDRCONF(NETDEV_UP): wlp3s0: link is not ready
    [ 3807.403557] IPv6: ADDRCONF(NETDEV_UP): wlp3s0: link is not ready
    [ 3807.825253] IPv6: ADDRCONF(NETDEV_UP): wlp3s0: link is not ready
    [ 3822.921624] wlp3s0: authenticate with ec:22:80:10:b7:2f
    [ 3822.942120] wlp3s0: send auth to ec:22:80:10:b7:2f (try 1/3)
    [ 3822.946359] wlp3s0: authenticated
    [ 3822.949144] wlp3s0: associate with ec:22:80:10:b7:2f (try 1/3)
    [ 3822.955011] wlp3s0: RX AssocResp from ec:22:80:10:b7:2f (capab=0x411 status=0 aid=4)
    [ 3822.955325] wlp3s0: associated
    [ 3822.955335] IPv6: ADDRCONF(NETDEV_CHANGE): wlp3s0: link becomes ready
    Now the wireless is connected but I cannot use the network. Even `ping` returns failure.
    Code:
    ping -c 5 8.8.8.8
    PING 8.8.8.8 (8.8.8.8) 56(84) bytes of data.
    From 192.168.1.3 icmp_seq=1 Destination Host Unreachable
    From 192.168.1.3 icmp_seq=2 Destination Host Unreachable
    From 192.168.1.3 icmp_seq=3 Destination Host Unreachable
    From 192.168.1.3 icmp_seq=4 Destination Host Unreachable
    From 192.168.1.3 icmp_seq=5 Destination Host Unreachable
    
    --- 8.8.8.8 ping statistics ---
    5 packets transmitted, 0 received, +5 errors, 100% packet loss, time 4051ms
    pipe 4
    Could anyone please make some suggestions?
    openSUSE Tumbleweed (usually the latest snapshot) w/ KDE Plasma 5

  3. #3
    Join Date
    Jan 2016
    Location
    UK
    Posts
    368

    Default Re: Wireless cannot connect after dup to kernel 4.9.0-{1|2} yesterday

    I also have an issue where wireless is not available at boot time, but using Leap 42.2. However not sure if it's the same. Mine is soft bocked. So run rfkill list all (you may need to install rfkill, assuming you can get online wired maybe?) and post the output.

    Stuart

  4. #4
    Join Date
    Jan 2016
    Location
    Manchester, UK
    Posts
    240

    Default Re: Wireless cannot connect after dup to kernel 4.9.0-{1|2} yesterday

    Quote Originally Posted by broadstairs View Post
    I also have an issue where wireless is not available at boot time, but using Leap 42.2. However not sure if it's the same. Mine is soft bocked. So run rfkill list all (you may need to install rfkill, assuming you can get online wired maybe?) and post the output.

    Stuart
    Thank you, Stuart,

    It seems my problem is different.
    Code:
    ~> sudo rfkill list all
    [sudo] password for root: 
    0: phy0: Wireless LAN
            Soft blocked: no
            Hard blocked: no
    No device is blocked here.

    My wireless is not available not only during boot but also after logged in. WiFi list is showing but NetworkManager reports it cannot connect or do connect but still no real connection (i.e. I cannot browse internet with the connection).

    P.S. I use a USB tethering from my phone to connect to the internet right now.
    Last edited by cnzhx; 30-Dec-2016 at 08:52. Reason: Add P.S.
    openSUSE Tumbleweed (usually the latest snapshot) w/ KDE Plasma 5

  5. #5
    Join Date
    Jan 2016
    Location
    Manchester, UK
    Posts
    240

    Default Re: Wireless cannot connect after dup to kernel 4.9.0-{1|2} yesterday

    Quote Originally Posted by cnzhx View Post
    Tumbleweed released snapshot 20161226 yesterday. After the `zypper dup --no-allow-vendor-change` update, the NetworkManager could not connect to wireless network, throwing out message of `Cannot find IP configuration` or something like that.
    The message is,
    IP configuration is unavailable
    Updated observation:

    The wireless connection works 2 or 3 times among about 10 times reboots. But I am not sure if following operations helped, such as following command being tried,
    Code:
    sudo netconfig update -f
    apart from operations mentioned above,

    • `sudo systemctl restart network`
    • `sudo systemctl restart NetworkManager`
    • Delete WiFi configuration and re-create.
    • Change WiFi connection from system-wide to current-user-only, and vise versa.


    If the wireless connection works after certain boot, further service restart may cause it never connects again. The weird thing is why does it work sometimes and does not in other times.

    I am now connected and feared to tackle it further. Maybe another a few snapshots of TW could make it right.
    openSUSE Tumbleweed (usually the latest snapshot) w/ KDE Plasma 5

  6. #6
    Join Date
    Jan 2016
    Location
    Manchester, UK
    Posts
    240

    Default Re: Wireless cannot connect after dup to kernel 4.9.0-{1|2} yesterday

    Hi all,

    I think I just found the problem. But I have difficulty to solve it. Could anyone help me check the following logs to identify the problem?

    The situation is that the wireless network works well when the WiFi entry is set as per-user scheme other than system-wide (with the option "All users may connect to this network"). I just learned to set a system connection from here [1] but was using it only a few days then it breaks my heart. [1: https://forums.opensuse.org/showthre...-System-Reboot]

    When the WiFi entry was set as "system connection" with "All users may connect to this network" and "Store password and make it available for all users (not encrypted)" checked, NetworkManager can connect to the hotspot during boot and after user logged in. But the connection is not usable. User cannot open webpage, and cannot ping any IP or site. User cannot even ping the router.

    However, I can use the network by setting a per-user wifi connection.

    Here is the dmesg message and the critical message entry should be "AP off, try to reconnect now":
    Code:
    [   23.757903] IPv6: ADDRCONF(NETDEV_UP): enp0s25: link is not ready
    [   24.001294] IPv6: ADDRCONF(NETDEV_UP): enp0s25: link is not ready
    [   24.011432] IPv6: ADDRCONF(NETDEV_UP): wlp3s0: link is not ready
    [   24.355833] IPv6: ADDRCONF(NETDEV_UP): wlp3s0: link is not ready
    [   24.705569] IPv6: ADDRCONF(NETDEV_UP): wlp3s0: link is not ready
    [   25.037870] NET: Registered protocol family 17
    [   25.086941] IPv6: ADDRCONF(NETDEV_UP): wlp3s0: link is not ready
    [   26.748881] IPv6: ADDRCONF(NETDEV_UP): wlp3s0: link is not ready
    [   27.736036] wlp3s0: authenticate with ec:22:80:10:b7:2f
    [   27.753682] wlp3s0: send auth to ec:22:80:10:b7:2f (try 1/3)
    [   27.755937] wlp3s0: authenticated
    [   27.756771] wlp3s0: associate with ec:22:80:10:b7:2f (try 1/3)
    [   27.764643] wlp3s0: RX AssocResp from ec:22:80:10:b7:2f (capab=0x411 status=0 aid=9)
    [   27.765013] wlp3s0: associated
    [   27.765027] IPv6: ADDRCONF(NETDEV_CHANGE): wlp3s0: link becomes ready
    [  119.464184] rtlwifi:rtl_watchdog_wq_callback [rtlwifi]:<0-0> AP off, try to reconnect now
    [  119.464208] wlp3s0: Connection to AP ec:22:80:10:b7:2f lost
    [  129.544119] rtlwifi:rtl_watchdog_wq_callback [rtlwifi]:<0-0> AP off, try to reconnect now
    [  136.656949] wlp3s0: Connection to AP 00:00:00:00:00:00 lost
    [  152.024118] IPv6: ADDRCONF(NETDEV_UP): wlp3s0: link is not ready
    [  154.749833] rtl8192c_common:rtl92c_firmware_selfreset(): 8051 reset fail.
    [  155.095334] IPv6: ADDRCONF(NETDEV_UP): wlp3s0: link is not ready
    [  157.013536] IPv6: ADDRCONF(NETDEV_UP): wlp3s0: link is not ready
    [  158.029856] wlp3s0: authenticate with ec:22:80:10:b7:2f
    [  158.050343] wlp3s0: send auth to ec:22:80:10:b7:2f (try 1/3)
    [  158.054243] wlp3s0: authenticated
    [  158.055919] wlp3s0: associate with ec:22:80:10:b7:2f (try 1/3)
    [  158.060147] wlp3s0: RX AssocResp from ec:22:80:10:b7:2f (capab=0x411 status=0 aid=9)
    [  158.060464] wlp3s0: associated
    [  158.060476] IPv6: ADDRCONF(NETDEV_CHANGE): wlp3s0: link becomes ready
    Below is the journal message. The critical message entry might be "Temporary failure in name resolution".
    Code:
    ~> sudo journalctl --since "3 minutes ago" | grep NetworkManager
    Dec 31 08:42:48 CnZhx NetworkManager[1145]: <info>  [1483173768.5660] dhcp4 (wlp3s0): state changed unknown -> bound
    Dec 31 08:42:48 CnZhx NetworkManager[1145]: <info>  [1483173768.5677] device (wlp3s0): state change: ip-config -> ip-check (reason 'none') [70 80 0]
    Dec 31 08:42:48 CnZhx NetworkManager[1145]: <info>  [1483173768.5693] device (wlp3s0): state change: ip-check -> secondaries (reason 'none') [80 90 0]
    Dec 31 08:42:48 CnZhx NetworkManager[1145]: <info>  [1483173768.5702] device (wlp3s0): state change: secondaries -> activated (reason 'none') [90 100 0]
    Dec 31 08:42:48 CnZhx NetworkManager[1145]: <info>  [1483173768.5705] manager: NetworkManager state is now CONNECTED_LOCAL
    Dec 31 08:42:48 CnZhx NetworkManager[1145]: <info>  [1483173768.5733] manager: NetworkManager state is now CONNECTED_SITE
    Dec 31 08:42:48 CnZhx NetworkManager[1145]: <info>  [1483173768.5735] policy: set 'TALKTALK-10B72F' (wlp3s0) as default for IPv4 routing and DNS
    Dec 31 08:42:48 CnZhx NetworkManager[1145]: nisdomainname: you must be root to change the domain name
    Dec 31 08:42:48 CnZhx NetworkManager[1145]: nisdomainname: you must be root to change the domain name
    Dec 31 08:42:48 CnZhx NetworkManager[1145]: <info>  [1483173768.7425] device (wlp3s0): Activation: successful, device activated.
    Dec 31 08:42:48 CnZhx NetworkManager[1145]: <info>  [1483173768.9900] manager: NetworkManager state is now CONNECTED_GLOBAL
    Dec 31 08:48:38 CnZhx NetworkManager[1145]: <info>  [1483174118.4813] connectivity: check for uri 'http://conncheck.opensuse.org' failed with 'Error resolving 'conncheck.opensuse.org': Temporary failure in name resolution'
    Dec 31 08:48:38 CnZhx NetworkManager[1145]: <info>  [1483174118.4814] manager: NetworkManager state is now CONNECTED_SITE
    Dec 31 08:49:18 CnZhx NetworkManager[1145]: <info>  [1483174158.5149] connectivity: check for uri 'http://conncheck.opensuse.org' failed with 'Error resolving 'conncheck.opensuse.org': Temporary failure in name resolution'
    And the ping status,
    Code:
    ~> ping -c 3 8.8.8.8
    PING 8.8.8.8 (8.8.8.8) 56(84) bytes of data.
    From 192.168.1.3 icmp_seq=3 Destination Host Unreachable
    
    --- 8.8.8.8 ping statistics ---
    3 packets transmitted, 0 received, +1 errors, 100% packet loss, time 2042ms
    Could any help analysis the above logs? Thanks in advance.

    Regards,
    cnzhx
    openSUSE Tumbleweed (usually the latest snapshot) w/ KDE Plasma 5

  7. #7
    Join Date
    Feb 2016
    Location
    Berlin
    Posts
    277

    Default Re: Wireless cannot connect after dup to kernel 4.9.0-{1|2} yesterday

    since no one else has written...check out arch page on setting up/troubleshooting wireless network. verify its not an auth/permission problem. boot using previous kernel, if that doesnt work do a full rollback and hope next update with new kernal fixes it.

  8. #8
    Join Date
    Jan 2016
    Location
    Manchester, UK
    Posts
    240

    Default Re: Wireless cannot connect after dup to kernel 4.9.0-{1|2} yesterday

    Quote Originally Posted by ndc33 View Post
    since no one else has written...check out arch page on setting up/troubleshooting wireless network. verify its not an auth/permission problem. boot using previous kernel, if that doesnt work do a full rollback and hope next update with new kernal fixes it.
    Thank you, ndc,

    I finally found that I could use a per-user configuration of wireless connection in NetworkManager for it to work, although sometimes it still has no internet access after the NM shows it has connected to the wireless hotspot and I have to reboot to give it another chance. I updated this information in my last post in this thread.

    To answer your question, it seems that the NM has no problem to auth when using a system connection configuration. But I have no access to internet with that connection. I cannot even ping my router. And sometimes, NM have problems to even connect. The problems vary from time to time including associating, not updating resolv.conf, etc.

    Based on this inconsistent symptom, I guess I have to wait for updates to see if they can fix this.
    openSUSE Tumbleweed (usually the latest snapshot) w/ KDE Plasma 5

  9. #9
    Join Date
    Jan 2016
    Location
    Manchester, UK
    Posts
    240

    Default Re: Wireless cannot connect after dup to kernel 4.9.0-{1|2} yesterday

    I might have identified the problem, but I need further help to resolve it.

    While trying to find a solution to this, I occasionally found the wireless connection will connect and work for a very short while if I issue the following commands,

    Code:
    sudo modprobe -r rtl8192ce && sudo modprobe rtl8192ce
    But after that short time, the connection becomes unusable again. The symptoms are,
    • ping any IP will return an error of "Destination unreachable"
    • ping any domain will timeout because no DNS resolution; and, if try to open website in browser, it cannot resolve the domain


    And here is the output of dmesg after a module reloading in case it helps,
    Code:
    [  838.269998] wlp3s0: deauthenticating from 00:1a:1e:1b:83:61 by local choice (Reason: 3=DEAUTH_LEAVING)
    [  855.287963] rtl8192c_common:rtl92c_firmware_selfreset(): 8051 reset fail.
    [  855.632550] rtl8192ce:rtl92ce_read_eeprom_info [rtl8192ce]:<0-0> Chip Version ID: B_CHIP_88C
    [  855.643288] rtl8192ce: Using firmware rtlwifi/rtl8192cfwU.bin
    [  855.645255] ieee80211 phy0: Selected rate control algorithm 'rtl_rc'
    [  855.647460] rtl8192ce 0000:03:00.0 wlp3s0: renamed from wlan0
    [  855.649637] rtlwifi: rtlwifi: wireless switch is on
    [  855.680113] IPv6: ADDRCONF(NETDEV_UP): wlp3s0: link is not ready
    [  856.024786] IPv6: ADDRCONF(NETDEV_UP): wlp3s0: link is not ready
    [  856.373272] IPv6: ADDRCONF(NETDEV_UP): wlp3s0: link is not ready
    [  856.451041] IPv6: ADDRCONF(NETDEV_UP): wlp3s0: link is not ready
    [  857.760321] IPv6: ADDRCONF(NETDEV_UP): wlp3s0: link is not ready
    [  858.750518] wlp3s0: authenticate with 00:1a:1e:1b:83:61
    [  858.770212] wlp3s0: send auth to 00:1a:1e:1b:83:61 (try 1/3)
    [  858.773179] wlp3s0: authenticated
    [  858.773664] wlp3s0: associate with 00:1a:1e:1b:83:61 (try 1/3)
    [  858.779409] wlp3s0: RX AssocResp from 00:1a:1e:1b:83:61 (capab=0x1431 status=0 aid=3)
    [  858.779770] wlp3s0: associated
    [  858.779812] IPv6: ADDRCONF(NETDEV_CHANGE): wlp3s0: link becomes ready
    [  858.786692] wlp3s0: Limiting TX power to 20 (20 - 0) dBm as advertised by 00:1a:1e:1b:83:61
    Regards,
    cnzhx
    openSUSE Tumbleweed (usually the latest snapshot) w/ KDE Plasma 5

  10. #10
    Join Date
    Jan 2016
    Location
    Manchester, UK
    Posts
    240

    Default Re: Wireless cannot connect after dup to kernel 4.9.0-{1|2} yesterday

    Quote Originally Posted by cnzhx View Post
    I might have identified the problem, but I need further help to resolve it.

    While trying to find a solution to this, I occasionally found the wireless connection will connect and work for a very short while if I issue the following commands,

    Code:
    sudo modprobe -r rtl8192ce && sudo modprobe rtl8192ce
    But after that short time, the connection becomes unusable again.
    Updates to this finding: A old post in 2012 helps identify the problem finally. The post link: https://bbs.archlinux.org/viewtopic....07433#p1107433

    A brief summary to the post content:
    1. Check if rtl8192ce is loaded:

    Code:
    lsmod
    2. Get some information about it:

    Code:
    modinfo rtl8192ce
    and check the parameters info at the end.

    3. Check how are configured those parameters:
    Code:
    systool -v -m rtl8192ce
    I got under "Parameters:"

    Code:
    debug   =   "0"
    fwlps   =   "Y"
    ips   =   "Y"
    swnc   =   "N"
    swlps   =   "N"
    If you already checked the command results at the end in step 2, you saw that some of this parameters are for power saving. So I decided disable.

    4. Make a file in `/etc/modprobe.d/rtl8192ce.conf` and add this:

    Code:
    options rtl8192ce ips=0 fwlps=0
    and save it and reboot.
    (disable those you are enable)

    5. Repeat step 3 to check if the parameters were disable.
    This problem is finally solved. But I find it difficult to understand how does an old, resolved problem reoccur in new kernel.
    openSUSE Tumbleweed (usually the latest snapshot) w/ KDE Plasma 5

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •