Results 1 to 10 of 10

Thread: How to install gnome-themes-standard?

  1. #1

    Default How to install gnome-themes-standard?

    Greetings,

    Old timer with debian distro but very new user of openSUSE. I am trying to install the package gnome-themes-standard on Leap 42.2 and get a bit confused.

    It cannot be found in the repos.

    Code:
    # zypper repos
    #  | Alias                     | Name                                    | Enabled | GPG Check | Refresh
    ---+---------------------------+-----------------------------------------+---------+-----------+--------
     1 | openSUSE-42.2-0           | openSUSE-42.2-0                         | No      | ----      | Yes    
     2 | repo-debug                | openSUSE-Leap-42.2-Debug                | No      | ----      | Yes    
     3 | repo-debug-non-oss        | openSUSE-Leap-42.2-Debug-Non-Oss        | No      | ----      | Yes    
     4 | repo-debug-update         | openSUSE-Leap-42.2-Update-Debug         | No      | ----      | Yes    
     5 | repo-debug-update-non-oss | openSUSE-Leap-42.2-Update-Debug-Non-Oss | No      | ----      | Yes    
     6 | repo-non-oss              | openSUSE-Leap-42.2-Non-Oss              | Yes     | (r ) Yes  | Yes    
     7 | repo-oss                  | openSUSE-Leap-42.2-Oss                  | Yes     | (r ) Yes  | Yes    
     8 | repo-source               | openSUSE-Leap-42.2-Source               | Yes     | (r ) Yes  | Yes    
     9 | repo-source-non-oss       | openSUSE-Leap-42.2-Source-Non-Oss       | Yes     | (r ) Yes  | Yes    
    10 | repo-update               | openSUSE-Leap-42.2-Update               | Yes     | (r ) Yes  | Yes    
    11 | repo-update-non-oss       | openSUSE-Leap-42.2-Update-Non-Oss       | Yes     | (r ) Yes  | Yes    
    
    
    # zypper refresh
    Repository 'openSUSE-Leap-42.2-Non-Oss' is up to date.                                                                                                                                 
    Repository 'openSUSE-Leap-42.2-Oss' is up to date.                                                                                                                                     
    Repository 'openSUSE-Leap-42.2-Source' is up to date.                                                                                                                                  
    Repository 'openSUSE-Leap-42.2-Source-Non-Oss' is up to date.                                                                                                                          
    Repository 'openSUSE-Leap-42.2-Update' is up to date.                                                                                                                                  
    Repository 'openSUSE-Leap-42.2-Update-Non-Oss' is up to date.                                                                                                                          
    All repositories have been refreshed.
    
    
    # zypper install gnome-themes-standard
    Loading repository data...
    Reading installed packages...
    Package 'gnome-themes-standard' not found.
    Resolving package dependencies...
    
    Nothing to do.
    According to software.opensuse.org the package would be available in the repo located at http://download.opensuse.org/reposit...Leap:42.2.repo
    Note I could download the rpm from software.opensuse.org directly, but I'd like to understand the big picture

    So I open my browser to http://download.opensuse.org/reposit...42.2/standard/ and find out that I am redirected to http://download.opensuse.org/distrib...repo/oss/suse/ which is already in my repo list.
    Anyhow I manually browse noarch and x86_64 directories and search but cannot find gnome-themes-standard

    Voilà, sorry for the newbie question and thanks in advance for your help with my first baby steps if you can explain to me what's going on here
    Cheers

  2. #2
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,382

    Default Re: How to install gnome-themes-standard?

    I am nott a Gnome user, thus my answer can not go into Gnome dictated details (like what the package name is). But I can give you some general advice.

    First, it is nice and helpful when you post your repo list in cases like this, but please make a list that includes the URLs. Just the Aliases and Names does not help much, because these are local to your system and can be anything
    Code:
    zypper lr -d
    Second, when you are not sure about a package name (package names can differ from the file that it provides, specially when it contains more then one file), why not use YaST> Software > Software Management and then the Search functionality? There is plenty possibility there to use search strings like "theme" (without the "s).
    Henk van Velden

  3. #3

    Default Re: How to install gnome-themes-standard?

    Quote Originally Posted by hcvv View Post
    First, it is nice and helpful when you post your repo list in cases like this, but please make a list that includes the URLs. Just the Aliases and Names does not help much, because these are local to your system and can be anything
    Code:
    zypper lr -d
    Code:
    # zypper lr -d
    #  | Alias                     | Name                                    | Enabled | GPG Check | Refresh | Priority | Type   | URI                                                                           | Service
    ---+---------------------------+-----------------------------------------+---------+-----------+---------+----------+--------+-------------------------------------------------------------------------------+--------
     1 | openSUSE-42.2-0           | openSUSE-42.2-0                         | No      | ----      | Yes     |   99     | yast2  | hd:///?device=/dev/disk/by-id/usb-Imation_Nano_Pro_0703C110C96B33FE-0:0-part1 |        
     2 | repo-debug                | openSUSE-Leap-42.2-Debug                | No      | ----      | Yes     |   99     | NONE   | http://download.opensuse.org/debug/distribution/leap/42.2/repo/oss/           |        
     3 | repo-debug-non-oss        | openSUSE-Leap-42.2-Debug-Non-Oss        | No      | ----      | Yes     |   99     | NONE   | http://download.opensuse.org/debug/distribution/leap/42.2/repo/non-oss/       |        
     4 | repo-debug-update         | openSUSE-Leap-42.2-Update-Debug         | No      | ----      | Yes     |   99     | NONE   | http://download.opensuse.org/debug/update/leap/42.2/oss/                      |        
     5 | repo-debug-update-non-oss | openSUSE-Leap-42.2-Update-Debug-Non-Oss | No      | ----      | Yes     |   99     | NONE   | http://download.opensuse.org/debug/update/leap/42.2/non-oss/                  |        
     6 | repo-non-oss              | openSUSE-Leap-42.2-Non-Oss              | Yes     | (r ) Yes  | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/leap/42.2/repo/non-oss/             |        
     7 | repo-oss                  | openSUSE-Leap-42.2-Oss                  | Yes     | (r ) Yes  | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/leap/42.2/repo/oss/                 |        
     8 | repo-source               | openSUSE-Leap-42.2-Source               | Yes     | (r ) Yes  | Yes     |   99     | yast2  | http://download.opensuse.org/source/distribution/leap/42.2/repo/oss/          |        
     9 | repo-source-non-oss       | openSUSE-Leap-42.2-Source-Non-Oss       | Yes     | (r ) Yes  | Yes     |   99     | yast2  | http://download.opensuse.org/source/distribution/leap/42.2/repo/non-oss/      |        
    10 | repo-update               | openSUSE-Leap-42.2-Update               | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/leap/42.2/oss/                            |        
    11 | repo-update-non-oss       | openSUSE-Leap-42.2-Update-Non-Oss       | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/leap/42.2/non-oss/                        |

    Quote Originally Posted by hcvv View Post
    Second, when you are not sure about a package name (package names can differ from the file that it provides, specially when it contains more then one file), why not use YaST> Software > Software Management and then the Search functionality? There is plenty possibility there to use search strings like "theme" (without the "s).
    Ok noted the search from YaST, though I am using zypper search
    Anyhow I am sure about the package name, as I stated in my original post it is not available in repos though referenced in http://software.opensuse.org/downloa...hemes-standard and that's the why of this post

  4. #4
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,382

    Default Re: How to install gnome-themes-standard?

    When I search for software that is not in the repos I have, I use https://software.opensuse.org/search
    Putting gnome-themes-standard in the search field provides me with a resulting Direct Install button for version 3.20.2.
    Doesn't that work for you?
    Henk van Velden

  5. #5
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    27,213
    Blog Entries
    15

    Default Re: How to install gnome-themes-standard?

    Hi
    The gnome-themes-standard is a src rpm...
    Code:
    zypper se gnome-themes-standard
    
    S | Name                  | Summary               | Type      
    --+-----------------------+-----------------------+-----------
      | gnome-themes-standard | Standard GNOME Themes | srcpackage
    
    zypper in -t srcpackage gnome-themes-standard
    
    Resolving package dependencies...
    
    The following source package is going to be installed:
      gnome-themes-standard
    
    1 source package to install.
    Overall download size: 2.8 MiB. Already cached: 0 B. After the operation, additional 2.8 MiB will be used.
    Continue? [y/n/? shows all options] (y): n
    
    zypper if -t srcpackage --provides gnome-themes-standard
    
    Information for srcpackage gnome-themes-standard:
    -------------------------------------------------
    Repository  : openSUSE-Leap-42.2-Source
    Name        : gnome-themes-standard    
    Version     : 3.20.2-1.3               
    Arch        : noarch                   
    Vendor      : openSUSE                 
    Summary     : Standard GNOME Themes    
    Description :                          
        This packages contains the standard GNOME themes from GNOME 3 and
        later.
    Provides    : ---
    So do you really want to install the source as most of the packages built from the src rpm are installed...
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  6. #6

    Default Re: How to install gnome-themes-standard?

    Quote Originally Posted by hcvv View Post
    When I search for software that is not in the repos I have, I use https://software.opensuse.org/search
    Putting gnome-themes-standard in the search field provides me with a resulting Direct Install button for version 3.20.2.
    Doesn't that work for you?
    No offense, though you are obviously not reading my messages.

    Quote Originally Posted by malcolmlewis View Post
    Hi
    The gnome-themes-standard is a src rpm...
    So do you really want to install the source as most of the packages built from the src rpm are installed...
    Yes, for compilation

    Ok thank you guys for the help an all, but let's forget about it.
    Feel free to delete this thread, it's getting nowhere.

    Cheers

  7. #7
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    27,213
    Blog Entries
    15

    Default Re: How to install gnome-themes-standard?

    On Sat 31 Dec 2016 03:46:02 AM CST, benjbouch wrote:

    hcvv;2806080 Wrote:
    > When I search for software that is not in the repos I have, I use
    > https://software.opensuse.org/search
    > Putting gnome-themes-standard in the search field provides me with a
    > resulting Direct Install button for version 3.20.2.
    > Doesn't that work for you?

    No offense, though you are obviously not reading my messages.

    malcolmlewis;2806091 Wrote:
    > Hi
    > The gnome-themes-standard is a src rpm...
    > So do you really want to install the source as most of the packages
    > built from the src rpm are installed...

    Yes, for compilation

    Ok thank you guys for the help an all, but let's forget about it.
    Feel free to delete this thread, it's getting nowhere.

    Cheers


    Hi
    How so? I showed you the command to install the src rpm?

    Now, if you download ( -d, --download-only) only with the zypper command
    (rather than install), then copy to your user directory and use
    rpmbuild (it will create an rpmbuild directory), then any modifications
    can be done as your user, then just switch to root user to install.

    The other option is to just download the src rpm from the search
    feature and use rpmbuild, then you can always use the build service to
    build, locally (with osc) or remotely. We have so many ways to do
    things...

    Threads don't generally get deleted, you never know when
    someone may have the same query...

    --
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    openSUSE Leap 42.1|GNOME 3.16.2|4.1.36-41-default
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!


  8. #8

    Default Re: How to install gnome-themes-standard?

    So you mean that zypper install does not install src packages by default
    In order to install a src I need to use -t srcpackage
    And that's why gnome-themes-standard was not found
    Correct ?

  9. #9
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    27,213
    Blog Entries
    15

    Default Re: How to install gnome-themes-standard?

    Quote Originally Posted by benjbouch View Post
    So you mean that zypper install does not install src packages by default
    In order to install a src I need to use -t srcpackage
    And that's why gnome-themes-standard was not found
    Correct ?
    Hi
    Yes, just like if you want to check(info)/install patches, patterns the -t options is required the type 'package' is the default. I would use the download only option, then you can have a bit more flexibility on what you want to do with it....
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  10. #10

    Default Re: How to install gnome-themes-standard?

    Makes a lot of sense.
    Thanks a lot for your time!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •