Results 1 to 5 of 5

Thread: Pulseaudio not functioning correctly for root

  1. #1

    Question Pulseaudio not functioning correctly for root

    I have observed this on several computers.

    Pulseaudio and audio in general work correctly for non-root users.

    For root, audio works (checked using speaker-test), but connection of applications to pulseaudio is denied. For example, Audio Volume in system tray does not see pulseaudio (shows empty screen), pavucontrol says "Establishing connection to PulseAudio. Please wait ..."

    However, it looks like pulseaudio is running in some form for root.

    When issuing
    Code:
    pulseaudio -D
    
    or 
    
    pulseaudio -D --system
    everything begins working for root after a few seconds. But after a reboot the pulseadio for root is still working improperly.

    I tried to modify some configuration files listed in
    Code:
    man pulseaudio
    but didn't succeed.

    Is the pulseaudio supposed to work for root?

  2. #2

    Unhappy Pulseaudio is not started for root

    Quote Originally Posted by ZStefan View Post
    However, it looks like pulseaudio is running in some form for root.
    I have found that this was wrong. Pulseaudio is not running when root is logged in.

    (Why do some think that root is not human and does not want to manage audio comfortably? Do they think that hearing some sound is enough for root?)

  3. #3
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,241

    Default Re: Pulseaudio not functioning correctly for root

    I think your main problem is loging in as root. Something you should not do.
    And even when you think you can do different, you can not expect from others here to have any experience with that, nor that they will ever try to re-create your problem on their own system.
    Last edited by hcvv; 29-Dec-2016 at 06:57.
    Henk van Velden

  4. #4
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,760

    Default Re: Pulseaudio not functioning correctly for root

    Logging in as root to a GUI can seriously damage your system accidentally. DO NOT DO IT.

    Become root from a normal user login is OK and the recommended method.Also login to a terminal is OK But GUIs mode many files on the fly behind the curtain and thus root can steal ownership breaking things for a normal user.

    This is not Windows this is Linux different rules here.

  5. #5

    Angry That was one more hidden obstacle. Who put it there, why?

    Thanks, I spent hours until I understood that pulseaudio is not root-friendly.

    It is good that other components of audio settings, like Yast's audio module and kmix are runnable by root. Otherwise, root alone would hear no sound. Good that their authors thought differently - at least some must trust their own product.

    Good to know that this is by design, and not a fault in OS, driver or configuration.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •