Results 1 to 2 of 2

Thread: KDE Panel Settings: Wildcarding "horizontal" parameter in ~/.config/plasmashellrc

  1. #1

    Default KDE Panel Settings: Wildcarding "horizontal" parameter in ~/.config/plasmashellrc

    I run Leap in a VM, so the width of the window is always a bit different. It's maximized vertically, but horizontally I leave a bit of space from the host OS visible to the left so I can operate the window pager. Moreover, Leap doesn't remember the window size in my VMware when it's rebooted, so I always have to manually drag it large again.

    Why is this a problem? Because apparently, the panel settings are set specifically only for a single horizontal width. So I first thought my settings were being erased. Actually I was 1px or 2px off so it wasn't binding to the settings I saved. So now to the main question.

    Is there a way to wildcard the horizontal parameter so it covers ALL widths? I want to set the panel to autohide. It would suffice to just make that the default if that's possible.

    Right now I have:

    Code:
    [PlasmaViews][Panel 2][Horizontal1796]
    panelVisibility=0
    ...but I'd prefer not to have to create 100 lines like that with different horizontal settings just to capture the range of window sizes I typically use. I've tried "Horizontal1-2000" "Horizontal*" and "Horizontal" but no joy.

  2. #2

    Default Re: KDE Panel Settings: Wildcarding "horizontal" parameter in ~/.config/plasmashellrc

    I have looked at older SUSE versions, and in OpenSUSE 13.2, it appears that the following syntax will apply to all widths:

    Code:
    [PlasmaViews][Panel 2]
    panelVisibility=1
    i.e. you can just omit the [horizontal1234] setting. However, this doesn't work in Leap 42.2 - so apparently Ben Bitdiddle has broken it.

    Note in the original post I had panelVisibility=0, but counterintuitively, it's actually panelVisibility=1 that enables auto hide mode.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •