Page 1 of 2 12 LastLast
Results 1 to 10 of 20

Thread: FileZilla not working and Kwrite error.

  1. #1

    Default FileZilla not working and Kwrite error.

    Hi All,

    I'm trying to sort out the last few problems with Leap 42.1 (KDE Plasma 5.4.2).

    First of all I would like to get FileZilla working. It installed OK but whenever I attempt to run it, I get the bouncing icon and even something briefly on the panel but then it dies. I have tried reinstalling without success.

    My other main problem is with Kwrite. I can load files, edit and save them but while I have it running it seems to interfere with some other operations and I always get an error message
    KDEInit could not launch '/usr/bin/kwrite'
    when I close the window.

    Any suggestions to solve these problems will be gratefully received.

    Best wishes

    Schrod

  2. #2

    Default Re: FileZilla not working and Kwrite error.

    Hi All

    I have created a new user and found that kwrite works OK for them, but it still throws up the error with my usual login. I presume that the problem is with some configuration file left over from opensuse 13.2 but I don't know which one.

    FileZilla doesn't work on either user.

    If you can give some hints how to solve these problems I would be much obliged.

    All the best

    Schrod

  3. #3

    Default Re: FileZilla not working and Kwrite error.

    Quote Originally Posted by Schrod View Post
    I have created a new user and found that kwrite works OK for them, but it still throws up the error with my usual login. I presume that the problem is with some configuration file left over from opensuse 13.2 but I don't know which one.
    Probably a wrong menu entry?
    If you edited the menu entry in KDE4, that one will still be there. But kwrite has been ported to KF5 and the command line options (and other things) have changed. So the old one might not work any more.

    You should be able to delete it in the menu editor (in worst case, select Edit->Restore System Menu), or delete the corresponding file in ~/.local/share/applications/ (probably named kwrite.desktop, kde4-kwrite.desktop or similar).

    FileZilla doesn't work on either user.
    More details please.
    What exactly does "doesn't work" mean?

    Try to run it in a terminal window, do you get error messages?

  4. #4

    Default Re: FileZilla not working and Kwrite error.

    Thanks for your help wolfi323.

    I deleted kwrite.desktop from ~/.local/share/applications/ and now I have no errors with Kwrite. :-)

    I have run FileZilla in a terminal window and this is the result:

    linux-zhj4:~ # filezilla
    Fatal Error: Mismatch between the program and library build versions detected.
    The library used 3.0 (wchar_t,compiler with C++ ABI 1002,STL containers,compatible with 2.8),
    and your program used 3.0 (wchar_t,compiler with C++ ABI 1009,STL containers,compatible with 2.8).
    Aborted

    According to Yast
    All package dependencies are OK.
    so I am at a loss how to proceed further.

    Regards

    Schrod

  5. #5

    Default Re: FileZilla not working and Kwrite error.

    Quote Originally Posted by Schrod View Post
    I have run FileZilla in a terminal window and this is the result:

    linux-zhj4:~ # filezilla
    Fatal Error: Mismatch between the program and library build versions detected.
    The library used 3.0 (wchar_t,compiler with C++ ABI 1002,STL containers,compatible with 2.8),
    and your program used 3.0 (wchar_t,compiler with C++ ABI 1009,STL containers,compatible with 2.8).
    Aborted
    That's this bug then:
    https://bugzilla.opensuse.org/show_bug.cgi?id=953949

    You maybe could use Konqueror or Dolphin as ftp client as a workaround...

    PS: Where did you install filezilla from? It doesn't seem to be included in Leap at all.
    If it's a left-over from 13.2 e.g, it would explain the error message.
    Code:
    rpm -qi filezilla
    Last edited by wolfi323; 15-Nov-2015 at 04:43.

  6. #6

    Default Re: FileZilla not working and Kwrite error.

    Thanks for your advice. It isn't too much of a problem yet as my main computer is still running 13.2 and FileZilla works on that.

    In response to where I got it from:

    linux-zhj4:~ # rpm -qi filezilla
    Name : filezilla
    Version : 3.14.1
    Release : 70.3
    Architecture: x86_64
    Install Date: Fri Nov 13 17:16:56 2015
    Group : Productivity/Networking/Ftp/Clients
    Size : 5677384
    License : GPL-2.0+
    Signature : RSA/SHA1, Thu Nov 12 13:27:01 2015, Key ID 62eb1a0917280ddf
    Source RPM : filezilla-3.14.1-70.3.src.rpm
    Build Date : Thu Nov 12 13:25:40 2015
    Build Host : build80
    Relocations : (not relocatable)
    Vendor : obs://build.opensuse.org/network
    URL : https://filezilla-project.org/
    Summary : A GUI FTP and SFTP Client
    Description :
    FileZilla is a modern and powerful FTP client.
    FileZilla development focuses on high usability while also
    supporting as many useful features as possible.

    Some of the main features are:
    * Continuing interrupted up-/downloads.
    * Managing different FTP sites.
    * Modifiable Commands.
    * Keep-Alive-System.
    * Timeout detection.
    * Firewall support.
    * SOCKS4/5 and HTTP 1.1 proxy support.
    * SSL support (secure connections).
    * SFTP support.
    * Upload/Download queue.
    * Drag&Drop support.
    Distribution: network / openSUSE_Leap_42.1

    I'll probably wait until I get a working version before I upgrade my other machine.

    Regards

    Schrod

  7. #7

    Default Re: FileZilla not working and Kwrite error.

    Fresh Leap install here, can confirm that FileZilla from the "network" repo also doesnt load for me.

    Code:
    craig@openSUSE:~> filezilla
    Fatal Error: Mismatch between the program and library build versions detecte
    d.
    The library used 3.0 (wchar_t,compiler with C++ ABI 1002,STL containers,comp
    atible with 2.8),
    and your program used 3.0 (wchar_t,compiler with C++ ABI 1009,STL containers
    ,compatible with 2.8).
    Aborted
    
    
    it's disappointing that we even have to add another repo just to get a program that's always been in the opensuse repos in the past :/
    http://cra1g321.deviantart.com ~ Free $10 Credit = https://www.digitalocean.com/?refcode=c815cd864aeb

  8. #8

    Default Re: FileZilla not working and Kwrite error.

    Quote Originally Posted by cra1g321 View Post
    it's disappointing that we even have to add another repo just to get a program that's always been in the opensuse repos in the past :/
    Well, apparently nobody cared enough for it to submit it to Leap.
    And that it doesn't work at all doesn't make it better.

    There are other versions available at software.opensuse.org.
    Maybe one of those would work?

  9. #9

    Default Re: FileZilla not working and Kwrite error.

    Download from
    https://filezilla-project.org/
    all linux platform
    It is missing some library (libpng12.0)
    Install it
    Make a link.
    It seems to work fine
    v

  10. #10

    Default Re: FileZilla not working and Kwrite error.

    Thanks for the suggestion but I have libpng12-0 according to Yast, and FileZilla still does not work :-(


    All the best
    Schrod

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •