Page 1 of 3 123 LastLast
Results 1 to 10 of 25

Thread: CPU running with top speed all the time

  1. #1

    Default CPU running with top speed all the time

    Few days ago i installed a fresh Leap 42.2 so i can use amdgpupro with my new AMD RX 480.
    Installation was standard as suggested from installer, nothing special, except the
    amdgpupro driver 16.50. All went well and the system is running like a charm.
    Unfortunatelly conky, which i use to monitor my system, wasn´t working at that
    time, because they changed their system. After adjusting conky 3 days later i
    noticed, that the cpu was running at full speed all the time without ever clocking
    down.
    I use a Xeon 1230 v3 with 3.3Ghz max speed and 3.7Ghz turbo.
    The cpu is working now with Leap 42.2 between 3.5Ghz and 3.69Ghz never clocking
    down, even if no load is present for the system.(Init 3 for ex)
    Code:
    linux-urgh:~ # cpupower frequency-info 
    analyzing CPU 0:
      driver: intel_pstate
      CPUs which run at the same hardware frequency: 0
      CPUs which need to have their frequency coordinated by software: 0
      maximum transition latency:  Cannot determine or is not supported.
      hardware limits: 800 MHz - 3.70 GHz
      available cpufreq governors: performance powersave
      current policy: frequency should be within 800 MHz and 3.70 GHz.
                      The governor "powersave" may decide which speed to use
                      within this range.
      current CPU frequency: 3.68 GHz (asserted by call to hardware)
      boost state support:
        Supported: yes
        Active: yes
    
    
    Code:
    linux-urgh:~ # cpupower monitor 
        |Nehalem                    || SandyBridge        || Mperf              || RAPL               || Idle_Stats                                                                                                                                                                 
    CPU | C3   | C6   | PC3  | PC6  || C7   | PC2  | PC7  || C0   | Cx   | Freq || pack | core | dram || POLL | C1-H | C1E- | C3-H | C6-H | C7s-                                                                                                                                    
       0|  1.18|  0.89|  0.00|  0.00|| 90.29| 83.81|  0.00||  2.65| 97.35|  3664||4467457|667174|953306||  0.00|  0.11|  0.27|  1.22|  0.94| 94.19                                                                                                                                  
       4|  1.18|  0.89|  0.00|  0.00|| 90.29| 83.81|  0.00||  0.06| 99.94|  3469||4467457|667174|953306||  0.00|  0.00|  1.09|  0.07|  0.00| 98.75                                                                                                                                  
       1|  0.97|  0.41|  0.00|  0.00|| 92.18| 83.81|  0.00||  2.51| 97.49|  3658||4467457|667174|953306||  0.00|  0.01|  0.44|  0.93|  0.43| 95.12                                                                                                                                  
       5|  0.96|  0.41|  0.00|  0.00|| 92.18| 83.81|  0.00||  2.36| 97.64|  3665||4467457|667174|953306||  0.00|  0.00|  0.34|  0.29|  0.08| 96.41                                                                                                                                  
       2|  0.34|  0.47|  0.00|  0.00|| 90.36| 83.81|  0.00||  1.42| 98.58|  3679||4467457|667174|953306||  0.00|  0.03|  7.07|  0.36|  0.49| 90.51                                                                                                                                  
       6|  0.34|  0.47|  0.00|  0.00|| 90.36| 83.81|  0.00||  0.05| 99.95|  3653||4467457|667174|953306||  0.00|  0.00|  1.67|  0.00|  0.00| 98.26                                                                                                                                  
       3|  0.11|  0.00|  0.00|  0.00|| 97.82| 83.81|  0.00||  0.28| 99.72|  3565||4467457|667174|953306||  0.00|  0.10|  0.99|  0.11|  0.00| 98.44                                                                                                                                  
       7|  0.11|  0.00|  0.00|  0.00|| 97.83| 83.81|  0.00||  0.30| 99.70|  3571||4467457|667174|953306||  0.00|  0.00|  0.29|  0.00|  0.00| 99.37     
    
    There is nothing wrong with intel speed-stepping or the mainboard, because the
    cpu is clocking well up and down on a parallel installed Win 7.


    Funny thing is, that with an ubuntu 16.04 and the same amdgpupro driver installed for
    testing purpose, the cpu shows the same problem, with exactly the same high Ghz
    as with Leap 42.2.
    Can anyone without the amdgpupro confirm, that Leap 42.2 is clocking the cpu well
    up and down?
    Can anyone with the amdgpupro confirm, that the cpu is running on turbo speed on
    their system as well? Thx

  2. #2
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    31,301
    Blog Entries
    15

    Default Re: CPU running with top speed all the time

    Hi
    Disable intel_pstate and see if that helps (switch back to acpi), add the following via YaST2 -> System -> Bootloader -> Kernel Parameters tab to the Optional Kernel Command Line Parameter, between the silent and quiet words;
    Code:
    intel_pstate=disable
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  3. #3

    Default Re: CPU running with top speed all the time

    Wow great, that did the job, thank you very very much.
    The cpu is now clocking up and down like it should be.

    It took a bit to insert the command, because yast in KDE as well as yast on command line
    was freezing, when entering the kernel parameters. I insert the command then directly in
    grub on boot. Thx again.

  4. #4
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    16,173

    Default Re: CPU running with top speed all the time

    Inserting at boot in grub is a one time thing the setting is lost on next boot you must do it via Yast or grub-conf to make it permanent

  5. #5
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    31,301
    Blog Entries
    15

    Default Re: CPU running with top speed all the time

    Quote Originally Posted by testi55 View Post
    Wow great, that did the job, thank you very very much.
    The cpu is now clocking up and down like it should be.

    It took a bit to insert the command, because yast in KDE as well as yast on command line
    was freezing, when entering the kernel parameters. I insert the command then directly in
    grub on boot. Thx again.
    Hi
    I would suggest some research on intel_pstate configuration, technically going forward that's what should be used, but might be worth a bug report....?
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  6. #6

    Default Re: CPU running with top speed all the time

    Quote Originally Posted by gogalthorp View Post
    Inserting at boot in grub is a one time thing the setting is lost on next boot you must do it via Yast or grub-conf to make it permanent
    Ah ok, didn´t know that. I try to find a solution then to avoid yast from freezing. Maybe it´s because ubuntu is still installed on my box.

    malcolmlewis

    I don`t know if Leap 42.2 is causing the cpu behavior or the amdgpupro driver, so no good idea right know for a bug report.

    But thanks again for both of you for your great support.

  7. #7
    Join Date
    Nov 2013
    Location
    Kamloops, BC, Canada
    Posts
    3,974

    Default Re: CPU running with top speed all the time

    Quote Originally Posted by testi55 View Post
    Ah ok, didn´t know that. I try to find a solution then to avoid yast from freezing.
    Well, you could add it to the line at boot, just as you did, then launch the Yast Bootloader module, then add that to the boot line in there.
    -Gerry Makaro
    Fraser-Bell Info Tech
    Solving Tech Mysteries since the Olden Days!
    ~~
    If I helped you, consider clicking the Star at the bottom left of my post.

  8. #8

    Default Re: CPU running with top speed all the time

    Coming in to report that this identical problem happened to my Leap 42.2 installation with an Intel i7 4970K.

    Adding "intel_pstate=disable" to the kernel parameters also solved the problem for me.

    cpupower frequency-info now shows "driver: acpi-cpufreq" and "available cpufreq governors: ondemand performance".

    Previously, available cpufreq governors read, "powersave performance". Powersave was the "current policy" but it was not throttling the CPU correctly.

  9. #9
    will honea NNTP User

    Default Re: CPU running with top speed all the time

    On Thu, 29 Dec 2016 03:56:01 +0000, SUSEtoad wrote:

    > Adding "intel_pstate=disable" to the kernel parameters also solved the
    > problem for me.


    Ditto here. I had forgotten where I had seen it - thanks.

    --
    Will Honea

  10. #10

    Default Re: CPU running with top speed all the time

    Quote Originally Posted by malcolmlewis View Post
    ... intel_pstate configuration, technically going forward that's what should be used, but might be worth a bug report
    Is this being worked on?

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •