Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: LxQT not shown as desktop option in session selection

  1. #1
    Join Date
    Jun 2008
    Location
    Raleigh, NC
    Posts
    87

    Default LxQT not shown as desktop option in session selection

    I installed 42.2 (64 bit) with the lxde desktop option. Then I selected all lxqt packages. I don't like the pattern because it installs too much junk, mostly not even related to the desktop.

    I don't see the lxqt option when logging in- It always defaults to lxde (the only installed desktop). While editing sysconfig, I see a lot of options, including desktops NOT installed such as kde and xfce but lxqt is not in the list (lxde is).

    Does it have to do with display manager ? Do I have to install lightdm or something ?
    Dell inspiron model I-7375 2 in 1.
    Ryzen 2500U, 8 GB RAM, SATA SSD, Full disk encryption
    Opensuse Tumbleweed (latest)

  2. #2

    Default Re: LxQT not shown as desktop option in session selection

    Quote Originally Posted by mvaar View Post
    I don't see the lxqt option when logging in- It always defaults to lxde (the only installed desktop).
    Is lxqt-session installed?

    While editing sysconfig, I see a lot of options, including desktops NOT installed such as kde and xfce but lxqt is not in the list (lxde is).
    That list is static and actually irrelevant.
    You can enter anything you like. (but the corresponding xsession file should be installed, otherwise the system will fallback to IceWM or twm).

    Note that this only sets the default choice.
    Most display managers will remember what you last selected, so this probably won't have any conceivable effect at all (unless you use xdm which doesn't offer a choice and always uses the value from sysconfig).

    And it doesn't influence at all what the display manager will offer as choices.

    Does it have to do with display manager ? Do I have to install lightdm or something ?
    Which one are you using now?
    Isn't lightdm the default for a LXDE installation anyway?
    Last edited by wolfi323; 22-Dec-2016 at 10:28.

  3. #3
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    10,935
    Blog Entries
    2

    Default Re: LxQT not shown as desktop option in session selection

    Quote Originally Posted by wolfi323 View Post
    Is lxqt-session installed?


    That list is static and actually irrelevant.
    You can enter anything you like. (but the corresponding xsession file should be installed, otherwise the system will fallback to IceWM or twm).

    Note that this only sets the default choice.
    Most display managers will remember what you last selected, so this probably won't have any conceivable effect at all (unless you use xdm which doesn't offer a choice and always uses the value from sysconfig).

    And it doesn't influence at all what the display manager will offer as choices.


    Which one are you using now?
    Isn't lightdm the default for a LXDE installation anyway?
    Side observation,
    On 42.1, the default DM was lxdm, but I don't see it available in any way in 42.2 (but maybe I should try harder to look for it somewhere?). As long as there are good alternatives that still exist, I haven't followed up on this...

    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

  4. #4

    Default Re: LxQT not shown as desktop option in session selection

    Quote Originally Posted by tsu2 View Post
    Side observation,
    On 42.1, the default DM was lxdm, but I don't see it available in any way in 42.2 (but maybe I should try harder to look for it somewhere?).
    lxdm has been dropped from the distribution a few months ago.

    It will be replaced by lightdm on upgrades, if it was installed.

  5. #5
    Join Date
    Jun 2012
    Location
    Naoussa, Imathia, Greece
    Posts
    9

    Default Re: LxQT not shown as desktop option in session selection

    I have the exact same problem here.
    lxqt-session package is installed, there is a lxqt.desktop file in /usr/share/xsessions/ and still the Lxqt option is not there in SDDM.

    The weird thing is that on another ultrabook using the same version 42.2 the option is there!
    btw did you find a solution?

  6. #6

    Default Re: LxQT not shown as desktop option in session selection

    Quote Originally Posted by diggy128 View Post
    I have the exact same problem here.
    lxqt-session package is installed, there is a lxqt.desktop file in /usr/share/xsessions/ and still the Lxqt option is not there in SDDM.
    The xsession file is in lxqt-common. I take it that is installed, otherwise the lxqt.desktop file would not be in /usr/share/xsessions/ .

    The lxqt option is only shown if lxqt-session is installed too though, are you sure it is?
    Code:
    rpm -q lxqt-session
    Does /usr/bin/lxqt-session exist?
    If not, try to reinstall lxqt-session:
    Code:
    sudo zypper in -f lxqt-session

  7. #7
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    10,935
    Blog Entries
    2

    Default Re: LxQT not shown as desktop option in session selection

    Don't know if you have a special reason to stick with SDDM,
    But I have a number of LXDE and LXQt virtual machines running on 42.1, 42.2, 42.3 and Tumbleweed and I've switched them all over to LightDM with hardly any problems (only one minor issue discussed in another thread where at one time there were 2 LXDE/LXQt entries).

    If you want to support Remote Desktop Administration, you'd have to switch to LightDM anyway, and in 42.3 LightDM is the default.
    If you're adding LXDE/LXQt to another Desktop, you might have another Desktop Manager installed instead.

    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

  8. #8

    Default Re: LxQT not shown as desktop option in session selection

    Quote Originally Posted by tsu2 View Post
    and in 42.3 LightDM is the default.
    Not really, that depends on what you choose during installation.

    If you select GNOME you will get gdm, if you select KDE you will get sddm.
    And a minimum X installation will probably only pull in xdm.

    AFAIK, lightdm is part of the LXQT pattern though, if that's what you mean.

    But I don't think this problem is very related to the displaymanager in use. The .desktop files in /usr/share/xsessions are used/displayed by all of them (except xdm, which doesn't allow to choose a session at all), and I highly doubt there would be an sddm specific bug here (as that would likely affect other sessions too).
    Last edited by wolfi323; 16-Sep-2017 at 05:55.

  9. #9
    Join Date
    Nov 2013
    Location
    Kamloops, BC, Canada
    Posts
    3,974

    Default Re: LxQT not shown as desktop option in session selection

    Quote Originally Posted by tsu2 View Post
    If you want to support Remote Desktop Administration, you'd have to switch to LightDM anyway, and in 42.3 LightDM is the default.
    If you're adding LXDE/LXQt to another Desktop, you might have another Desktop Manager installed instead.

    TSU
    kdm also works for this. I am currently using Xfce with kdm in 42.2 and 42.3 to test some issues, VNC both ways, with TigerVNC and x11vnc working flawlessly.
    -Gerry Makaro
    Fraser-Bell Info Tech
    Solving Tech Mysteries since the Olden Days!
    ~~
    If I helped you, consider clicking the Star at the bottom left of my post.

  10. #10

    Default Re: LxQT not shown as desktop option in session selection

    Quote Originally Posted by Fraser_Bell View Post
    kdm also works for this. I am currently using Xfce with kdm in 42.2 and 42.3 to test some issues, VNC both ways, with TigerVNC and x11vnc working flawlessly.
    Indeed, sddm doesn't support VNC (or XDMCP which is actually the problem).

    lightdm should, gdm as well, and kdm does definitely.

    But that was not asked here AFAICR....

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •