Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: Autostart no longer works

  1. #1
    Join Date
    Aug 2008
    Location
    Mexico and Sweden
    Posts
    1,288

    Default Autostart no longer works

    This works under 42.1...

    Code:
    [Desktop Entry]Comment=
    Exec=pal >/home/ion/TEMP/pal.out;cat /home/ion/TEMP/pal.out /home/ion/TEMP/addon >/home/ion/TEMP/result;more /home/ion/TEMP/result\s
    GenericName=
    Icon=
    Name=Pal
    Path=
    StartupNotify=true
    Terminal=1
    TerminalOptions=
    Type=Application
    X-KDE-SubstituteUID=false
    X-KDE-Username=
    but not under 42.2. Under 42.1 "more" causes the screen print to pause, while the screen never displays under 42.2. The file was directly copied from 42.1 to 42.2.

    Any suggestions would be appreciated.

  2. #2
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,157

    Default Re: Autostart no longer works

    Did you test if the statement works outside of this definition file?
    One could e.g. doubt if the program pal is there (I do not know it), etc., etc.
    Henk van Velden

  3. #3

    Default Re: Autostart no longer works

    Try to set "Terminal=true" instead of "Terminal=1".

    And also try to set xterm as default terminal application in KDE's settings.
    Konsole doesn't handle the '-e' option properly in 16.08 (because it uses Qt's command line parser now which doesn't support rest-of-the-line arguments) and might choke on your Exec line.

    If it still doesn't work with xterm, try to "wrap" your Exec line into a call to sh, i.e.:
    Code:
    Exec=sh -c "pal >/home/ion/TEMP/pal.out;cat /home/ion/TEMP/pal.out /home/ion/TEMP/addon >/home/ion/TEMP/result;more /home/ion/TEMP/result\s"
    Or put that in a script and run the script in the Exec line.

    I very much doubt that such a construct like you have is supported by the official freedesktop.org standard, and may just have worked by luck in KDE previously...
    Last edited by wolfi323; 21-Dec-2016 at 10:01.

  4. #4
    Join Date
    Aug 2008
    Location
    Mexico and Sweden
    Posts
    1,288

    Default Re: Autostart no longer works

    Quote Originally Posted by hcvv View Post
    Did you test if the statement works outside of this definition file?
    One could e.g. doubt if the program pal is there (I do not know it), etc., etc.
    Well when I run the statement from a console, i.e.

    Code:
    ion@linux-erzo:~>pal >/home/ion/TEMP/pal.out;cat /home/ion/TEMP/pal.out /home/ion/TEMP/addon >/home/ion/TEMP/result;more /home/ion/TEMP/result
    
    I get the expected result....

    Code:
         Su   Mo   Tu   We   Th   Fr   Sa
    Dec *11*  12   13  *14*  15   16   17 
         18   19   20  @21@*22**23*
     *24*
         25   26   27   28   29   30   31  
    Jan  01   02   03   04   05  *06*  07  
         08   09   10   11   12   13   14  
    
    Thu 22 Dec 2016 - Tomorrow
    * Test purposes #2
    
    Fri 23 Dec 2016 - 2 days away
    * Test purposes #3
    
    Sat 24 Dec 2016 - 3 days away
    * Test purposes #4
    
        
        
        
        
        
           
        
      
       
       
       
       
       
    
    *
    *
    *
    *
    *
    *
    *
    *
    *
    *
    *
    *
    *
    *
    *
    *
    *
    *
    
    ion@linux-erzo:~> 
    
    
    So "pal", "cat" and "more" are present and properly executed.

  5. #5
    Join Date
    Aug 2008
    Location
    Mexico and Sweden
    Posts
    1,288

    Default Re: Autostart no longer works

    Quote Originally Posted by wolfi323 View Post
    Try to set "Terminal=true" instead of "Terminal=1".
    Did not work.

    .
    And also try to set xterm as default terminal application in KDE's settings..
    This worked but I didn't like xterm's display and I didn't try to configure it.

    If it still doesn't work with xterm, try to "wrap" your Exec line into a call to sh, i.e.:
    Code:
    Exec=sh -c "pal >/home/ion/TEMP/pal.out;cat /home/ion/TEMP/pal.out /home/ion/TEMP/addon >/home/ion/TEMP/result;more /home/ion/TEMP/result\s"
    .
    I was surprised when this didn't work.

    Or put that in a script and run the script in the Exec line..
    Yes I should have thought of that solution, which gives me the results I am accustomed to, and is simpler to modify in future. Many thanks for the suggestions. I learned something new along the way.


  6. #6

    Default Re: Autostart no longer works

    Quote Originally Posted by ionmich View Post
    I was surprised when this didn't work.
    It doesn't work with konsole, because of the mentioned "bug".
    (A fix is in review currently btw)

    It should work with xterm though.

    Btw, something like 'konsole -e "ls;more"' (which effectively is called with Exec=ls;more) doesn't work even with KDE4's konsole here on 13.2. I only get the error message that the command "ls;more" is not found.
    You really need to let that be interpreted by a shell (via sh -c "ls;more" e.g.).
    Last edited by wolfi323; 21-Dec-2016 at 16:58.

  7. #7
    Join Date
    Aug 2008
    Location
    Mexico and Sweden
    Posts
    1,288

    Default Re: Autostart no longer works

    CORRECTION---I was mistaken, the only method that works is using xterm. Now how do I configure xterm? I see no menu options for it.

  8. #8
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,631
    Blog Entries
    3

    Default Re: Autostart no longer works

    Quote Originally Posted by ionmich View Post
    CORRECTION---I was mistaken, the only method that works is using xterm. Now how do I configure xterm? I see no menu options for it.
    I'm not sure what you are looking for. But I think it is this:

    Configure Desktop (system settings) --> Applications --> Default Applications

    Select "Terminal Emulator". Check "Use a different terminal program", and enter "xterm" (without the quotes).
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  9. #9
    Join Date
    Aug 2008
    Location
    Mexico and Sweden
    Posts
    1,288

    Default Re: Autostart no longer works

    Quote Originally Posted by nrickert View Post
    I'm not sure what you are looking for. But I think it is this:

    Configure Desktop (system settings) --> Applications --> Default Applications

    Select "Terminal Emulator". Check "Use a different terminal program", and enter "xterm" (without the quotes).
    My apologies. I did not make my request very clear. Yes, I have set "xterm" as the default. What I would like to have is an "xterm" with large bold courier fonts, white on a black background. I see no way of setting that from within the window "xterm" opens. Like the "Settings" choice in the Konsole menu.

  10. #10
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,631
    Blog Entries
    3

    Default Re: Autostart no longer works

    Quote Originally Posted by ionmich View Post
    My apologies. I did not make my request very clear. Yes, I have set "xterm" as the default. What I would like to have is an "xterm" with large bold courier fonts, white on a black background. I see no way of setting that from within the window "xterm" opens. Like the "Settings" choice in the Konsole menu.
    You put that sort of thing in a ".Xresources" file in your home directory. Or perhaps ".Xdefaults" works.

    It's a while since I used those, but maybe google for: xresources xterm
    and see what shows up.

    With ".Xresources" you probably have to logout and login again before they take effect. So try ".Xdefaults" first (if you don't already have ".Xresources", as that takes effect immediately. The man page of "xterm" gives some hints about possible resources that you can configure, but it's a bit short on detail.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •