Results 1 to 9 of 9

Thread: Gnome Boxes can't create VM

  1. #1

    Default Gnome Boxes can't create VM

    Just installed Gnome Boxes, I cannot create a new VM from iso it says: Failed to start...

    On terminal the output is:

    (gnome-boxes:7740): Boxes-WARNING **: machine.vala:606: Failed to start Peppermint-7-20161201-amd64: Unable to start domain: internal error: process exited while connecting to monitor: spice-qemu-char: unsupported type: smartcard
    allowed names: vdagent, usbredir
    qemu-system-x86_64: qemu-char.c:4533: qmp_chardev_add: Assertion `!i' failed.

  2. #2
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,661
    Blog Entries
    15

    Default Re: Gnome Boxes can't create VM

    On Sun 18 Dec 2016 12:56:01 AM CST, moe Kernel wrote:

    Just installed Gnome Boxes, I cannot create a new VM from iso it says:
    Failed to start...

    On terminal the output is:

    (gnome-boxes:7740): Boxes-WARNING **: machine.vala:606: Failed to start
    Peppermint-7-20161201-amd64: Unable to start domain: internal error:
    process exited while connecting to monitor: spice-qemu-char: unsupported
    type: smartcard
    allowed names: vdagent, usbredir
    qemu-system-x86_64: qemu-char.c:4533: qmp_chardev_add: Assertion `!i'
    failed.


    Hi
    I see the same error, asking my GNOME contacts to see if it's known
    about...

    --
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    openSUSE Leap 42.1|GNOME 3.16.2|4.1.36-41-default
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!


  3. #3
    Join Date
    Jun 2014
    Location
    Italy
    Posts
    76

    Default Re: Gnome Boxes can't create VM

    Any update on this one? Boxes is still broken here.

  4. #4
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,661
    Blog Entries
    15

    Default Re: Gnome Boxes can't create VM

    Quote Originally Posted by lorenzodes View Post
    Any update on this one? Boxes is still broken here.
    Hi
    I moved on to just use virt-manager..... (boxes is just a front end to libvirt)...

    What is not working, did you run gnome-boxes --checks? Is libvirtd service enabled and running?
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  5. #5
    Join Date
    Jun 2014
    Location
    Italy
    Posts
    76

    Default Re: Gnome Boxes can't create VM

    Quote Originally Posted by malcolmlewis View Post
    Hi
    I moved on to just use virt-manager..... (boxes is just a front end to libvirt)...

    What is not working, did you run gnome-boxes --checks? Is libvirtd service enabled and running?
    It's the same problem reported by the OP:
    Code:
    (gnome-boxes:545): Boxes-WARNING **: vm-creator.vala:155: Failed to start domain 'opensuse42.2': Unable to start domain: internal error: process exited while connecting to monitor: spice-qemu-char: unsupported type: smartcard
    allowed names: vdagent, usbredir
    qemu-system-x86_64: qemu-char.c:4540: qmp_chardev_add: Assertion `!i' failed.
    
    
    (gnome-boxes:545): Boxes-WARNING **: machine.vala:606: Failed to start openSUSE Leap 42.2: Unable to start domain: internal error: process exited while connecting to monitor: spice-qemu-char: unsupported type: smartcard
    allowed names: vdagent, usbredir
    qemu-system-x86_64: qemu-char.c:4540: qmp_chardev_add: Assertion `!i' failed.

  6. #6
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    11,125
    Blog Entries
    2

    Default Re: Gnome Boxes can't create VM

    Recommend submitting a bug report at https://bugzilla.opensuse.org

    Referencing
    https://bugs.launchpad.net/ubuntu/+s...s/+bug/1484118

    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

  7. #7
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,661
    Blog Entries
    15

    Default Re: Gnome Boxes can't create VM

    On Sat 03 Jun 2017 08:36:01 AM CDT, lorenzodes wrote:

    malcolmlewis;2825215 Wrote:
    > Hi
    > I moved on to just use virt-manager..... (boxes is just a front end to
    > libvirt)...
    >
    > What is not working, did you run gnome-boxes --checks? Is libvirtd
    > service enabled and running?


    It's the same problem reported by the OP:

    Code:
    --------------------

    (gnome-boxes:545): Boxes-WARNING **: vm-creator.vala:155: Failed to
    start domain 'opensuse42.2': Unable to start domain: internal error:
    process exited while connecting to monitor: spice-qemu-char:
    unsupported type: smartcard allowed names: vdagent, usbredir
    qemu-system-x86_64: qemu-char.c:4540: qmp_chardev_add: Assertion `!i'
    failed. (gnome-boxes:545): Boxes-WARNING **: machine.vala:606: Failed
    to start openSUSE Leap 42.2: Unable to start domain: internal error:
    process exited while connecting to monitor: spice-qemu-char:
    unsupported type: smartcard allowed names: vdagent, usbredir
    qemu-system-x86_64: qemu-char.c:4540: qmp_chardev_add: Assertion `!i'
    failed. --------------------


    Hi
    All fixed now: https://build.opensuse.org/request/show/500765

    --
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    openSUSE Leap 42.2|GNOME 3.20.2|4.4.62-18.6-default
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!


  8. #8
    Join Date
    Jun 2014
    Location
    Italy
    Posts
    76

    Default Re: Gnome Boxes can't create VM

    Thank you for the patch.

    I am new to this whole process, how long till the working packages shows up in the official repos?

  9. #9
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,661
    Blog Entries
    15

    Default Re: Gnome Boxes can't create VM

    Quote Originally Posted by lorenzodes View Post
    Thank you for the patch.

    I am new to this whole process, how long till the working packages shows up in the official repos?
    Hi
    The fix was by one of the openSUSE GNOME MAintainers, not me, he just advised it was fixed (See they do keep an eye of forum posts... )

    Not sure, depends how busy the reviewers are. You could grab the build binaries from OBS, but probably better to wait.
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •