Results 1 to 4 of 4

Thread: Software Management "crashes"

  1. #1
    Join Date
    Jul 2014
    Location
    Round Rock, TX
    Posts
    76

    Default Software Management "crashes"

    Good morning all,

    I will open YaST from the KDE menu, and that loads without error. I click on Software Management, which loads and then "crashes". I then opened a terminal session, entered su (and password), and ran yast2 --qt. Software Manager attempted to run, but then "crashed", and I received the following:
    Code:
    computer_name:/home/michael # yast2 --qt
    Run command: /sbin/yast2 sw_single &
    YaST got signal 11 at file /usr/share/YaST2/modules/PackagesUI.rb:312
      sender PID: 504
    /sbin/yast2: line 440:  5633 Segmentation fault      $ybindir/y2base $module "$@" "$SELECTED_GUI" $Y2_GEOMETRY $Y2UI_ARG
    S
    Can anyone shed some light on what this means and how I can get it fixed?

    Thanks in advance,
    Mike

  2. #2
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,744

    Default Re: Software Management "crashes"

    Be sure are not mixing yast mods from other repos

    Show zypper lr -d if in doubt

  3. #3
    Join Date
    Jul 2014
    Location
    Round Rock, TX
    Posts
    76

    Default Re: Software Management "crashes"

    Quote Originally Posted by gogalthorp View Post
    Be sure are not mixing yast mods from other repos

    Show zypper lr -d if in doubt
    Thanks for responding.This is what I get when I run the command:
    Code:
    #  | Alias                               | Name                                    | Enabled | GPG Check | Refresh | Priority | Type   | URI                                                            
             | Service
    ---+-------------------------------------+-----------------------------------------+---------+-----------+---------+----------+--------+----------------------------------------------------------------
    ---------+--------                                                                                                       
     1 | Packman                             | Packman                                 | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://ftp.gwdg.de/pub/linux/misc/packman/suse/openSUSE_Leap_42
    .1/      |                                                                                                               
     2 | google-chrome                       | google-chrome                           | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://dl.google.com/linux/chrome/rpm/stable/x86_64            
             |                                                                                                               
     3 | http-download.opensuse.org-6b6b72cd | openSUSE:Leap:42.1:NonFree              | Yes     | (r ) Yes  | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/leap/42.1/repo/non-os
    s/       |                                                                                                               
     4 | http-download.opensuse.org-8546ae9d | Education                               | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/Education/openSUSE_Le
    ap_42.1/ |                                                                                                               
     5 | openSUSE-42.1-0                     | openSUSE-42.1-0                         | Yes     | (r ) Yes  | No      |   99     | yast2  | cd:///?devices=/dev/disk/by-id/ata-HL-DT-ST_DVD+_-RW_GU40N_KWGB
    3H82724  |                                                                                                                                                            
     6 | repo-debug                          | openSUSE-Leap-42.1-Debug                | No      | ----      | Yes     |   99     | NONE   | http://download.opensuse.org/debug/distribution/leap/42.1/repo/
    oss/     |         
     7 | repo-debug-non-oss                  | openSUSE-Leap-42.1-Debug-Non-Oss        | No      | ----      | Yes     |   99     | NONE   | http://download.opensuse.org/debug/distribution/leap/42.1/repo/
    non-oss/ |         
     8 | repo-debug-update                   | openSUSE-Leap-42.1-Update-Debug         | No      | ----      | Yes     |   99     | NONE   | http://download.opensuse.org/debug/update/leap/42.1/oss        
             |         
     9 | repo-debug-update-non-oss           | openSUSE-Leap-42.1-Update-Debug-Non-Oss | No      | ----      | Yes     |   99     | NONE   | http://download.opensuse.org/debug/update/leap/42.1/non-oss/   
             |         
    10 | repo-non-oss                        | openSUSE-Leap-42.1-Non-Oss              | No      | ----      | Yes     |   99     | NONE   | http://download.opensuse.org/distribution/leap/42.1/repo/non-os
    s/       |         
    11 | repo-oss                            | openSUSE-Leap-42.1-Oss                  | Yes     | (r ) Yes  | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/leap/42.1/repo/oss/  
             |         
    12 | repo-source                         | openSUSE-Leap-42.1-Source               | No      | ----      | Yes     |   99     | NONE   | http://download.opensuse.org/source/distribution/leap/42.1/repo
    /oss/    |         
    13 | repo-update                         | openSUSE-Leap-42.1-Update               | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/leap/42.1/oss/             
             |         
    14 | repo-update-non-oss                 | openSUSE-Leap-42.1-Update-Non-Oss       | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/leap/42.1/non-oss/         
             |        
    
    
    I'm not sure what you are saying mixing yast mods. Sorry for my ignorance.

    Thanks,
    Mike

  4. #4
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,744

    Default Re: Software Management "crashes"

    Those look OK there are repos that exist that may have different software versions on them mixing version is bad. Sorry don't have a solution

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •