Results 1 to 6 of 6

Thread: Problem upgrading to CUPS 2.2.1

  1. #1
    Join Date
    Apr 2015
    Location
    Indiana
    Posts
    87

    Default Problem upgrading to CUPS 2.2.1

    I have had CUPS 1.7.5 operating fine for a while and as I was researching I found that CUPS releases was up to 2.2.1 so I downloaded the file from

    HTML Code:
    https://github.com/apple/cups/releases
    Then I followed the INSTALL.txt file and ran the following commands with no errors.

    Code:
    ./configuration
    Code:
    make
    After restarting CUPS and accessing the CUPS server page I am still running 1.7.5.

    What did I do wrong to not complete the upgrade? What should my next step be to either remove the 2.2.1 files or complete the upgrade?
    Bryan Sailer
    SpaceMonkey
    openSUSE LEAP 15.1
    KDE
    "Don't sweat the small stuff, it's all small stuff"

  2. #2
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,384

    Default Re: Problem upgrading to CUPS 2.2.1

    While I personally would not try to replace software that was part of my openSUSE version and that was "operating fine" with some other version from outside, I assume that de-installing the official openSUSE vesion (through YaST or zypper) would be something to be done before trying to install the self build version.
    Henk van Velden

  3. #3
    Join Date
    Apr 2015
    Location
    Indiana
    Posts
    87

    Default Re: Problem upgrading to CUPS 2.2.1

    hcvv,
    You bring up a great point I was just reading the latest versions of CUPS and I thought I would try the latest version. I have removed the 2.2.1 files and directories and moved on to other projects. I posted the question to see if anyone else had installed a new version of CUPS. Thank you for the advice.
    Bryan Sailer
    SpaceMonkey
    openSUSE LEAP 15.1
    KDE
    "Don't sweat the small stuff, it's all small stuff"

  4. #4
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,384

    Default Re: Problem upgrading to CUPS 2.2.1

    Quote Originally Posted by bryansailer View Post
    I have removed the 2.2.1 files and directories and
    You mean you deleted the (maybe only some) files, but did not de-install the package? A bit like removing the legs from under the table?
    Henk van Velden

  5. #5
    Join Date
    Apr 2015
    Location
    Indiana
    Posts
    87

    Default Re: Problem upgrading to CUPS 2.2.1

    I deleted the files I downloaded and when I search in YAST I do not find CUPS 2.2.1. Your advice about sticking with the installed opensuse version is what I am going to do. Why fix something that is not broken. Than you for all of the help.
    Bryan Sailer
    SpaceMonkey
    openSUSE LEAP 15.1
    KDE
    "Don't sweat the small stuff, it's all small stuff"

  6. #6
    Join Date
    Jun 2008
    Location
    Stoney Stanton - England
    Posts
    1,108

    Default Re: Problem upgrading to CUPS 2.2.1

    I see that you have decided to stick with cups 1.7.5 but if you change your mind just use the repo up-date for 42.1 printing at:

    http://download.opensuse.org/reposit...USE_Leap_42.1/

    This has cups 2.1.3

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •