Results 1 to 5 of 5

Thread: gnome 3.20.4 No way to lock the screen

  1. #1
    Join Date
    Mar 2010
    Location
    Southern Europe
    Posts
    352

    Default gnome 3.20.4 No way to lock the screen

    Hi,
    Does anybody know how to lock the screen in gnome. Ctr+Alt+l does nothing.
    There is an extension named "lock screen" that is supposed to add an icon to the panel with that function. It does add the icon, but clicking on it nothing happens.
    Any idea.
    Thanks in advance.

  2. #2
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,864
    Blog Entries
    15

    Default Re: gnome 3.20.4 No way to lock the screen

    Hi
    It's super+l or the system menu (upside down triangle top right) and press the padlock icon.

    To see the other settings/shortcuts go to the keyboard in system settings.
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  3. #3
    Join Date
    Mar 2010
    Location
    Southern Europe
    Posts
    352

    Default Re: gnome 3.20.4 No way to lock the screen

    Quote Originally Posted by malcolmlewis View Post
    Hi
    It's super+l or the system menu (upside down triangle top right) and press the padlock icon.

    To see the other settings/shortcuts go to the keyboard in system settings.
    Thank you.
    super+l does nothing
    The triangle in the top right corner is there, but no padlock icon.
    According to settings/keyboard, the shortcut is super+l as you say. I tried to change it, but the new one does nothing either.

    It looks like there is some missing package. But I don't know. I am new in gnome (I've been using kde for 12 years).
    Any other idea?
    Thanks anyway.

  4. #4
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,864
    Blog Entries
    15

    Default Re: gnome 3.20.4 No way to lock the screen

    Hi
    I'm guessing your not using gdm, this needs to be used for the login manager... if it's not installed install gdm, then switch to it via YaST -> System -> /etc/sysconfig Editor, then Desktop -> Display manager -> DISPLAYMANAGER select gmd in the dropdown, logout/login.

    See: https://doc.opensuse.org/release-not...ec.general.gdm
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  5. #5
    Join Date
    Mar 2010
    Location
    Southern Europe
    Posts
    352

    Default Re: gnome 3.20.4 No way to lock the screen

    Quote Originally Posted by malcolmlewis View Post
    Hi
    I'm guessing your not using gdm, this needs to be used for the login manager... if it's not installed install gdm, then switch to it via YaST -> System -> /etc/sysconfig Editor, then Desktop -> Display manager -> DISPLAYMANAGER select gmd in the dropdown, logout/login.

    See: https://doc.opensuse.org/release-not...ec.general.gdm
    You were right.
    gdm was installed, but the display manager in sysconfig needed to be changed. I did it and now it works perfectly.
    Thanks a lot for your useful advice.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •