Results 1 to 2 of 2

Thread: CentOS 6.8 server with SUSE repo?

  1. #1

    Default CentOS 6.8 server with SUSE repo?

    have a successful repo server (CentOS 6.8), with repos for CentOS 5, 6, 7, and RHEL, 5, 6, 7, and am looking at setting up a SUSE repo on the same host server.

    I downloaded all SUSE package files onto my host server.
    On my client machines, I have the /etc/zypp/repos.d/mysuse.repo file pointing to my server. Running zypper, the clients find the server, but then the following error occurs (going from my memory):

    Can't locate 'media.1/media' file.

    I do have a media.1/media folder/file using the same folder structure as my source for SUSE package files.
    I read the media file and it has a bit of info, but nothing descriptive.

    My question: What does the media.1/media file need to contain so that my SUSE repo can be found??


  2. #2
    Join Date
    Jun 2008
    San Diego, Ca, USA
    Blog Entries

    Default Re: CentOS 6.8 server with SUSE repo?

    You'll have to be more precise how you generated that error, not just the importance of quoting the error correctly.

    So, for instance IMO there is a big difference between setting up a private repo vs trying to install the packages in that repo on your Host if that is indeed what you tried to do.

    I can't find any recent, up to date info but AFAIK in this Forum post long ago I described one method and provided a link to an SDB that is probably still mostly usable.

    And, of course rsync is probably the best way to create and keep your mirror up to date.

    Beginner Wiki Quickstart -
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts