I have added a custom source highlighting file to Kate. In 42.1, this highlighting was applied automatically when I opened a file with the specified ending (in this case *.sas). In 42.2, this no longer happens. I need to apply the highlighting by choosing the file type through Kate's Tools-Highlighting menu, where my custom highlighting file properly appears as Sources/SAS which is how I configured it. I've created a Mime type in the KDE system settings file types menu for files with this ending and the system recognizes it - for example, the icon I associated with these files shows up in Dolphin as it should. As I've said this all worked in 42.1. My configuration was exactly the same then as it is now -- I preserved my home directory and the settings stayed as they were, which I confirmed both in Kate and in KDE system settings. How do I get the highlighting to appear automatically as it did in 42.1 (and as far back as OpenSuse 11.0, for that matter)?

Thanks.