Results 1 to 7 of 7

Thread: No desktop effects

  1. #1

    Default No desktop effects

    I'm running SESE Leap 42.1 on a machine with AMD videocard HD 7700 and I don't know how to enable 3D-effects. I have fglrx driver installed, and Radeon Control Center tells me that OpenGL vendor is AMD. On previous versions of SUSE I used to go to the Desctop Effects in System Settings to check out OpenGL parameters, but in 42.1 I don't have an OpenGL tab in Desktop Effects. What should I do to enable OpenGL and 3D effects?

  2. #2
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,769

    Default Re: No desktop effects

    Be sure you are running systemsettings5 if you upgraded then the KDE4 version may still be in the menu

  3. #3

    Default Re: No desktop effects

    Quote Originally Posted by gogalthorp View Post
    Be sure you are running systemsettings5 if you upgraded then the KDE4 version may still be in the menu
    I do use systemsettings5.

    Don't know if it is related, but when start systemsettings5 from the console and navigate to Desctop Effects I see this message in console:
    Constructing a KPluginInfo object from old style JSON. Please use kcoreaddons_desktop_to_json() for "/usr/lib64/qt5/plugins/kwin/effects/configs/kcm_kwin4_genericscripted.so" instead of kservice_desktop_to_json() in your CMake code.
    And when I try to preview(???) the effect (pressing the button with the film icon) the app crashes with the segfault.

  4. #4
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,769

    Default Re: No desktop effects

    Are you sure you have all the correct repositories? Did you install any of the newer KDE stuff???

    Sounds like maybe you have incompatible repos.

  5. #5

    Default Re: No desktop effects

    Quote Originally Posted by gogalthorp View Post
    Are you sure you have all the correct repositories? Did you install any of the newer KDE stuff???

    Sounds like maybe you have incompatible repos.
    Code:
    :~> zypper lr
    #  | Псевдоним                           | Name                                    | Enabled | Проверка GPG | Refresh
    ---+-------------------------------------+-----------------------------------------+---------+--------------+--------
     1 | AMD_flrgx                           | AMD flrgx                               | Yes     | (r ) Yes     | Yes    
     2 | LOCAL_REPO                          | LOCAL_REPO                              | Yes     | ( p) Yes     | Yes    
     3 | http-download.opensuse.org-28158c99 | Application:Geo                         | Yes     | (r ) Yes     | Yes    
     4 | http-download.opensuse.org-3ee10fca | openSUSE:Leap:42.1:NonFree              | Yes     | (r ) Yes     | Yes    
     5 | http-download.opensuse.org-b4b482b2 | devel:languages:python                  | Yes     | (r ) Yes     | Yes    
     6 | http-download.opensuse.org-e732e9ab | science                                 | Yes     | (r ) Yes     | Yes    
     7 | libdvdcss                           | libdvdcss                               | Yes     | (r ) Yes     | Yes    
     8 | openSUSE-42.1-0                     | openSUSE-42.1-0                         | Yes     | (r ) Yes     | No     
     9 | packman                             | packman                                 | Yes     | (r ) Yes     | Yes    
    10 | repo-debug                          | openSUSE-Leap-42.1-Debug                | No      | ----         | Yes    
    11 | repo-debug-non-oss                  | openSUSE-Leap-42.1-Debug-Non-Oss        | No      | ----         | Yes    
    12 | repo-debug-update                   | openSUSE-Leap-42.1-Update-Debug         | No      | ----         | Yes    
    13 | repo-debug-update-non-oss           | openSUSE-Leap-42.1-Update-Debug-Non-Oss | No      | ----         | Yes    
    14 | repo-non-oss                        | openSUSE-Leap-42.1-Non-Oss              | No      | ----         | Yes    
    15 | repo-oss                            | openSUSE-Leap-42.1-Oss                  | Yes     | (r ) Yes     | Yes    
    16 | repo-source                         | openSUSE-Leap-42.1-Source               | No      | ----         | Yes    
    17 | repo-update                         | openSUSE-Leap-42.1-Update               | Yes     | (r ) Yes     | Yes    
    18 | repo-update-non-oss                 | openSUSE-Leap-42.1-Update-Non-Oss       | Yes     | (r ) Yes     | Yes
    Actually I don't remember if I updated SUSE or just installed new version on this particular machine. But I do remember that visual effects worked some time ago because I like to have background of my konsole transparent and I notices that something is wrong about effects because it became non-transparent.

  6. #6
    Join Date
    Sep 2008
    Posts
    2,997

    Default Re: No desktop effects

    fiy if kwin5 crashes desktop effects are turned off automatically so check if composing is on and see check the state of desktop effects
    you can filter the desired option in ksystemsettings5
    if you can't find the desired option write opengl in the top right corner the desired button should stand out

  7. #7

    Default Re: No desktop effects

    Quote Originally Posted by I_A View Post
    fiy if kwin5 crashes desktop effects are turned off automatically so check if composing is on and see check the state of desktop effects
    you can filter the desired option in ksystemsettings5
    if you can't find the desired option write opengl in the top right corner the desired button should stand out
    Thanks for the hint with the search bar! OpenGL settings were moved from Desktop Effects to Display and Monitor -> Compositor (but WHY!? that's irrational). The issue is solved.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •