Results 1 to 4 of 4

Thread: KDE Versions With Krypton

  1. #1
    Join Date
    Jun 2008
    Location
    Miami, OK
    Posts
    64

    Default KDE Versions With Krypton

    I've switched my repositories over from Tumbleweed to Krypton and just wonder if I have everything right. Could anyone confirm that my KDE versions are as they should be?
    KDE Plasma 5.7.95
    KDE Frameworks 5.28.0
    QT Version 5.7.0

    Everything seems to be working fine, but just want to make sure I have what I should for the current KDE versions in my system.
    Thanks!
    MSI K9NGM4-V V2
    AMD Athlon 64 X2 4600+(4GB RAM)
    NVIDIA GT218
    Acer P215H
    OpenSUSE Tumbleweed (64 Bit)

  2. #2

    Default Re: KDE Versions With Krypton

    Quote Originally Posted by zenarcher View Post
    I've switched my repositories over from Tumbleweed to Krypton and just wonder if I have everything right. Could anyone confirm that my KDE versions are as they should be?
    KDE Plasma 5.7.95
    KDE Frameworks 5.28.0
    QT Version 5.7.0
    Well, how did you determine those versions?

    I assume kinfocenter.
    And that takes the Plasma version from /usr/share/xsessions/plasma5.desktop, which hasn't been updated in a while in the unstable repos it seems (an oversight, but just cosmetical).

    The actual package versions (e.g. kwin5, plasma5-workspace, kconfig, or one of the many others) should tell more.

    And/or better show your repo list to see that you did the right thing:
    Code:
    zypper lr -d
    Everything seems to be working fine, but just want to make sure I have what I should for the current KDE versions in my system.
    Then it should be fine I suppose.

    Btw (on a technical note), you do not really "switch from Tumbleweed to Krypton".
    Krypton is just a LiveCD based on Tumbleweed but with the latest KDE git versions from the KDE:Unstable repos.

    In the end, you just added the KDE:Unstable repos to your Tumbleweed system.
    At least that's what I hope you did, and not remove the standard Tumbleweed repos... (otherwise you will run into troubles soon)
    Last edited by wolfi323; 01-Dec-2016 at 06:26.

  3. #3
    Join Date
    Jun 2008
    Location
    Miami, OK
    Posts
    64

    Default Re: KDE Versions With Krypton

    Quote Originally Posted by wolfi323 View Post
    Well, how did you determine those versions?

    I assume kinfocenter.
    And that takes the Plasma version from /usr/share/xsessions/plasma5.desktop, which hasn't been updated in a while in the unstable repos it seems (an oversight, but just cosmetical).

    The actual package versions (e.g. kwin5, plasma5-workspace, kconfig, or one of the many others) should tell more.

    And/or better show your repo list to see that you did the right thing:
    Code:
    zypper lr -d

    Then it should be fine I suppose.

    Btw (on a technical note), you do not really "switch from Tumbleweed to Krypton".
    Krypton is just a LiveCD based on Tumbleweed but with the latest KDE git versions from the KDE:Unstable repos.

    In the end, you just added the KDE:Unstable repos to your Tumbleweed system.
    At least that's what I hope you did, and not remove the standard Tumbleweed repos... (otherwise you will run into troubles soon)
    Thanks!! Poor wording on my part. Yes, that's exactly what I did. Just added the KDE:Unstable repos to the Tumbleweed install I've been using. Everything seems to be working fine. Just wanted to verify that I had things as they should be, as this Krypton is not something I've tried before. Tumbleweed has been great.
    MSI K9NGM4-V V2
    AMD Athlon 64 X2 4600+(4GB RAM)
    NVIDIA GT218
    Acer P215H
    OpenSUSE Tumbleweed (64 Bit)

  4. #4

    Default Re: KDE Versions With Krypton

    Quote Originally Posted by zenarcher View Post
    Thanks!! Poor wording on my part.
    No problem.

    Yes, that's exactly what I did. Just added the KDE:Unstable repos to the Tumbleweed install I've been using.
    Ok, but I hope you ran "zypper dup" afterwards, just adding repos won't change your system.

    But that seems to be fine too, according to your version numbers...

    Btw, the packages are updated mostly automatically from git by OBS (ok, a manual retrigger is required, but that can be done by a script too, even a cronjob... ).
    And that's why the plasma5.session version number is outdated, that one we provide on our own unrelated to upstream git and apparently it has been forgotten to update it manually.

    And one thing I'd like to add: the KDE:Unstable repos do exist for quite a while (years), they just were not advertised as such.
    Krypton (the LiveCD) is new, and a good thing to try the latest KDE git versions without having to install it...

    And there's also Argon, which is based on Leap (42.2 currently), but also with the latest unstable KDE git packages.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •