Results 1 to 4 of 4

Thread: problem with new terminal in link to application

  1. #1
    Join Date
    Nov 2015
    Posts
    15

    Default problem with new terminal in link to application

    I have been trying to set up a "link to application" that will run ssh in a new terminal. Previously I had no problem setting such a link, all I had to do is specify in the "advanced options" menu that the application was to run in a new terminal. However, when I use the "run in terminal" option under "advanced options" and click on the icon, the program seems to run but the new terminal never appears. Does anyone know how to solve this problem?

  2. #2
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    24,722

    Default Re: problem with new terminal in link to application

    This is obviously in some desktop environment. But which one?
    Henk van Velden

  3. #3

    Default Re: problem with new terminal in link to application

    I assume it's KDE/Plasma5 for now.

    What is the exact ssh command line that you entered?

    There is a problem in konsole currently in that it doesn't properly handle the -e parameter (which is used to run the command if the "Run in terminal" option is activated). To be precise, options (i.e. things that start with '-') that follow -e are treated as options for konsole itself and therefore can/will make konsole fail to start.
    Actually this is a limitation in Qt itself, it doesn't support "rest of the line" command line options.

    As a workaround, set xterm as default terminal application in "Configure Desktop"->Applications->Default Applications.

  4. #4
    Join Date
    Nov 2015
    Posts
    15

    Default Re: problem with new terminal in link to application

    Quote Originally Posted by wolfi323 View Post
    I assume it's KDE/Plasma5 for now.


    What is the exact ssh command line that you entered?

    There is a problem in konsole currently in that it doesn't properly handle the -e parameter (which is used to run the command if the "Run in terminal" option is activated). To be precise, options (i.e. things that start with '-') that follow -e are treated as options for konsole itself and therefore can/will make konsole fail to start.
    Actually this is a limitation in Qt itself, it doesn't support "rest of the line" command line options.

    As a workaround, set xterm as default terminal application in "Configure Desktop"->Applications->Default Applications.
    Thank you for your help. Your guess was right: I am using KDE/Plasma5, and the workaround that you suggested works. The ssh command that I am using is "ssh -l dws address of server"

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •