Results 1 to 6 of 6

Thread: prevent windows going below task manager

  1. #1
    Join Date
    Jun 2008
    Location
    NZ
    Posts
    1,546

    Default prevent windows going below task manager

    Using openSUSE Leap 42.2 with Plasma 5.8.4 (from plasma repo) some windows slip below the task manager preventing access to ok/apply/cancel buttons.
    Even when the windows are maximised these buttons still stay below the task manager.
    This appears to happen with both QT and GTK applications.
    Here is the batter / power management dialogue in plasma - and it cannot be resized to fit - (it also happens for me with Handbrake)

    Is there a setting to prevent this happening?




    (edit) - I should aslo point out that the panel setting is set to "always visible"
    Mark F.
    openSUSE Leap 15.1 / Plasma 5.12



  2. #2

    Default Re: prevent windows going below task manager

    Quote Originally Posted by farcusnz View Post
    (edit) - I should aslo point out that the panel setting is set to "always visible"
    Well, then it is to be expected that windows go below the panel.
    There is another option that windows can cover the panel though (in KDE4 at least, cannot check Plasma5 at the moment, but it should be there too).

    Or make the window to show "Always on top" via the window menu->"More Actions" (you can even add a button to the window title bar that does that) or the task manager's right-click menu.

    Alternatively you can drag and move the window at any empty space (for KDE applications at least) or move it by holding Alt and clicking/dragging it, or by choosing "Move" in the task manager context menu or the window menu. This way you don't have to be able to reach the title bar.
    You can even resize it that way by holding Alt and *right* clicking/dragging, or again the beforementioned menus.

  3. #3
    Join Date
    Jun 2008
    Location
    NZ
    Posts
    1,546

    Default Re: prevent windows going below task manager

    Quote Originally Posted by wolfi323 View Post
    Well, then it is to be expected that windows go below the panel.
    There is another option that windows can cover the panel though (in KDE4 at least, cannot check Plasma5 at the moment, but it should be there too).

    Or make the window to show "Always on top" via the window menu->"More Actions" (you can even add a button to the window title bar that does that) or the task manager's right-click menu.

    Alternatively you can drag and move the window at any empty space (for KDE applications at least) or move it by holding Alt and clicking/dragging it, or by choosing "Move" in the task manager context menu or the window menu. This way you don't have to be able to reach the title bar.
    You can even resize it that way by holding Alt and *right* clicking/dragging, or again the beforementioned menus.
    Thanks for the reply but I think perhaps you have misunderstood my problem (or I may not have been clear).
    This is a new behaviour that I did not see in earlier releases of plasma 5.
    If I select "more actions > keep above" then the power management window is then above the task manager but the ok/apply/cancel buttons are still off screen.
    Indeed I can move the window around and can even adjust the window width but it will not let me adjust the window height no matter what is tried.
    The only way to access ok/apply/cancel (in this power management window at least) is to move the window up. There is no way to fit the full window within the boundaries of the screen.

    Even when maximised this window stays below the task manager / or off screen if keep above is selected . I have never seen this before on any operating system . . . and indeed in plasma 5.8 most other windows behave as expected. The only windows I can reproduce this strange behaviour on are the power management window in plasma, Handbrake-gtk and MKVToolNix GUI
    I'm sure there may be others that I haven't yet seen but as already mentioned - the majority of windows behave as expected - ie they sit above task manager when maximised and can be resized in all directions.
    Mark F.
    openSUSE Leap 15.1 / Plasma 5.12



  4. #4

    Default Re: prevent windows going below task manager

    Quote Originally Posted by farcusnz View Post
    Thanks for the reply but I think perhaps you have misunderstood my problem (or I may not have been clear).
    No, I don't think that I misunderstood you.
    Your main problem is that some windows are too big to fit onto the screen.

    But the title of this thread is "prevent windows going below task manager" (I suppose you mean the panel), so I tried to cover that as well.

    This is a new behaviour that I did not see in earlier releases of plasma 5.
    The "Energy settings" window you show is a known "bug" in kcmshell5. It apparently sizes the window big enough to not show scroll bars and doesn't regard the screen size.
    See https://bugzilla.opensuse.org/show_bug.cgi?id=1001272 and https://bugs.kde.org/show_bug.cgi?id=366299.

    I don't think this is a new problem, but newer Plasma (powerdevil5) versions may offer more settings on your system, so the window will get bigger.
    It doesn't happen here btw, mine is about 670 pixels high; but again, it depends on your system what options are available and as a consequence how high the window will be.

    Another "workaround" for this particular case would be to open those settings in systemsettings5, this will not enlarge the window but rather show scroll bars instead.

    If I select "more actions > keep above" then the power management window is then above the task manager but the ok/apply/cancel buttons are still off screen.
    Yes, the problem is that the buttons are off screen (because the window is too big to fit to the screen and kwin tries to keep the window title bar on screen at least), not that they are below the panel.

    Indeed I can move the window around and can even adjust the window width but it will not let me adjust the window height no matter what is tried.
    I thought it should be able to resize it via the methods I mentioned.
    But I tried just now, and it's really not possible to make it smaller.

    Sorry, I seemed to remember I could shrink it when I last tried. But apparently my memory played tricks with me...

    Apparently the application (kcmshell5) indeed sets the *minimum* size bigger (i.e. higher) than the screen in your case (for this particular settings module).

    The only windows I can reproduce this strange behaviour on are the power management window in plasma, Handbrake-gtk and MKVToolNix GUI
    That's a bug in those applications then though, kwin just respects what the applications set the window's (minimum) size to.
    Actually this is/was quite a common problem in GTK applications, I do remember a few bug reports.

    One way to "fix" the problem for the affected applications may be via kwin's "window rules" ("More Actions"->"Special Settings for this window").
    You can force a specific size (and also minimum and maximum size) that way.

    I haven't actually tried this now, but this really should work.
    Last edited by wolfi323; 01-Dec-2016 at 02:44.

  5. #5
    Join Date
    Jun 2008
    Location
    NZ
    Posts
    1,546

    Default Re: prevent windows going below task manager

    Quote Originally Posted by wolfi323 View Post
    Another "workaround" for this particular case would be to open those settings in systemsettings5, this will not enlarge the window but rather show scroll bars instead.


    Yes, the problem is that the buttons are off screen (because the window is too big to fit to the screen and kwin tries to keep the window title bar on screen at least), not that they are below the panel.


    I thought it should be able to resize it via the methods I mentioned.
    But I tried just now, and it's really not possible to make it smaller.

    Sorry, I seemed to remember I could shrink it when I last tried. But apparently my memory played tricks with me...

    Apparently the application (kcmshell5) indeed sets the *minimum* size bigger (i.e. higher) than the screen in your case (for this particular settings module).
    yes, of course the panel and not task manager.
    Displaying the power management window within systemsettings5 gives me scrollbars and fits on the screen nicely - I need to remember to use this when trying to access power management.


    That's a bug in those applications then though, kwin just respects what the applications set the window's (minimum) size to.
    Actually this is/was quite a common problem in GTK applications, I do remember a few bug reports.

    One way to "fix" the problem for the affected applications may be via kwin's "window rules" ("More Actions"->"Special Settings for this window").
    You can force a specific size (and also minimum and maximum size) that way.

    I haven't actually tried this now, but this really should work.
    Thanks, yes - these workarounds work nicely for me

    I guess part of the problem is my screen resolution which is only 1366x768
    Mark F.
    openSUSE Leap 15.1 / Plasma 5.12



  6. #6

    Default Re: prevent windows going below task manager

    Quote Originally Posted by farcusnz View Post
    I guess part of the problem is my screen resolution which is only 1366x768
    That's one part of the problem, yes.

    And the other one is that your system apparently offers more powermanagement capabilities (that are now offered by powerdevil5 too) than a deskop system (with a bigger screen) would have...
    At least that's the reason why I didn't notice this problem before (at least before I read and replied to that mentioned openSUSE bugreport).

    Might have happened to the responsible upstream developers and testers too, i.e. it seemed to work fine in all testings.

    Not that I ever called this dialog, because it never even occured to me to do that as the icon just says "no batteries to configure" on my systems. anyway... But that's a different story.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •