Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: Upgrading Kde is impeded by one repository

  1. #1
    Join Date
    Oct 2008
    Location
    near the Alps
    Posts
    567

    Question Upgrading Kde is impeded by one repository

    Hi ;=)

    I'm trying to upgrade kde after using zypper dup to go from 42.1 to 42.2.

    One package can't be reached which impedes the upgrade.

    I was able to install it through 1 click install though https://software.opensuse.org/packag...4qt5-debuginfo

    ... but it seems zypper needs it anyway .

    Have you got the same result with this repository ?

    Thanks

    Code:
    zypper ref && zypper up 
    ...
    All repositories have been refreshed.
    Loading repository data...
    Reading installed packages...
    
    The following 482 package updates will NOT be installed:
      Mesa Mesa-32bit Mesa-demo-x Mesa-dri-devel Mesa-dri-nouveau Mesa-libEGL-devel Mesa-libEGL1 Mesa-libEGL1-32bit Mesa-libGL-devel Mesa-libGL1 Mesa-libGL1-32bit Mesa-libGLESv2-2 Mesa-libglapi0 Mesa-libglapi0-32bit Mesa-libva
     ...
    ....
    
    The following 16 NEW packages are going to be installed:
      akonadi-mime akonadi-search baloo5-file baloo5-tools kipi-plugins-lang libKF5AkonadiAgentBase5 libKF5AkonadiCore5 libKF5AkonadiMime5 libKF5AkonadiPrivate5 libKF5AkonadiSearch libKF5AkonadiWidgets5 libKF5CalendarCore5 libKF5Contacts5
      libKF5Kipi31_0_0 libKF5Mime5 libproxy1-config-kde
    
    The following 4 packages are going to be REMOVED:
      baloo-file baloo-pim baloo-tools libproxy1-config-kde4
    
    The following 39 packages are going to be upgraded:
      a52dec exfat-utils faac faad2 fuse-exfat gmerlin kipi-plugins lame libIlmImf-2_2-22 liba52-0 libaudio2 libdbusmenu-qt5-2-debuginfo libdca0 libdcadec0 libdvdcss2 libfaac0 libfaad2 libgmerlin0 libmad0 libmp3lame0 libmp4v2-2 libmpeg2-0
      libmpeg2convert0 libmpg123-0 libphonon4qt5-debuginfo libproxy1 libproxy1-networkmanager libproxy1-pacrunner-webkit librtmp1 libshine3 libslv2-9 libtsmux0 libtwolame0 libvo-amrwbenc0 libx264-148 libxvidcore4 mpeg2dec openshot xvidcore
    
    39 packages to upgrade, 16 new, 4 to remove.
    Overall download size: 31.1 MiB. Already cached: 0 B. After the operation, 3.5 MiB will be freed.
    Continue? [y/n/? shows all options] (y): y
    Retrieving package libphonon4qt5-debuginfo-4.9.0-5.72.x86_64                                                                                                                                          (1/55),   2.6 MiB ( 13.2 MiB unpacked)
    Retrieving: libphonon4qt5-debuginfo-4.9.0-5.72.x86_64.rpm ...........................................................................................................................................................................[error]
    File './x86_64/libphonon4qt5-debuginfo-4.9.0-5.72.x86_64.rpm' not found on medium 'http://download.opensuse.org/repositories/KDE:/Frameworks5/openSUSE_Leap_42.2/'
    
    Abort, retry, ignore? [a/r/i/? shows all options] (a):        
    Problem occured during or after installation or removal of packages:
    Installation aborted by user
    
    Please see the above error message for a hint.
    
    
    openSUSE421:~ # zypper info libphonon4qt5-debuginfo
    Loading repository data...
    Reading installed packages...
    
    
    Information for package libphonon4qt5-debuginfo:
    ------------------------------------------------
    Repository     : KDE:Frameworks5                            
    Name           : libphonon4qt5-debuginfo                    
    Version        : 4.9.0-5.72                                 
    Arch           : x86_64                                     
    Vendor         : obs://build.opensuse.org/KDE               
    Installed Size : 13.2 MiB                                   
    Installed      : Yes                                        
    Status         : out-of-date (version 4.9.0-5.3 installed)  
    Summary        : Debug information for package libphonon4qt5
    Description    :                                            
        This package provides debug information for package libphonon4qt5.
        Debug information is useful when developing applications that use this
        package or when debugging this package.
    
    openSUSE421:~ #
    openSUSE Leap 42.2 , KDE Plasma 5

  2. #2
    Join Date
    Jul 2008
    Location
    United Kingdom
    Posts
    307

    Default Re: Upgrading Kde is impeded by one repository

    Am I not correct in thinking that it is best practise to disable extra repos on dist upgrades. One of the reasons they are not recommended in Tumbleweed.

  3. #3
    Join Date
    Oct 2008
    Location
    near the Alps
    Posts
    567

    Default Re: Upgrading Kde is impeded by one repository

    Hi

    You're right indeed Which is why i used only 4 repos to zypper dup (oss, non-oss, and update of these).

    I'm now after the dup.

    I added the repos for 42.2 changing their urls for 42.2 , and i'm now trying to upgrade Kde Plasma.
    openSUSE Leap 42.2 , KDE Plasma 5

  4. #4
    Join Date
    Jul 2008
    Location
    United Kingdom
    Posts
    307

    Default Re: Upgrading Kde is impeded by one repository

    I just had a look for it in YAst and libphonon4qt5 is version 4.9.0-2.6 and there is no *debug package at all.....

    Not sure if this is a pointer

  5. #5
    Join Date
    Oct 2008
    Location
    near the Alps
    Posts
    567

    Default Re: Upgrading Kde is impeded by one repository

    hi

    actually i found it from 1 click install, from the link i gave above you can see the repos it uses to add it.

    Now i do not get what's happening : is the repository having problems temporarily ? Do i have to add another repo (for debug packages ?)

    Why can't i upgrade from zipper nor yast ? Seems like Frameworks repo has a problem of some kind (?)


    btw : the site here is very s_l_o_w motion to load, each page takes hours, others sites seem ok.
    openSUSE Leap 42.2 , KDE Plasma 5

  6. #6
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,650

    Default Re: Upgrading Kde is impeded by one repository

    Generally you use either the regular repos or the framework one. mixing is bad. So did you do a vendor change to framework??

  7. #7
    Join Date
    Oct 2008
    Location
    near the Alps
    Posts
    567

    Default Re: Upgrading Kde is impeded by one repository

    hi

    could you please unfold what you mean by regular repos , the framework ones ?

    Actually i can't change the system packages to the Frameworks repo in Yast repo tab.

    example :

    Code:
    
    
    # zypper ref && zypper up                                                                                                                                                                                                     
    Repository 'openSUSE BuildService - Mozilla' is up to date.                                                                                                                                                                                 
    Repository 'google-talkplugin' is up to date.                                                                                                                                                                                               
    Repository 'KDE:Frameworks5' is up to date.                                                                                                                                                                                                 
    Repository 'Adobe Flash Plugin' is up to date.                                                                                                                                                                                              
    Repository 'non-oss' is up to date.                                                                                                                                                                                                         
    Repository 'update_non-oss' is up to date.                                                                                                                                                                                                  
    Repository 'kde_frameworks5' is up to date.                                                                                                                                                                                                 
    Repository 'packman' is up to date.                                                                                                                                                                                                         
    Repository 'Qt5' is up to date.                                                                                                                                                                                                             
    Repository 'printing_openSUSE' is up to date.                                                                                                                                                                                               
    Repository 'X11:Xorg' is up to date.                                                                                                                                                                                                        
    Repository 'windows:mingw:win32' is up to date.                                                                                                                                                                                             
    Repository 'network_wicked_master' is up to date.                                                                                                                                                                                           
    Repository 'Libreoffice_factory' is up to date.                                                                                                                                                                                             
    Repository 'Libdvdcss Repository' is up to date.                                                                                                                                                                                            
    Repository 'oss' is up to date.                                                                                                                                                                                                             
    Repository 'kernel_stable_standard' is up to date.                                                                                                                                                                                          
    Retrieving repository 'update_oss' metadata ..........................................................................................................................................................................................[done]
    Building repository 'update_oss' cache ...............................................................................................................................................................................................[done]
    Repository 'windows:mingw:win64' is up to date.                                                                                                                                                                                             
    All repositories have been refreshed.
    Loading repository data...
    Reading installed packages...
    
    The following 483 package updates will NOT be installed:
      Mesa Mesa-32bit Mesa-demo-x Mesa-dri-devel Mesa-dri-nouveau Mesa-libEGL-devel Mesa-libEGL1 Mesa-libEGL1-32bit Mesa-libGL-devel Mesa-libGL1 Mesa-libGL1-32bit Mesa-libGLESv2-2 Mesa-libglapi0 Mesa-libglapi0-32bit Mesa-libva
      OpenPrintingPPDs OpenPrintingPPDs-ghostscript OpenPrintingPPDs-hpijs OpenPrintingPPDs-postscript autocutsel baloo5 baloo5-lang bluez-qt-udev breeze breeze4-style breeze5-cursors breeze5-icons breeze5-wallpapers cmake colord-kde
      compositeproto-devel cups cups-client cups-devel cups-filters cups-filters-cups-browsed cups-filters-foomatic-rip cups-filters-ghostscript cups-libs cups-libs-32bit damageproto-devel dmxproto-devel dri2proto-devel extra-cmake-modules
      ffmpeg fixesproto-devel flute font-util fontcacheproto-devel fontsproto-devel freshplayerplugin gccmakedep ghostscript ghostscript-fonts-other ghostscript-fonts-std ghostscript-x11 glproto-devel glu-devel graphite2-devel
      gstreamer-plugins-bad gstreamer-plugins-bad-lang gstreamer-plugins-ugly gstreamer-plugins-ugly-lang gutenprint hplip-hpijs hplip-sane iceauth ilmbase-devel imake inputproto-devel k3b k3b-lang kbproto-devel kcolorchooser
      kernel-firmware kernel-macros kf5-filesystem kinit-devel kio_iso kmahjongg krdc ktorrent ktorrent-lang libFS-devel libFS6 libGLU1 libGLU1-32bit libHalf12 libICE-devel libICE6 libICE6-32bit libIex-2_2-12 libIexMath-2_2-12
      libIlmThread-2_2-12 libImath-2_2-12 libKF5JS5 libOSMesa9 libOSMesa9-32bit libSM-devel libSM6 libSM6-32bit libX11-6 libX11-6-32bit libX11-data libX11-devel libX11-xcb1 libX11-xcb1-32bit libXRes1 libXRes1-32bit libXTrap-devel libXTrap6
      libXau-devel libXau6 libXau6-32bit libXaw-devel libXaw6 libXaw7 libXaw8 libXcomposite-devel libXcomposite1 libXcomposite1-32bit libXcursor-devel libXcursor1 libXcursor1-32bit libXdamage-devel libXdamage1 libXdamage1-32bit
      libXdmcp-devel libXdmcp6 libXevie-devel libXevie1 libXext-devel libXext6 libXext6-32bit libXfixes-devel libXfixes3 libXfixes3-32bit libXfont-devel libXfont1 libXfontcache-devel libXfontcache1 libXft-devel libXft2 libXft2-32bit
      libXi-devel libXi6 libXi6-32bit libXinerama-devel libXinerama1 libXinerama1-32bit libXmu-devel libXmu6 libXmuu1 libXp-devel libXp6 libXpm-devel libXpm4 libXpm4-32bit libXprintAppUtil-devel libXprintAppUtil1 libXprintUtil-devel
      libXprintUtil1 libXrandr-devel libXrandr2 libXrandr2-32bit libXrender-devel libXrender1 libXrender1-32bit libXres-devel libXss1 libXss1-32bit libXt-devel libXt6 libXt6-32bit libXtst-devel libXtst6 libXtst6-32bit libXv-devel libXv1
      libXv1-32bit libXvMC-devel libXvMC1 libXvnc1 libXxf86dga-devel libXxf86dga1 libXxf86misc-devel libXxf86misc1 libXxf86vm-devel libXxf86vm1 libXxf86vm1-32bit libabw-0_1-1 libavcodec56 libavcodec57 libavdevice56 libavdevice57
      libavfilter5 libavfilter6 libavformat56 libavformat57 libavresample2 libavresample3 libavutil54 libavutil55 libbase libbzrtp0 libcdr-0_1-1 libcmis-0_5-5 libdmx-devel libdmx1 libdrm2-32bit libdrm_amdgpu1-32bit libdrm_intel1-32bit
      libdrm_nouveau2-32bit libdrm_radeon1-32bit libe-book-0_1-1 libetonyek-0_1-1 libevdev-devel libevdev2 libexttextcat libexttextcat-2_0-0 libfontenc-devel libfontenc1 libfonts libformula libfreehand-0_1-1 libgbm1 libgbm1-32bit
      libgltf-0_0-0 libgraphite2-3 libgstadaptivedemux-1_0-0 libgstbadaudio-1_0-0 libgstbadbase-1_0-0 libgstbadvideo-1_0-0 libgstbasecamerabinsrc-1_0-0 libgstcodecparsers-1_0-0 libgstgl-1_0-0 libgstmpegts-1_0-0 libgstphotography-1_0-0
      libgsturidownloader-1_0-0 libgstwayland-1_0-0 libhyphen0 libixion-0_11-0 liblangtag1 liblayout liblbxutil-devel liblbxutil1 libloader liblpsolve55-0 libmjpegutils-2_0-0 libmlt++3 libmlt6 libmlt6-data libmlt6-modules libmspub-0_1-1
      libmtdev1 libmwaw-0_3-3 libmythes-1_2-0 libnetcontrol0 libodfgen-0_1-1 liboldX-devel liboldX6 liborcus-0_11-0 libpagemaker-0_0-0 libpciaccess-devel libpciaccess0 libpciaccess0-32bit libpixman-1-0 libpixman-1-0-32bit
      libpixman-1-0-devel libpostproc53 libpostproc54 libquicktime0 libreoffice libreoffice-base libreoffice-base-drivers-mysql libreoffice-branding-upstream libreoffice-calc libreoffice-calc-extensions libreoffice-draw
      libreoffice-filters-optional libreoffice-icon-theme-breeze libreoffice-icon-theme-galaxy libreoffice-icon-theme-hicontrast libreoffice-icon-theme-oxygen libreoffice-icon-theme-sifr libreoffice-icon-theme-tango libreoffice-impress
      libreoffice-kde4 libreoffice-l10n-en libreoffice-l10n-fr libreoffice-mailmerge libreoffice-math libreoffice-pyuno libreoffice-share-linker libreoffice-writer libreoffice-writer-extensions librepository librevenge-0_0-0
      librevenge-generators-0_0-0 librevenge-stream-0_0-0 libserializer libsox3 libswresample1 libswresample2 libswscale3 libswscale4 libva-drm1 libva-drm1-32bit libva-egl1 libva-glx1 libva-x11-1 libva-x11-1-32bit libva1 libva1-32bit
      libvdpau_nouveau libvdpau_r300 libvdpau_r600 libvdpau_radeonsi libvisio-0_1-1 libwayland-egl1 libwicked-0-6 libwpd-0_10-10 libwpd-tools libwpg-0_3-3 libwps-0_4-4 libxcb-composite0 libxcb-cursor0 libxcb-damage0 libxcb-devel
      libxcb-dpms0 libxcb-dri2-0 libxcb-dri2-0-32bit libxcb-dri3-0 libxcb-dri3-0-32bit libxcb-glx0 libxcb-glx0-32bit libxcb-icccm4 libxcb-image0 libxcb-keysyms1 libxcb-present0 libxcb-present0-32bit libxcb-randr0 libxcb-record0
      libxcb-render-util0 libxcb-render0 libxcb-render0-32bit libxcb-res0 libxcb-screensaver0 libxcb-shape0 libxcb-shm0 libxcb-shm0-32bit libxcb-sync1 libxcb-sync1-32bit libxcb-util1 libxcb-xf86dri0 libxcb-xfixes0 libxcb-xfixes0-32bit
      libxcb-xinerama0 libxcb-xkb1 libxcb-xtest0 libxcb-xv0 libxcb-xvmc0 libxcb1 libxcb1-32bit libxine-devel libxine2 libxine2-pulse libxkbfile-devel libxkbfile1 libxkbui-devel libxkbui1 libxml++-2_6-2 libxshmfence-devel libxshmfence1
      libxshmfence1-32bit lndir luit makedepend manufacturer-PPDs melt melt6 mjpegtools mkfontdir mkfontscale mozilla-kde4-integration mtdev-devel myspell-dictionaries myspell-en myspell-en_US myspell-fr_FR myspell-lightproof-en
      openexr-devel oxygen5-cursors oxygen5-icon-theme oxygen5-icon-theme-large oxygen5-sounds parallel-printer-support pentaho-libxml pentaho-reporting-flow-engine plasma5-defaults-openSUSE plasma5-session plasma5-theme-openSUSE
      printproto-devel pthread-stubs-devel python-mlt python-sip python-xcb-proto-devel randrproto-devel recordproto-devel resourceproto-devel rgb s2tc s2tc-32bit sac scrnsaverproto-devel sessreg setxkbmap sox tigervnc trapproto-devel
      ucode-amd util-macros-devel vaapi-dummy-driver videoproto-devel wicked wicked-service xauth xbitmaps xbitmaps-devel xcb-proto-devel xcb-util-devel xconsole xdm xdm-xsession xdpyinfo xextproto-devel xf86-input-evdev xf86-input-joystick
      xf86-input-keyboard xf86-input-libinput xf86-input-mouse xf86-input-synaptics xf86-input-vmmouse xf86-input-void xf86-input-wacom xf86-video-amdgpu xf86-video-ati xf86-video-fbdev xf86-video-mach64 xf86-video-nouveau xf86-video-r128
      xf86-video-vesa xf86dgaproto-devel xf86driproto-devel xf86miscproto-devel xf86vidmodeproto-devel xhost xineramaproto-devel xinit xkbcomp xkeyboard-config xkeyboard-config-lang xmessage xmodmap xorg-cf-files xorg-sgml-doctools
      xorg-x11-Xvnc xorg-x11-devel xorg-x11-driver-input xorg-x11-driver-video xorg-x11-essentials xorg-x11-fonts xorg-x11-fonts-core xorg-x11-libX11-ccache xorg-x11-libs xorg-x11-util-devel xprop xproto-devel xrandr xrdb xset xsetroot
      xtrans
    
    The following 8 NEW packages are going to be installed:
      akonadi-mime akonadi-search baloo5-file baloo5-tools kipi-plugins-lang libKF5AkonadiAgentBase5 libKF5AkonadiMime5 libproxy1-config-kde
    
    The following application is going to be REMOVED:
      Konsole
    
    The following 4 packages are going to be REMOVED:
      baloo-file baloo-pim baloo-tools libproxy1-config-kde4
    
    The following 64 packages are going to be upgraded:
      Mesa Mesa-32bit Mesa-dri-devel Mesa-dri-nouveau Mesa-libEGL-devel Mesa-libEGL1 Mesa-libEGL1-32bit Mesa-libGL-devel Mesa-libGL1 Mesa-libGL1-32bit Mesa-libGLESv2-2 Mesa-libglapi0 Mesa-libglapi0-32bit Mesa-libva a52dec exfat-utils faac
      faad2 fuse-exfat gmerlin kipi-plugins konsole konsole-part lame libIlmImf-2_2-22 libOSMesa9 libOSMesa9-32bit liba52-0 libaudio2 libdbusmenu-qt5-2-debuginfo libdca0 libdcadec0 libdvdcss2 libfaac0 libfaad2 libgbm1 libgbm1-32bit
      libgmerlin0 libmad0 libmp3lame0 libmp4v2-2 libmpeg2-0 libmpeg2convert0 libmpg123-0 libphonon4qt5-debuginfo libproxy1 libproxy1-networkmanager libproxy1-pacrunner-webkit librtmp1 libshine3 libslv2-9 libtsmux0 libtwolame0
      libvdpau_nouveau libvdpau_r300 libvdpau_r600 libvdpau_radeonsi libvo-amrwbenc0 libwayland-egl1 libx264-148 libxvidcore4 mpeg2dec openshot xvidcore
    
    64 packages to upgrade, 8 new, 4 to remove.
    Overall download size: 57.7 MiB. Already cached: 0 B. After the operation, 9.4 MiB will be freed.
    Continue? [y/n/? shows all options] (y): 
    Retrieving package libphonon4qt5-debuginfo-4.9.0-5.72.x86_64                                                                                                                                          (1/72),   2.6 MiB ( 13.2 MiB unpacked)
    Retrieving: libphonon4qt5-debuginfo-4.9.0-5.72.x86_64.rpm ...........................................................................................................................................................................[error]
    File './x86_64/libphonon4qt5-debuginfo-4.9.0-5.72.x86_64.rpm' not found on medium 'http://download.opensuse.org/repositories/KDE:/Frameworks5/openSUSE_Leap_42.2/'
    openSUSE Leap 42.2 , KDE Plasma 5

  8. #8
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,650

    Default Re: Upgrading Kde is impeded by one repository

    the KDE framework repo is an add on. It is not part of a regular vanilla install. It may contain different versions of KDE then the default normal regular openSUSE repo. Mixing versions can lead to problem. Use the stuff from one or the other. You do this by setting the vendor to the one you plan on using and doing a dup from that repo. It appears to me you problem is come from clashing versions

  9. #9
    Join Date
    Oct 2008
    Location
    near the Alps
    Posts
    567

    Default Re: Upgrading Kde is impeded by one repository

    i can see libphonon4qt5-debuginfo-4.9.0-5.72.x86_64.rpm here : http://download.opensuse.org/reposit...p_42.2/x86_64/


    what's the meaning of " File './x86_64/libphonon4qt5-debuginfo-4.9.0-5.72.x86_64.rpm' "


    is the server down ?
    openSUSE Leap 42.2 , KDE Plasma 5

  10. #10
    Join Date
    Oct 2008
    Location
    near the Alps
    Posts
    567

    Default Re: Upgrading Kde is impeded by one repository

    Quote Originally Posted by gogalthorp View Post
    the KDE framework repo is an add on. It is not part of a regular vanilla install. It may contain different versions of KDE then the default normal regular openSUSE repo. Mixing versions can lead to problem. Use the stuff from one or the other. You do this by setting the vendor to the one you plan on using and doing a dup from that repo. It appears to me you problem is come from clashing versions
    This exactly is what i'm trying to do : i'd like to use Frameworks and Qt5 repos.

    I was planning to switch system packages to these repos but it refused, as shown above.
    openSUSE Leap 42.2 , KDE Plasma 5

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •