Results 1 to 7 of 7

Thread: Leap 42.2: unicode file names shown as ??????

  1. #1

    Default Leap 42.2: unicode file names shown as ??????

    Brand new install of Leap 42.2
    I have ext4 partition with unicode file names (russian, lithuanian). All of them shown like this:



    When trying to create new folder with russian symbols - typed symbols seen correctly in Dolphin's dialog, but when saved - appears as ??????? (question marks)

    This is the first time opensuse release lacks unicode support. This partition was used as HOME in Leap 42.1 previously and all was good

    What steps must be done to add full support of unicode file names?

    Thanks

  2. #2
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    24,732

    Default Re: Leap 42.2: unicode file names shown as ??????

    Well, it looks like a very bad regression.

    Let us first eliminate the desktop. Can you post an
    Code:
    ls -l
    of one or more of these files?
    Henk van Velden

  3. #3

    Default Re: Leap 42.2: unicode file names shown as ??????

    Two new folders created in Dolphin and one existing folder:

    Code:
    tosiara@leap422:~/leap-42.2-unicode-bug> ls -l
    total 12
    drwxr-xr-x 2 tosiara users 4096 2016-11-26 21:13 created-in-dolphin-???????
    drwxr-xr-x 2 tosiara users 4096 2016-11-26 21:13 created-in-dolphin-lietuvi?kai
    drwxr-xr-x 2 tosiara users 4096 2016-11-26 21:15 ?????????? ?????????????????? - ???????????? (2012)
    I can't mkdir in console because symbols are already "????" as I type

  4. #4
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    24,732

    Default Re: Leap 42.2: unicode file names shown as ??????

    Strange. I am just poking in the dark.
    Can you post
    Code:
    echo $LANG
    Henk van Velden

  5. #5

    Default Re: Leap 42.2: unicode file names shown as ??????

    It was LANG=C

    Now I changed "Region" in KDE settings to Lithuania and Preferred language to "American English" and have this:
    Code:
    ~/leap-42.2-unicode-bug> env | grep LANG
    LANG=lt_LT.US-ASCII
    LANGUAGE=en_US
    After rebooting I'm now able to type unicode, but still can't list files, even those that I have just typed and created:
    Code:
    ~/leap-42.2-unicode-bug> touch lietuviškai
    ~/leap-42.2-unicode-bug> touch русский
    ~/leap-42.2-unicode-bug> ls -lt1
    total 12
    -rw-r--r-- 1 tosiara users    0 Nov 27 10:05 ??????????????
    -rw-r--r-- 1 tosiara users    0 Nov 27 10:04 lietuvi??kai
    -rw-r--r-- 1 tosiara users    0 Nov 26 21:36 console-l??????????????
    -rw-r--r-- 1 tosiara users    0 Nov 26 21:36 console-lietuvi??kai
    drwxr-xr-x 2 tosiara users 4096 Nov 26 21:15 ?????????? ?????????????????? - ???????????? (2012)
    drwxr-xr-x 2 tosiara users 4096 Nov 26 21:13 created-in-dolphin-lietuvi?kai
    drwxr-xr-x 2 tosiara users 4096 Nov 26 21:13 created-in-dolphin-???????
    I even tried to switch to "real" console using CTRL+F1, there I see following:



    And if I "ls" and pipe ouput to a file, this is what file contents I get:
    Code:
    -rw-r--r-- 1 tosiara  users    0 Nov 27 10:05 русский
    -rw-r--r-- 1 tosiara  users    0 Nov 27 10:04 lietuviškai
    -rw-r--r-- 1 tosiara  users    0 Nov 26 21:36 console-lрусский
    -rw-r--r-- 1 tosiara  users    0 Nov 26 21:36 console-lietuviškai
    drwxr-xr-x 2 tosiara  users 4096 Nov 26 21:15 Ляпис Трубецкой - Рабкор (2012)
    drwxr-xr-x 2 tosiara  users 4096 Nov 26 21:13 created-in-dolphin-lietuvi?kai
    drwxr-xr-x 2 tosiara  users 4096 Nov 26 21:13 created-in-dolphin-???????
    Three different results

    Could "ASCII" be a problem?
    LANG=lt_LT.US-ASCII

  6. #6

    Default Re: Leap 42.2: unicode file names shown as ??????

    Tried to set Region to "Russia" and now all shown fine (except the one created in LANG=C locale):
    Code:
    ~/leap-42.2-unicode-bug> env | grep LANG
    LANG=ru_RU.UTF-8
    LANGUAGE=en_US
    
    
    > ls -l
    total 16
    -rw-r--r-- 1 tosiara  users    0 ноя 26 21:36 console-lietuviškai
    -rw-r--r-- 1 tosiara  users    0 ноя 26 21:36 console-lрусский
    drwxr-xr-x 2 tosiara  users 4096 ноя 26 21:13 created-in-dolphin-???????
    drwxr-xr-x 2 tosiara  users 4096 ноя 26 21:13 created-in-dolphin-lietuvi?kai
    -rw-r--r-- 1 tosiara  users    0 ноя 27 10:04 lietuviškai
    -rw-r--r-- 1 root root   535 ноя 27 10:07 ls.txt
    drwxr-xr-x 2 tosiara  users 4096 ноя 26 21:15 Ляпис Трубецкой - Рабкор (2012)
    -rw-r--r-- 1 tosiara  users    0 ноя 27 10:05 русский
    But I still see the same picture when switched to "real" console, outside of KDE

  7. #7
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    24,732

    Default Re: Leap 42.2: unicode file names shown as ??????

    Yes, your LANG parameter should at least end on .UTF-8.

    You should have LANG=C at the most for root, not for normal users.

    I have no idea why it was wrong in your case.

    You could also check in ~/.profile. I have there the following snippet:
    Code:
    # Most applications support several languages for their output.
    # To make use of this feature, simply uncomment one of the lines below or
    # add your own one (see /usr/share/locale/locale.alias for more codes)
    #
    #export LANG=de_DE.UTF-8        # uncomment this line for German output
    #export LANG=fr_FR.UTF-8        # uncomment this line for French output
    #export LANG=es_ES.UTF-8        # uncomment this line for Spanish output
    export LANG=nl_NL.UTF-8 # uncomment this line for Dutch output
    I assume your's must have similar (adapted to the language you prefer). It is bit of a strange beast in that the first part is for giving you messages in the language you use and the second one is setting something to UTF-8, which is of course language independent.
    Henk van Velden

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •