Results 1 to 9 of 9

Thread: Firefox language headache

  1. #1

    Default Firefox language headache

    Just upgraded to 42.2 from 13.2, and Firefox is driving me mad : under Gnome, the interface is in french, under Plasma, it's in english...

    My locale is set to fr-FR.UTF-8 in .profile, in /etc/sysconfig/language : RC_LANG="fr_FR.UTF-8", and french is #1 in plasma language configuration panel...

    Any idea ?

  2. #2

    Default Re: Firefox language headache

    What happens if you open Yast and go to Languages and select French?

  3. #3

    Default Re: Firefox language headache

    French is of course selected in Yast since the beginning. On my desktop, I upgraded from 42.1, and everything is okay. The problem is on my laptop, where I upgraded from 13.2...

    I have compared the two PCs, every piece of config is the same. Bouh ouh ouh !

  4. #4
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,582

    Default Re: Firefox language headache

    You have to change in the desktop also because each user can have their own language

  5. #5

    Default [FIXED] Firefox language headache

    Thanks to gogalthorp, I went to see my desktop settings for Plasma : French was 1st position , and English 2nd. I removed English and now Firefox speaks French . This said, I think this behavior is abnormal, as far as one language is configured as preferred and available on the system, it should be used, whatever 2nd or 3rd language are.

    The question is who is responsible for that ? FF or KDE ?

  6. #6
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,582

    Default Re: Firefox language headache

    No it is correct. Remember Linux is multi-user thus each user can have their own preferences and may be different even from the system settings. So the system and root have one set of preferences including language and each user their own set of preferences. Windows is at its core single users with multi-user spliced on top. Linux at it's core is multi-user even if there is only a single user

  7. #7
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    2,410

    Default Re: Firefox language headache

    Quote Originally Posted by zartha View Post
    Just upgraded to 42.2 from 13.2, and Firefox is driving me mad : under Gnome, the interface is in french, under Plasma, it's in english...

    My locale is set to fr-FR.UTF-8 in .profile, in /etc/sysconfig/language : RC_LANG="fr_FR.UTF-8", and french is #1 in plasma language configuration panel...
    This could be due to the default KDE Plasma 5 System Settings language default in "Personalisation" -->> "Regional Settings":
    • The default for "Preferred Languages" seems to be, not set at all.
    • A further issue is the default "Spell Check" -- it seems to default to "American English (United States)".

    To get this default behaviour changed, I suspect that we'll have to start a topic in the KDE Forum "KDE Brainstorm" or possibly "Discussions & Opinions" -- attempting to get this changed by means of a KDE Bug Report is IMHO not a good idea.

  8. #8
    Join Date
    Oct 2008
    Location
    Stuttgart, Germany
    Posts
    55

    Default Re: Firefox language headache

    Hi,

    I have a similar issue. My preferred language is US English. It's the only one selected in yast. I added German (deutsch) and French (francais) as preferred languages in the System Settings dialog.

    I recently detected that the printer dialog in Firefox is mostly in German. Everything else I checked is in English. I then removed German and French as preferred languages and, voila, the printer dialog is all English again.

    I didn't know what to expect when I added German and French as preferred languages, but certainly not this strange mix!
    It impacts even error messages of bash! When I tried to kill a non-existing process, I got
    Code:
     bash: kill: (2173) - Kein passender Prozess gefunden
    Now I get
    Code:
     bash: kill: (5794) - No such process
    I even got a French linker error from gcc! I wonder whether that was related as well!

    Thanks, Stephan

  9. #9

    Default Re: Firefox language headache

    I _really_ think it's a Plasma 5 issue ! It seems that as soon as several languages are configured in "Personalization --> Regional Settings", system goes crazy and starts to speak as Salvatore in "The Name of the Rose".

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •