Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Calibre not launching

  1. #1

    Default Calibre not launching

    Hi everyone.

    Calibre is not launching anymore. From konsole:


    Code:
    python2: siplib.c:12299: sipEnumType_alloc: La declaración `sipTypeIsEnum(currentType)' no se cumple. 
    Abortado (`core' generado)


    These is my repo list:
    Code:
    Repository priorities in effect:                                                                                                                                                                                   (See 'zypper lr -P' for details)
          85 (raised priority)  :  1 repository   
          95 (raised priority)  :  1 repository   
          99 (default priority) :  4 repositories
    
    # | Alias               | Nombre                      | Habilitado | Comprobación GPG | Actualizar | Prioridad | Tipo   | URI                                                                                          | Servicio
    --+---------------------+-----------------------------+------------+------------------+------------+-----------+--------+----------------------------------------------------------------------------------------------+---------
    1 | MEGAsync            | MEGAsync                    | Si         | (r ) Si          | Si         |   99      | rpm-md | http://mega.nz/linux/MEGAsync/openSUSE_Tumbleweed/                                           |          
    2 | X11:XORG            | X11:XORG                    | No         | ----             | ----       |   90      | rpm-md | http://download.opensuse.org/repositories/X11:/XOrg/openSUSE_Tumbleweed/                     |          
    3 | openSUSE-20161018-0 | openSUSE-20161018-0         | Si         | (r ) Si          | Si         |   99      | yast2  | http://download.opensuse.org/tumbleweed/repo/oss/                                            |          
    4 | packman             | packman                     | Si         | (r ) Si          | Si         |   85      | rpm-md | http://ftp.gwdg.de/pub/linux/misc/packman/suse/openSUSE_Tumbleweed/                          |          
    5 | repo-debug          | openSUSE-Tumbleweed-Debug   | No         | ----             | ----       |   99      | NONE   | http://download.opensuse.org/debug/tumbleweed/repo/oss/                                      |          
    6 | repo-non-oss        | openSUSE-Tumbleweed-Non-Oss | Si         | (r ) Si          | Si         |   99      | yast2  | http://download.opensuse.org/tumbleweed/repo/non-oss/                                        |          
    7 | repo-source         | openSUSE-Tumbleweed-Source  | No         | ----             | ----       |   99      | NONE   | http://download.opensuse.org/source/tumbleweed/repo/oss/                                     |          
    8 | repo-update         | openSUSE-Tumbleweed-Update  | Si         | (r ) Si          | Si         |   99      | rpm-md | http://download.opensuse.org/update/tumbleweed/                                              |          
    9 | tumbleweed++        | tumbleweed++                | Si         | (r ) Si          | No         |   95      | rpm-md | http://download.opensuse.org/repositories/home:boombatower:tumbleweed++/openSUSE_Tumbleweed/ |


    What could possibly be?
    Thanks!

  2. #2
    Join Date
    Nov 2016
    Location
    Prague, CZ
    Posts
    39

    Default Re: Calibre not launching

    Take a look at this: https://forums.opensuse.org/showthre...ing-is-enabled

    I personally install Calibre from the webpage and it's rock solid even with my huge collection.

    http://calibre-ebook.com/download_linux

  3. #3

    Default Re: Calibre not launching

    I've seen that post, that's why I included my repo list. Strange thing is I've no other repo whose packages would conflict with calibre. It looks like there is a python/calibre missmatch compile issue (at least is what I could understood with some google search).
    Anyway, I've installed calibre from its website and everything is working great again (large collection here too)

    I appreciate your time to answer. Thanks!

  4. #4

    Default Re: Calibre not launching

    I have exactly the same error. Did you report a bug?

    I guess that calibre is using an enum type from a newer python-sip package. So python-sip needs an update. However someone should open a bug report.

  5. #5

    Default Re: Calibre not launching

    Quote Originally Posted by gladiac View Post
    I have exactly the same error. Did you report a bug?
    There has been a bug report, and the maintainer says the fix has been accepted to Factory (which means, it will be in the next Tumbleweed snapshot):
    http://bugzilla.opensuse.org/show_bug.cgi?id=1011610

    So please be patient a bit, an update should be available in the next days I suppose...

  6. #6

    Default Re: Calibre not launching

    This version works:

    http://download.opensuse.org/reposit...7.2.x86_64.rpm

    It is still waiting to be built in Factory. Once it is there it should be in Tumbleweed soon.

  7. #7

    Default Re: Calibre not launching

    It's been a month. How long does it usually take to be released in TW from factory?

    Quote Originally Posted by gladiac View Post
    This version works:

    http://download.opensuse.org/reposit...7.2.x86_64.rpm

    It is still waiting to be built in Factory. Once it is there it should be in Tumbleweed soon.
    openSUSE Leap 15.0

  8. #8

    Default Re: Calibre not launching

    On 12/28/2016 10:06 AM, bonedriven wrote:
    >
    > It's been a month. How long does it usually take to be released in TW
    > from factory?


    You do realize this is a volunteer distribution don't you. If things are
    not moving fast enough for you perhaps you could consider volunteering
    some of your time.
    Also keep in mind we are in the middle of holiday season.

    --
    Ken
    linux since 1994
    S.u.S.E./openSUSE since 1996

  9. #9

    Default Re: Calibre not launching

    Quote Originally Posted by bonedriven View Post
    It's been a month. How long does it usually take to be released in TW from factory?
    Depends on various factors.

    The then mentioned new version is in Tumbleweed already since more than 3 weeks though, and has even been updated to 2.74 meanwhile (2 weeks ago).
    If it still doesn't work for you, maybe check which version you have actually installed (and from where).
    Code:
    rpm -qi calibre
    There has been a Qt5 update to 5.7.1 recently which may have broken it again, but calibre in Tumbleweed has been rebuilt against that AFAICS.

  10. #10

    Default Re: Calibre not launching

    Quote Originally Posted by wolfi323 View Post
    Depends on various factors.

    The then mentioned new version is in Tumbleweed already since more than 3 weeks though, and has even been updated to 2.74 meanwhile (2 weeks ago).
    If it still doesn't work for you, maybe check which version you have actually installed (and from where).
    Code:
    rpm -qi calibre
    There has been a Qt5 update to 5.7.1 recently which may have broken it again, but calibre in Tumbleweed has been rebuilt against that AFAICS.
    Code:
    calibre
    Traceback (most recent call last):                                                                                                                                                            
      File "/usr/lib64/calibre/calibre/gui2/ui.py", line 157, in __init__                                                                                                                         
        ac = self.init_iaction(action)
      File "/usr/lib64/calibre/calibre/gui2/ui.py", line 171, in init_iaction
        ac = action.load_actual_plugin(self)
      File "/usr/lib64/calibre/calibre/customize/__init__.py", line 611, in load_actual_plugin
        ac = getattr(importlib.import_module(mod), cls)(gui,
      File "/usr/lib64/python2.7/importlib/__init__.py", line 37, in import_module
        __import__(name)
      File "/usr/lib64/calibre/calibre/gui2/actions/catalog.py", line 12, in <module>
        from calibre.gui2.tools import generate_catalog
      File "/usr/lib64/calibre/calibre/gui2/tools.py", line 15, in <module>
        from calibre.gui2.convert.single import NoSupportedInputFormats
      File "/usr/lib64/calibre/calibre/gui2/convert/single.py", line 17, in <module>
        from calibre.gui2.convert.look_and_feel import LookAndFeelWidget
      File "/usr/lib64/calibre/calibre/gui2/convert/look_and_feel.py", line 12, in <module>
        from calibre.gui2.convert.look_and_feel_ui import Ui_Form
      File "/usr/lib64/calibre/calibre/gui2/convert/look_and_feel_ui.py", line 290, in <module>
        from calibre.gui2.css_transform_rules import RulesWidget
      File "/usr/lib64/calibre/calibre/gui2/css_transform_rules.py", line 12, in <module>
        from calibre.ebooks.css_transform_rules import (
      File "/usr/lib64/calibre/calibre/ebooks/css_transform_rules.py", line 10, in <module>
        from cssutils.css import Property, CSSRule
      File "/usr/lib/python2.7/site-packages/cssutils/__init__.py", line 110, in <module>
        from . import util
      File "/usr/lib/python2.7/site-packages/cssutils/util.py", line 18, in <module>
        from _fetchgae import _defaultFetcher
      File "/usr/lib/python2.7/site-packages/cssutils/_fetchgae.py", line 7, in <module>
        from google.appengine.api import urlfetch
      File "/usr/lib/python2.7/site-packages/protobuf-3.0.0b2.post2-py2.7.egg/google/__init__.py", line 2, in <module>
        __import__('pkg_resources').declare_namespace(__name__)
      File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 2991, in <module>
        @_call_aside
      File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 2977, in _call_aside
        f(*args, **kwargs)
      File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 3019, in _initialize_master_working_set
        dist.activate(replace=False)
      File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 2548, in activate
        for pkg in self._get_metadata('namespace_packages.txt'):
      File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 2538, in _get_metadata
        for line in self.get_metadata_lines(name):
      File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 1474, in get_metadata_lines
        return yield_lines(self.get_metadata(name))
      File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 1470, in get_metadata
        value = self._get(self._fn(self.egg_info, name))
      File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 1579, in _get
        with open(path, 'rb') as stream:
    IOError: [Errno 13] Permission denied: '/usr/lib/python2.7/site-packages/protobuf-3.0.0b2.post2-py2.7.egg/EGG-INFO/namespace_packages.txt'
    
    
    Here's the rpm -qi calibre results:
    Code:
    rpm -qi calibre
    Name        : calibre
    Version     : 2.74.0
    Release     : 1.2
    Architecture: x86_64
    Install Date: Sat 31 Dec 2016 05:54:20 PM CST
    Group       : Productivity/Other
    Size        : 54714686
    License     : GPL-3.0
    Signature   : RSA/SHA256, Fri 23 Dec 2016 06:07:16 AM CST, Key ID b88b2fd43dbdc284
    Source RPM  : calibre-2.74.0-1.2.src.rpm
    Build Date  : Fri 23 Dec 2016 06:06:06 AM CST
    Build Host  : cloud111
    Relocations : (not relocatable)
    Packager    : http://bugs.opensuse.org
    Vendor      : openSUSE
    URL         : http://calibre-ebook.com
    Summary     : EBook Management Application
    Description :
    Calibre is an ebook library manager. It can view, convert and catalog
    ebooks in most of the major ebook formats. It can also talk to a few
    ebook reader devices. It can go out to the internet and fetch
    metadata for your books. It can download newspapers and convert them
    into ebooks for convenient reading. It is cross platform, running on
    Linux, Windows and OS X.
    Distribution: openSUSE Tumbleweed
    
    
    openSUSE Leap 15.0

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •