Results 1 to 9 of 9

Thread: Possible BUG In Konqueror 4.14.25

  1. #1

    Default Possible BUG In Konqueror 4.14.25

    Every time I go to the website https://www.dur.ac.uk/cis/email/ Konqueror completely crashes. The version of Konqueror is 4.14.25 (found in the Opensuse Repositories). My OS version is Leap 42.2, and I run a 64-bit OS. This did not happen with the most updated version of Konqueror in Leap 42.1. After upgrading my system, it happens every time.

  2. #2

    Default AW: Possible BUG In Konqueror 4.14.25

    It's unlikely a bug in Konqueror itself which is just a shell for embedding kparts.

    Rather in the used web browsing backend.
    Which one are you using?

    It doesn't crash here though, neither with KHTML nor WebKit (4.14.26 on openSUSE 13.2, but that should basically be the same as 4.14.25).

    Could you post the backtrace please?

    Though if there really is a bug, it likely won't get fixed. Qt4/QtWebKit4 is not supported/developed any more, and khtml is not really actively developed since years (though it still gets bug fixes from time to time).
    And the next konqueror release will use Qt5/KDE Frameworks5 (and QtWebEngine by default).

  3. #3
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,178
    Blog Entries
    3

    Default Re: Possible BUG In Konqueror 4.14.25

    Quote Originally Posted by morrison27 View Post
    Every time I go to the website https://www.dur.ac.uk/cis/email/ Konqueror completely crashes.
    It is crashing here on many sites. The konqueror in 42.1 was reasonably stable. The one in 42.2 is not. And I see the same problem with "rekonq" (which uses some of the same libraries).

    However, it does do okay if I switch the KHTML. So I guess I will leave it that way for the present. I don't have that option with "rekonq".
    openSUSE Leap 15.1; KDE Plasma 5;

  4. #4
    Join Date
    Jun 2008
    Location
    Stoney Stanton - England
    Posts
    1,093

    Default Re: Possible BUG In Konqueror 4.14.25

    The website works fine for me using konqueror. But that is using the latest version of tumbleweed (21112016) plasma5 konqueror 4.14.26

  5. #5

    Default Re: Possible BUG In Konqueror 4.14.25

    I just noticed that evince-browser-plugin is included again in Leap 42.2.

    It had been dropped/removed over a year ago (in 13.2), because it caused crashes in QtWebKit and also other browsers (Firefox e.g.). Somehow that change hasn't been submitted to Leap it seems...

    So, try to uninstall evince-browser-plugin if it is installed and see if it helps.

    PS: the bug report is here:
    https://bugzilla.opensuse.org/show_bug.cgi?id=901006
    (filed by nrickert)
    Last edited by wolfi323; 22-Nov-2016 at 11:31.

  6. #6

    Default Re: Possible BUG In Konqueror 4.14.25

    Quote Originally Posted by wolfi323 View Post
    I just noticed that evince-browser-plugin is included again in Leap 42.2.

    It had been dropped/removed over a year ago (in 13.2), because it caused crashes in QtWebKit and also other browsers (Firefox e.g.). Somehow that change hasn't been submitted to Leap it seems...
    Actually evince-browser-plugins was not included in 42.1 either, that would explain why Konqueror was stable in 42.1.
    Somehow they reintroduced it in 42.2, probably because that change never was submitted to Factory AFAIK.

  7. #7
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,178
    Blog Entries
    3

    Default Re: Possible BUG In Konqueror 4.14.25

    Quote Originally Posted by wolfi323 View Post
    I just noticed that evince-browser-plugin is included again in Leap 42.2.
    Ouch. I should have noticed that.

    Uninstalling that seems to have made a big difference. Konqueror hasn't crashed yet.

    And note to others -- after uninstalling, I marked "evince-browser-plugin" as tabood (never to be installed).
    openSUSE Leap 15.1; KDE Plasma 5;

  8. #8

    Default Re: Possible BUG In Konqueror 4.14.25

    Sorry, for the delay in replying. Removing the plug-in fixes the crashing issue. Now when I go to the site, though, and click on the staff email link, I obtain a "bad request" page. Does not happen with Firefox! Any suggestions?

  9. #9

    Default Re: Possible BUG In Konqueror 4.14.25

    Quote Originally Posted by morrison27 View Post
    Now when I go to the site, though, and click on the staff email link, I obtain a "bad request" page. Does not happen with Firefox! Any suggestions?
    Hm, works fine here.

    Maybe a temporary problem at the site?

    Or try to delete the cookies in Konqueror's settings.
    Last edited by wolfi323; 07-Dec-2016 at 13:54.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •