Page 1 of 2 12 LastLast
Results 1 to 10 of 20

Thread: Problem upgrading to Leap 42.2 from 42.1

  1. #1
    Join Date
    Jul 2011
    Location
    Alpharetta, Georgia, USA
    Posts
    289

    Default Problem upgrading to Leap 42.2 from 42.1

    I'm attempting to upgrade to Leap 42.2 from 42.1 and zypper gives the following conflict message when I do a zypper dup:

    Code:
    Problem: akonadi-server-16.08.2-2.1.x86_64 conflicts with akonadi-runtime provided by akonadi-runtime-1.13.0-4.5.x86_64
    zypper then offers two solutions. Solution 1 is to keep a bunch of obsolete packages including akonadi-server and Solution 2 is to deinstall some other packages including akonadi-runtime. I have been running the Frameworks5/Plasma5 and Qt5 repos in 42.1. So, I have attempted the upgrade with the Frameworks5/Plasma5 and Qt5 repos both disabled and enabled for 42.2 but either way I get the conflict.

    Does anybody have a recommendation on how I should handle the conflicts and successfully perform the upgrade?

    Thanks,

    Gordon
    Laptop #1: OpenSUSE Leap 15.0 (x86_64) | HP ZBook 17 G2 (17")
    Laptop #2: OpenSUSE Leap 15.0 (x86_64) | System76 Darter (14")

  2. #2
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,585

    Default Re: Problem upgrading to Leap 42.2 from 42.1

    Be sure all repos point to the new 42.2

  3. #3
    Join Date
    Jul 2011
    Location
    Alpharetta, Georgia, USA
    Posts
    289

    Default Re: Problem upgrading to Leap 42.2 from 42.1

    Quote Originally Posted by gogalthorp View Post
    Be sure all repos point to the new 42.2
    Hi gogalthorp,

    Thanks for the reply. All of my repos are set to point to 42.2. Here is the output from "zypper lr --uri" with all of my extra add-on repos disabled:
    Code:
    #  | Alias                                 | Name                                  | Enabled | GPG Check | Refresh | URI                                                                                                     
    ---+---------------------------------------+---------------------------------------+---------+-----------+---------+---------------------------------------------------------------------------------------------------------
     1 | GLD - Bumblebee                       | GLD - Bumblebee                       | No      | ----      | No      | http://download.opensuse.org/repositories/X11:/Bumblebee/openSUSE_Leap_42.2/                            
     2 | GLD - Games_Tools_PlayOnLinux         | GLD - Games_Tools_PlayOnLinux         | No      | ----      | No      | http://download.opensuse.org/repositories/games:/tools/openSUSE_Leap_42.2/                              
     3 | GLD - wolfi323_Frameworks5_KDEConnect | GLD - wolfi323_Frameworks5_KDEConnect | No      | ----      | No      | http://download.opensuse.org/repositories/home:/wolfi323:/branches:/KDE:/Frameworks5/openSUSE_Leap_42.2/
     4 | GLD_-_Packman_multimedia              | GLD - Packman multimedia              | No      | ----      | No      | http://ftp.gwdg.de/pub/linux/packman/suse/openSUSE_Leap_42.2/                                           
     5 | GLD_-_Plasma_5                        | GLD - Plasma 5                        | No      | ----      | No      | http://download.opensuse.org/repositories/KDE:/Frameworks5/openSUSE_Leap_42.2/                          
     6 | GLD_-_Printing                        | GLD - Printing                        | No      | ----      | No      | http://download.opensuse.org/repositories/Printing/openSUSE_Leap_42.2/                                  
     7 | GLD_-_Qt5                             | GLD - Qt5                             | No      | ----      | No      | http://download.opensuse.org/repositories/KDE:/Qt5/openSUSE_Leap_42.2/                                  
     8 | GLD_-_Ubuntu_fonts_by_gldickens3      | GLD - Ubuntu fonts by gldickens3      | No      | ----      | No      | http://download.opensuse.org/repositories/home:/gldickens3/openSUSE_Leap_42.2/                          
     9 | GLD_-_libdvdcss_1                     | GLD - libdvdcss                       | No      | ----      | No      | http://opensuse-guide.org/repo/openSUSE_Leap_42.2/                                                      
    10 | download.opensuse.org-non-oss         | Main Repository (NON-OSS)             | Yes     | (r ) Yes  | Yes     | http://download.opensuse.org/distribution/leap/42.2/repo/non-oss/                                       
    11 | download.opensuse.org-non-oss_1       | Update Repository (Non-Oss)           | Yes     | (r ) Yes  | Yes     | http://download.opensuse.org/update/leap/42.2/non-oss/                                                  
    12 | download.opensuse.org-oss             | Main Repository (OSS)                 | Yes     | (r ) Yes  | Yes     | http://download.opensuse.org/distribution/leap/42.2/repo/oss/                                           
    13 | download.opensuse.org-oss_1           | Main Update Repository                | Yes     | (r ) Yes  | Yes     | http://download.opensuse.org/update/leap/42.2/oss/                                                      
    14 | http-download.opensuse.org-0cdd6e04   | openSUSE:Leap:42.2:Update             | Yes     | (r ) Yes  | Yes     | http://download.opensuse.org/repositories/openSUSE:/Leap:/42.2:/Update/standard/                        
    15 | http-download.opensuse.org-65e66900   | M17N:fonts                            | No      | ----      | No      | http://download.opensuse.org/repositories/M17N:/fonts/openSUSE_Leap_42.2/
    Any other ideas?

    Thanks,

    Gordon
    Laptop #1: OpenSUSE Leap 15.0 (x86_64) | HP ZBook 17 G2 (17")
    Laptop #2: OpenSUSE Leap 15.0 (x86_64) | System76 Darter (14")

  4. #4
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,585

    Default Re: Problem upgrading to Leap 42.2 from 42.1

    Mix with Wolfie's stuff maybe

    You apparently of conflicting repos. Maybe go into yast and see if you can see where things are coming from

  5. #5
    Join Date
    Jul 2011
    Location
    Alpharetta, Georgia, USA
    Posts
    289

    Default Re: Problem upgrading to Leap 42.2 from 42.1

    Quote Originally Posted by gogalthorp View Post
    Mix with Wolfie's stuff maybe

    You apparently of conflicting repos. Maybe go into yast and see if you can see where things are coming from
    Hi gogalthorp,

    Thanks for the quick reply. I think that you hit the nail on the head. A quick look at wolfi's repo show several akonadi related packages. I'll fix that, try again and let you know the results.

    I should have thought of that myself....

    Gordon
    Laptop #1: OpenSUSE Leap 15.0 (x86_64) | HP ZBook 17 G2 (17")
    Laptop #2: OpenSUSE Leap 15.0 (x86_64) | System76 Darter (14")

  6. #6

    Default AW: Re: Problem upgrading to Leap 42.2 from 42.1

    Quote Originally Posted by gldickens3 View Post
    Thanks for the quick reply. I think that you hit the nail on the head. A quick look at wolfi's repo show several akonadi related packages. I'll fix that, try again and let you know the results.
    If you want to use my repo, you should do a full switch to it. (and you should of course enable it too, and KDE:Qt5/KDE:Frameworks5 as well)
    My akonadi-server package does not conflict with akonadi-runtime.

    You cannot use both at the same time though, i.e. KDE4 applications won't work if an Akonadi5 server is running and vice-versa.

    Although, I see you named it GLD - wolfi323_Frameworks5_KDEConnect.
    If you only want to have the latest kdeconnect-kde, there's no need to use my repo (and I would actually disrecommend it).

    1.0.1 is included in 42.2's standard repos, 1.0.2 is available in KDE:Extra.

    If you do not (want to) use my repo, you should choose to uninstall akonadi-runtime if you want to install kdepim5.
    That's mentioned in the release notes even.

    But a zypper dup should actually not try to switch kdepim4 to kdepim5.
    If you currently have both installed, it will try to upgrade kdepim5 to the standard packages though which conflict with kdepim4.
    Last edited by wolfi323; 21-Nov-2016 at 10:22.

  7. #7
    Join Date
    Jul 2011
    Location
    Alpharetta, Georgia, USA
    Posts
    289

    Default Re: Problem upgrading to Leap 42.2 from 42.1

    Hi wolfi,

    Thanks for your reply. BTW, your repo is not working. Every time that its refreshed then it generates this error message:

    Code:
    File './repodata/a56127db107fc808ffb479c12513ea5b743d84c24a0a22126ceabd6a7c8826ce-appdata.xml.gz' not found on medium 'http://download.opensuse.org/repositories/home:/wolfi323:/branches:/KDE:/Frameworks5/openSUSE_Leap_42.1/'
    FYI,

    Gordon
    Laptop #1: OpenSUSE Leap 15.0 (x86_64) | HP ZBook 17 G2 (17")
    Laptop #2: OpenSUSE Leap 15.0 (x86_64) | System76 Darter (14")

  8. #8

    Default Re: Problem upgrading to Leap 42.2 from 42.1

    Quote Originally Posted by gldickens3 View Post
    Thanks for your reply. BTW, your repo is not working. Every time that its refreshed then it generates this error message:

    Code:
    File './repodata/a56127db107fc808ffb479c12513ea5b743d84c24a0a22126ceabd6a7c8826ce-appdata.xml.gz' not found on medium 'http://download.opensuse.org/repositories/home:/wolfi323:/branches:/KDE:/Frameworks5/openSUSE_Leap_42.1/'
    If you upgrade to 42.2, you should use the repo for 42.2 anyway.

    I will check the repo, but I'm not sure if I could do anything about it.
    Those files are created by OBS automatically.

    The mentioned file is there though:
    http://download.opensuse.org/reposit...42.1/repodata/

    Maybe some temporary inconsistency?

  9. #9
    Join Date
    Jul 2011
    Location
    Alpharetta, Georgia, USA
    Posts
    289

    Default Re: Problem upgrading to Leap 42.2 from 42.1

    Hi wolfi,

    I was able to successfully upgrade to 42.2. However, I ended up having to first remove akonadi-runtime and then akonadi-server as well prior to the upgrade. The primary kdepim packages that I use are korganizer and kaddressbook both of which I have installed since the upgrade to 42.2. Also, it appears that I am running kdepim4 and that akonadi-runtime was installed during the upgrade.

    So, my question now is: How do I get korganizer and kaddressbook to sync to my google calender since my google addressbook and google calender are no longer listed in my Akonadi Resources Configuration. When I click on "Add" then the google addressbook and google calender are no longer listed.

    Any ideas?

    Thanks,

    Gordon
    Laptop #1: OpenSUSE Leap 15.0 (x86_64) | HP ZBook 17 G2 (17")
    Laptop #2: OpenSUSE Leap 15.0 (x86_64) | System76 Darter (14")

  10. #10

    Default Re: Problem upgrading to Leap 42.2 from 42.1

    Quote Originally Posted by gldickens3 View Post
    Also, it appears that I am running kdepim4 and that akonadi-runtime was installed during the upgrade.
    Well, what do you have installed?
    akonadi-runtime or akonadi-server?
    korganizer or korganizer5?

    So, my question now is: How do I get korganizer and kaddressbook to sync to my google calender since my google addressbook and google calender are no longer listed in my Akonadi Resources Configuration. When I click on "Add" then the google addressbook and google calender are no longer listed.
    The KDE4 google resources are in kdepim4-runtime, the KF5 ones are in kdepim-runtime.
    Make sure the right one is installed (but I think it shouldn't be possible to have the wrong one).

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •