Results 1 to 5 of 5

Thread: opensuse 42.2, deluge don't work after upgrade to 42.2

  1. #1
    Join Date
    Nov 2016
    Location
    Russia
    Posts
    11

    Unhappy opensuse 42.2, deluge don't work after upgrade to 42.2

    Deluge don't start anymore after upgrade opensuse 42.1 -> 42.2. Get this error message

    Traceback (most recent call last):
    File "/usr/lib/python2.7/site-packages/deluge/ui/gtkui/gtkui.py", line 349, in _on_reactor_start
    client.start_classic_mode()
    File "/usr/lib/python2.7/site-packages/deluge/ui/client.py", line 559, in start_classic_mode
    self._daemon_proxy = DaemonClassicProxy(self.__event_handlers)
    File "/usr/lib/python2.7/site-packages/deluge/ui/client.py", line 432, in __init__
    self.__daemon = deluge.core.daemon.Daemon(classic=True)
    File "/usr/lib/python2.7/site-packages/deluge/core/daemon.py", line 141, in __init__
    from deluge.core.core import Core
    File "/usr/lib/python2.7/site-packages/deluge/core/core.py", line 36, in <module>
    from deluge._libtorrent import lt
    File "/usr/lib/python2.7/site-packages/deluge/_libtorrent.py", line 59, in <module>
    import libtorrent as lt
    ImportError: /usr/lib64/python2.7/site-packages/libtorrent.so: undefined symbol: _ZNK10libtorrent14announce_entry12can_announceEN5boost6chrono10time_pointINS2_12steady_clockENS2_8durationIlNS1_5ratioILl1ELl1000000000EEEEEEEb


    Anyone can help?

  2. #2
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,586
    Blog Entries
    14

    Default Re: opensuse 42.2, deluge don't work after upgrade to 42.2

    Please show output of
    Code:
    zypper lr -d
    between CODE tags, the # button in the layout editor.

    Plus, tell us where you installed deluge from, it's not part of the release.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  3. #3
    Join Date
    Nov 2016
    Location
    Russia
    Posts
    11

    Default Re: opensuse 42.2, deluge don't work after upgrade to 42.2

    Deluge installed from official release repo - openSUSE-42.2-0 http://download.opensuse.org/distrib...42.2/repo/oss/
    Here is rpm - http://download.opensuse.org/distrib...2.9.noarch.rpm



    Code:
    #  | Псевдоним                 | Имя                                     | Включён | Проверка GPG | Обновление | Приоритет | Тип    | URI                                                                      | Служба
    ---+---------------------------+-----------------------------------------+---------+--------------+------------+-----------+--------+--------------------------------------------------------------------------+-------
     1 | http-ftp.gwdg.de-ae2271dc | Packman Repository                      | Да      | (r ) Да      | Да         |   99      | rpm-md | http://ftp.gwdg.de/pub/linux/packman/suse/openSUSE_Leap_42.2/            |       
     2 | openSUSE-42.2-0           | openSUSE-42.2-0                         | Да      | (r ) Да      | Да         |   99      | yast2  | http://download.opensuse.org/distribution/leap/42.2/repo/oss/            |       
     3 | repo-debug                | openSUSE-Leap-42.2-Debug                | Нет     | ----         | Да         |   99      | NONE   | http://download.opensuse.org/debug/distribution/leap/42.2/repo/oss/      |       
     4 | repo-debug-non-oss        | openSUSE-Leap-42.2-Debug-Non-Oss        | Нет     | ----         | Да         |   99      | NONE   | http://download.opensuse.org/debug/distribution/leap/42.2/repo/non-oss/  |       
     5 | repo-debug-update         | openSUSE-Leap-42.2-Update-Debug         | Нет     | ----         | Да         |   99      | NONE   | http://download.opensuse.org/debug/update/leap/42.2/oss/                 |       
     6 | repo-debug-update-non-oss | openSUSE-Leap-42.2-Update-Debug-Non-Oss | Нет     | ----         | Да         |   99      | NONE   | http://download.opensuse.org/debug/update/leap/42.2/non-oss/             |       
     7 | repo-non-oss              | openSUSE-Leap-42.2-Non-Oss              | Да      | (r ) Да      | Да         |   99      | yast2  | http://download.opensuse.org/distribution/leap/42.2/repo/non-oss/        |       
     8 | repo-source               | openSUSE-Leap-42.2-Source               | Нет     | ----         | Да         |   99      | NONE   | http://download.opensuse.org/source/distribution/leap/42.2/repo/oss/     |       
     9 | repo-source-non-oss       | openSUSE-Leap-42.2-Source-Non-Oss       | Нет     | ----         | Да         |   99      | NONE   | http://download.opensuse.org/source/distribution/leap/42.2/repo/non-oss/ |       
    10 | repo-update               | openSUSE-Leap-42.2-Update               | Да      | (r ) Да      | Да         |   99      | rpm-md | http://download.opensuse.org/update/leap/42.2/oss/                       |       
    11 | repo-update-non-oss       | openSUSE-Leap-42.2-Update-Non-Oss       | Да      | (r ) Да      | Да         |   99      | rpm-md | http://download.opensuse.org/update/leap/42.2/non-oss/

  4. #4
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,586
    Blog Entries
    14

    Default Re: opensuse 42.2, deluge don't work after upgrade to 42.2

    Quote Originally Posted by LokiDrow View Post
    Deluge installed from official release repo - openSUSE-42.2-0 http://download.opensuse.org/distrib...42.2/repo/oss/
    Here is rpm - http://download.opensuse.org/distrib...2.9.noarch.rpm
    Hmmm, weird, software.opensuse.org doesn't show it being in the release, yet it is. I'll boot into Leap 42.2 tonight, install deluge and see what happens.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  5. #5
    Join Date
    Nov 2016
    Location
    Russia
    Posts
    11

    Red face Re: opensuse 42.2, deluge don't work after upgrade to 42.2

    Problem solved.
    Need to install libtorrent-rasterbar8, python-libtorrent-rasterbar; version 1.0.9 found, and deluge starts without errors

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •