Results 1 to 6 of 6

Thread: Gramps crashes after installation

  1. #1

    Default Gramps crashes after installation

    I installed OpenSUSE Leap 42.2 (fresh installation) and had to install my Gramps application again, of course.

    On starting Gramps, it crashed immediately with a python error message (I have submitted a bug to the Gramps site)

    However, I notice that only Gramps 4.2.0 is in this repository, and I believe that we should now be at 4.2.4 or 4.2.5. (Didn't we have one of these under Leap 42.1?)

    Why is only Gramps 4.2.0 available in the main repo now? (I see that 4.2.4 is in the Gnome:Apps repo. Is that where it is supposed to be?)

  2. #2
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    10,842
    Blog Entries
    2

    Default Re: Gramps crashes after installation

    You can submit a "Feature Request" at https://bugzilla.opensuse.org.
    The Maintainers will likely assign your request to whoever currently builds your app.

    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

  3. #3
    -G- NNTP User

    Default Re: Gramps crashes after installation

    On Sat, 19 Nov 2016 19:36:01 +0000, hnimmo wrote:

    > I installed OpenSUSE Leap 42.2 (fresh installation) and had to install
    > my Gramps application again, of course.
    >
    > On starting Gramps, it crashed immediately with a python error message
    > (I have submitted a bug to the Gramps site)


    I can confirm it, Gramps gives this error when run:

    15238: ERROR: grampsapp.py: line 107: Unhandled exception
    Traceback (most recent call last):
    File "/usr/lib/python3.4/site-packages/gramps/gui/widgets/
    styledtexteditor.py", line 289, in on_motion_notify_event
    self.match = self.textbuffer.match_check(iter_at_location.get_offset
    ())
    AttributeError: '_ResultTuple' object has no attribute 'get_offset'

  4. #4

    Default Re: Gramps crashes after installation

    I have submitted a bug report to the Opensuse bugzilla. See

    https://bugzilla.opensuse.org/show_bug.cgi?id=1011888

    Bob

  5. #5

    Default Re: Gramps crashes after installation

    On Sat, 19 Nov 2016 19:36:01 GMT
    hnimmo <hnimmo@no-mx.forums.microfocus.com> wrote:

    > I installed OpenSUSE Leap 42.2 (fresh installation) and had to install
    > my Gramps application again, of course.
    >
    > On starting Gramps, it crashed immediately with a python error message
    > (I have submitted a bug to the Gramps site)
    >
    > However, I notice that only Gramps 4.2.0 is in this repository, and I
    > believe that we should now be at 4.2.4 or 4.2.5. (Didn't we have one
    > of these under Leap 42.1?)
    >
    > Why is only Gramps 4.2.0 available now?
    >
    >


    It is available in the same way as other versions of openSUSE, i.e. via
    the Gnome:Apps repo
    http://download.opensuse.org/reposit...USE_Leap_42.2/

    Like all the other Gnome apps I use, it only gets put in this OBS repo
    and never gets pushed to factory or update. This has been the practice
    for the past dozen years or so in spite of what the documentation for
    that repo says.

    --
    Graham Davis, Bracknell, Berks., UK.
    openSUSE 13.2; KDE4; Kernel 4.8.9;
    AMD Athlon X4 860K Processor; Sound: FCH Azalia;
    Video: nVidia GeForce 210 (Driver: nouveau)


  6. #6

    Default Re: Gramps crashes after installation

    Quote Originally Posted by Cloddy View Post
    It is available in the same way as other versions of openSUSE, i.e. via
    the Gnome:Apps repo
    http://download.opensuse.org/reposit...USE_Leap_42.2/

    Like all the other Gnome apps I use, it only gets put in this OBS repo
    and never gets pushed to factory or update. This has been the practice
    for the past dozen years or so in spite of what the documentation for
    that repo says.

    --
    Graham Davis, Bracknell, Berks., UK.
    openSUSE 13.2; KDE4; Kernel 4.8.9;
    AMD Athlon X4 860K Processor; Sound: FCH Azalia;
    Video: nVidia GeForce 210 (Driver: nouveau)
    Nevertheless, something is wrong that seems to need correction: With only the main Repositories (OSS, NON-OSS, Update, Update Standard, Update Non-Oss) active, Gramps 4.2.0 was offered for installation (but I'm not sure from which repo.). But Gramps 4.2.0 had obviously not been integrated with Leap 42.2 and crashed immediately. Fortunately, Gramps is very good at protecting my user data, so no damage was done.

    Cheers
    Harvey

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •