Results 1 to 9 of 9

Thread: ALT+TAB doesn't show the list of windows

  1. #1

    Default ALT+TAB doesn't show the list of windows

    Hello everyone!

    I've just installed openSUSE Leap 42.2 and most things are working fine from scratch, but there's a really annoying issue that is bugging me a lot!

    When I try to switch from an open application to another using the ALT+TAB combination (it is so hard coded in my brain that I do this as a reflex) it doesn't switch to any other application, it doesn't even show a list of windows to select one. What it does is insert a bunch of TAB characters when I'm coding/writing or circle around the focus on the currently used application.

    I've been looking how to change this behavior in "System Settings" panel but even that the search text box shows results for ALT+TAB within "Window Management", I can't find the exact location of this setting



    Does anyone know how to bring the "normal" behavior to the ALT-TAB keys combination?

    Thank you very much in advance, regards...

    Nacho

  2. #2
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,173
    Blog Entries
    3

    Default Re: ALT+TAB doesn't show the list of windows

    I don't usually change windows that way, so I'm not sure what is "normal".

    For me, ALT-TAB produces a sidebar on the left of the screen containing an entry for each window. I can click on one to select a different window.

    The sidebar disappears as soon as I release the keys. Best seems to continue to hold down the ALT key after hitting the tab. And then the sidebar stays there to select a window.
    openSUSE Leap 15.1; KDE Plasma 5;

  3. #3

    Default Re: ALT+TAB doesn't show the list of windows

    Well... At least the behavior you describe would be good for me, but pressing ALT-TAB doesn't show anything for me on Leap 42.2

    Regarding "Normal" behavior, it was just a way to express what is expected to happen (not caring about related animations or effects) in order to switch from one open window to another. I briefly used (for a month or two) openSUSE Leap 42.1 in my previous job and I remember the behavior you describe, again, that would be more than fine for me.

    So, I'm not sure why it isn't working by default for me, but it would be really great to have it working in my installation.

    Thanks nrickert for making my question better (or at lest more understandable), so, any ideas?

    Regards...

  4. #4
    Join Date
    Jul 2008
    Location
    Seattle, WA
    Posts
    17,037

    Default Re: ALT+TAB doesn't show the list of windows

    On Fri, 18 Nov 2016 23:16:01 +0000, NachoGomez wrote:

    > Does anyone know how to bring the "normal" behavior to the ALT-TAB keys
    > combination?


    It might help someone help you to indicate what desktop environment
    you're using.

    Jim



    --
    Jim Henderson
    openSUSE Forums Administrator
    Forum Use Terms & Conditions at http://tinyurl.com/openSUSE-T-C

  5. #5

    Default Re: ALT+TAB doesn't show the list of windows

    Ooopss!

    I'm using the default KDE/Plasma installation

    Nacho

  6. #6
    Join Date
    Nov 2013
    Location
    Kamloops, BC, Canada
    Posts
    3,974

    Default Re: ALT+TAB doesn't show the list of windows

    I, too, am interested in this. I have always -- as far back as I can recall with windowed desktops -- flipped back and forth between open windows and apps using the Alt-Tab (or Alt-Shft-Tab to cycle in reverse).

    Are you saying that universal shortcut is suddenly no longer available in LEAP???

    I find that impossible to accept. Someone please confirm or clarify?

    I was about to start thinking about moving on from openSUSE 13.1 and test-installing LEAP, but if I understand this correctly, it is yet another roadblock that will keep me from trying LEAP.
    -Gerry Makaro
    Fraser-Bell Info Tech
    Solving Tech Mysteries since the Olden Days!
    ~~
    If I helped you, consider clicking the Star at the bottom left of my post.

  7. #7
    Join Date
    Nov 2013
    Location
    Kamloops, BC, Canada
    Posts
    3,974

    Default Re: ALT+TAB doesn't show the list of windows

    Have you looked in Configure Desktop (or whatever settings is now called for KDE/Plasma5) under Window Behavior, Task Switcher?

    That is where the Alt-Tab and Alt-Shift-Backtab (aka Alt-Shift-Tab) Window Switching Shortcuts appear in the Good KDE (kde4).

    Otherwise, look it up under the Shortcuts & Gestures module.
    -Gerry Makaro
    Fraser-Bell Info Tech
    Solving Tech Mysteries since the Olden Days!
    ~~
    If I helped you, consider clicking the Star at the bottom left of my post.

  8. #8
    Join Date
    Mar 2016
    Location
    New York
    Posts
    64

    Default Re: ALT+TAB doesn't show the list of windows

    It works fine on my 42.2 install, under configure desktop/desktop behavior/desktop effects/Window Managment/Flip Switch, just check off the box and alt tab away. while your there try the sphere it's wild..
    Motherboard: GA-EP45-UD3P
    CPU: Core2Quad Q8400 2.66GHz.
    Memory: 4 GIB DDR2
    GPU: Geforce GTX 650 1GIB Driver: NVIDIA G03- 340.96
    OS & Desktop: 42.2Leap 64 bit, KDE Plasma 5.8.3,QT 5.6.1 Kernel 4.4.27-2-deafult

  9. #9

    Thumbs up Re: ALT+TAB doesn't show the list of windows

    Well, I found that the ALT+TAB combination was assigned to another action in the Global Shortcuts section, by reassigning it now it behave as expected.

    Thanks everybody for your time and help!

    Regards...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •