Page 2 of 2 FirstFirst 12
Results 11 to 19 of 19

Thread: Multimedia Guide for openSUSE Leap 42.2

  1. #11

    Exclamation Re: Multimedia Guide for openSUSE Leap 42.2

    Okay, I have now installed OpenSUSE Leap 42.2 on two different machines with two very different experiences regarding restricted multimedia. The second machine had www access during install, the first didn't. With www access, it was a simple matter of checking the appropriate box during install, and everything Just Worked. The machine that was offline (and could not be online during OS install) is the problem. I've been using Linux since '07, but I am new to OpenSUSE; I am accustomed to distros that use Synaptic for package management.

    Before I get into details, I just have to wonder -- restricted/non-OSS capability is a problem that is ALREADY SOLVED, at least during the OS install process. Why is that chunk of script/code not accessible/usable for offline installs? Why must one resort to bash commands? One should NOT have to risk one's data by reinstalling the entire OS (and then have to re-update it) simply to access that single solitary check box, just because one did not have www access at that precise instant of initial OS install!!!

    So, anyway, once I got the machine online, I did try to install VLC via YaST (NOT from VideoLAN direct) FIRST. Of course, it still won't play MP3 or h264 MP4's. After going through a whole rigamarole to renew my ability to access this forum (lost password, compatibility issues with my cloud password storage method, plus re-verification here), I followed the above procedure. The repos added OK. But the final command, to install the actual packages.....

    machine:/home/sudoer # zypper install libxine2-codecs ffmpeg lame gstreamer-0_10-plugins-good gstreamer-0_10-plugins-bad gstreamer-0_10-plugins-ugly gstreamer-0_10-plugins-bad-orig-addon gstreamer-0_10-plugins-good-extra gstreamer-0_10-plugins-ugly-orig-addon gstreamer-0_10-plugins-ffmpeg libdvdcss2 flash-player dvdauthor07 gstreamer-plugins-base gstreamer-plugins-bad gstreamer-plugins-bad-orig-addon gstreamer-plugins-good gstreamer-plugins-ugly gstreamer-plugins-ugly-orig-addon gstreamer-plugins-good-extra gstreamer-0_10-plugins-fluendo_mpegdemux gstreamer-0_10-plugins-fluendo_mpegmux k3b-codecs gecko-mediaplayer vlc smplayer h264enc x264 gstreamer-plugins-libav vlc-codecs
    Loading repository data...
    Reading installed packages...
    'gstreamer-plugins-base' is already installed.
    No update candidate for 'gstreamer-plugins-base-1.8.3-5.3.2.x86_64'. The highest available version is already installed.
    'gstreamer-plugins-bad' is already installed.
    No update candidate for 'gstreamer-plugins-bad-1.8.3-5.3.1.x86_64'. The highest available version is already installed.
    'gstreamer-plugins-good' is already installed.
    No update candidate for 'gstreamer-plugins-good-1.8.3-5.6.1.x86_64'. The highest available version is already installed.
    'vlc' is already installed.
    There is an update candidate for 'vlc', but it is from a different vendor. Use 'zypper install vlc-2.2.4-34.6.x86_64' to install this candidate.
    'k3b-codecs' not found in package names. Trying capabilities.
    Resolving package dependencies...
    7 Problems:
    Problem: nothing provides libcdio.so.14()(64bit) needed by libxine2-codecs-1.2.6-114.1.x86_64
    Problem: nothing provides libdirectfb-1.6.so.0()(64bit) needed by gstreamer-0_10-plugins-bad-0.10.23-187.1.x86_64
    Problem: nothing provides libcdio.so.14()(64bit) needed by vlc-noX-2.2.4-34.6.x86_64
    Problem: nothing provides libcdio.so.14 needed by MPlayer-1.2.r37548-6.6.i586
    Problem: nothing provides libcdio.so.14()(64bit) needed by MPlayer-1.2.r37548-6.6.x86_64
    Problem: nothing provides libkcddb.so.4 needed by k3b-2.0.3-9.2.i586
    Problem: gstreamer-0_10-plugins-bad-orig-addon-0.10.23-187.1.x86_64 requires libmpeg2encpp-2.0.so.0()(64bit), but this requirement cannot be provided

    Problem: nothing provides libcdio.so.14()(64bit) needed by libxine2-codecs-1.2.6-114.1.x86_64
    Solution 1: do not install libxine2-codecs-1.2.6-114.1.x86_64
    Solution 2: break libxine2-codecs-1.2.6-114.1.x86_64 by ignoring some of its dependencies

    Choose from above solutions by number or skip, retry or cancel [1/2/s/r/c] (c):
    I cancelled out of the operation. So, I either already have something better, or can't get the package I need...what do I do now?

  2. #12
    Join Date
    Dec 2009
    Location
    Manchester, UK.
    Posts
    76

    Default Re: Multimedia Guide for openSUSE Leap 42.2

    Installed 42.3 (KDE) the other day. As I couldn't find the multimedia guide for that version, I used this guide.

    The only thing I can't play is mp3's.

    Any idea when the 42.3 multimedia guide will make an appearance?

    Thanks.
    openSUSE 42.3 (x86_64) KDE Plasma 5.8
    Gigabyte GA-MA785GM-US2H - AMD(R) DUAL CORE 270 @ 3.40GHz
    nVidia Geforce GTX280 - 8GB DDR2 800MHz RAM

    https://linuxcounter.net/user/482859.html

  3. #13
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    2,587

    Default AW: Multimedia Guide for openSUSE Leap 42.2

    Any idea when the 42.3 multimedia guide will make an appearance?
    Maybe when you publish it?

    If you have Problems, please open a new thread.

  4. #14
    Join Date
    Dec 2009
    Location
    Manchester, UK.
    Posts
    76

    Default Re: Multimedia Guide for openSUSE Leap 42.2

    Just did a zypper refresh && zypper update, which pulled down an extra 48 packages.

    mp3 is now working, so can say with confidence that the 42.2 multimedia guide run on 42.3 (KDE) was fine in getting all the necessary codecs etc. working for me


    openSUSE 42.3 (x86_64) KDE Plasma 5.8
    Gigabyte GA-MA785GM-US2H - AMD(R) DUAL CORE 270 @ 3.40GHz
    nVidia Geforce GTX280 - 8GB DDR2 800MHz RAM

    https://linuxcounter.net/user/482859.html

  5. #15
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,692
    Blog Entries
    20

    Default Re: Multimedia Guide for openSUSE Leap 42.2

    openSUSE_Leap_42.3_KDE
    My Articles Was I any help? If yes: Click the star below

  6. #16
    Peter_Abc NNTP User

    Default Re: Multimedia Guide for openSUSE Leap 42.2

    On 30/07/17 04:26, caf4926 wrote:
    >
    > https://forums.opensuse.org/entry.ph...ltimedia-Guide
    >


    I can not see it. The following is what shows up instead:

    >>Welcome! If this is your first visit, be sure to check out the

    FAQ. You will have to register before you can post in the forums. (Be
    aware the forums do not accept user names with a dash "-") Also, logging
    in lets you avoid the CAPTCHA verification when searching . Select
    Articles, Forum, or Blog. Posting in the Forums implies acceptance of
    the Terms and Conditions.

    Message
    Invalid Blog specified. If you followed a valid link, please notify the
    administrator<<


  7. #17
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,692
    Blog Entries
    20

    Default Re: Multimedia Guide for openSUSE Leap 42.2

    openSUSE_Leap_42.3_KDE
    My Articles Was I any help? If yes: Click the star below

  8. #18
    Peter_Abc NNTP User

    Default Re: Multimedia Guide for openSUSE Leap 42.2

    On 30/07/17 15:46, caf4926 wrote:
    >
    > Is also here
    > http://tinyurl.com/y9ypwyvs
    >


    Much better link and many thanks for the guide.

    Cheers,
    Peter


  9. #19

    Default Re: Multimedia Guide for openSUSE Leap 42.2

    "If you have a problem please make a new thread". Fine. I've copied my above wall of text, but for some reason I do not seem to be able to edit or delete it. If there is a mod/admin watching please delete my above post. Now I'm going to hunt around and find the right place to repost it
    Xheralt
    Registered Linux User #459491
    "Ignorance killed the cat, Curiosity was framed!" -- C.J. Cherryh

Page 2 of 2 FirstFirst 12

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •