Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: Recent update changed lid switch behaviour. How to undo?

  1. #1
    Join Date
    Jun 2008
    Location
    Hessia
    Posts
    303

    Question Recent update changed lid switch behaviour. How to undo?

    My system worked fine. Then I updated all packages through YaST's software tool, as I usually do after a couple of months.

    Problem: The laptop suspends if the lid remains unchanged, but closed.

    Before the update, the laptop would only suspend if the lid changed from open to closed. Now it always suspends if the lid is closed, regardless of whether the lid was closed before.

    Background:
    I use my laptop with several docking stations. In the main docking station, I only use two external monitors, while the laptop is docked with a closed lid. I dock with the laptop being powered down. I power up the laptop with the lid being closed the entire time. I have this setup since several years and used it for most workdays throughout the year without a problem.

    Now the laptop goes quickly to sleep after I log in in this configuration. I can restart by pressing the power button, but the laptop quickly goes to sleep again. The lid remains closed the entire time. If I open the lid, the laptop remains awake, but then I have to disable the laptop's internal display, which causes other problems, as I use docking stations with one external display where the internal display is used alongside.

    Thanks for any suggestions on how to restore the original behaviour.
    I am on Leap42.1 with KDE.

  2. #2
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    27,071
    Blog Entries
    15

    Default Re: Recent update changed lid switch behaviour. How to undo?

    Hi
    Check the settings in /etc/systemd/logind.conf here you can set/change behavior (see man logind.conf for full info on the options).

    I don't use suspend, so on my laptops I remove the # on HandleLidSwitch= and set to ignore rather than suspend
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  3. #3
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    2,559

    Default Re: Recent update changed lid switch behaviour. How to undo?

    Quote Originally Posted by malcolmlewis View Post
    /etc/systemd/logind.conf (see man logind.conf for full info on the options).

    I remove the # on HandleLidSwitch= and set to ignore rather than suspend
    Yes but, in the logind.conf man page it states:
    Note that the lid switch is ignored if the system is inserted in a docking station, or if more than one display is connected.
    I suspect that what needs to be done, is in the KDE Plasma 5 System Settings, Power Management category, Energy Saving module, the "Button events handling" needs to be set to "When laptop lid closed" -->> "Do nothing" ("Even when an external monitor is connected").

  4. #4
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    27,071
    Blog Entries
    15

    Default Re: Recent update changed lid switch behaviour. How to undo?

    Quote Originally Posted by dcurtisfra View Post
    Yes but, in the logind.conf man page it states:
    Hi
    Ahh yes in 42.1 it's different, 42.2 and Tumbleweed if no action set for HandleLidSwitchDocked then it falls back.
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  5. #5
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    2,559

    Unhappy Re: Recent update changed lid switch behaviour. How to undo?

    Quote Originally Posted by malcolmlewis View Post
    Ahh yes in 42.1 it's different, 42.2 and Tumbleweed if no action set for HandleLidSwitchDocked then it falls back.
    It gets worse: Leap 42.1 has "LidSwitchIgnoreInhibited=" and "PowerKeyIgnoreInhibited=, SuspendKeyIgnoreInhibited= and HibernateKeyIgnoreInhibited= default to "off". LidSwitchIgnoreInhibited= defaults to "yes". This means that the lid switch does not respect suspend blockers by default, but the power and sleep keys do."; Leap 42.2 RC2 has something totally different.

    My bets are still with KDE Plasma 5 PowerDevil -- I suspect that, the KDE PowerDevil folks haven't (yet) considered the case of Laptops which use Docking Stations . . .

  6. #6

    Default Re: Recent update changed lid switch behaviour. How to undo?

    Quote Originally Posted by dcurtisfra View Post
    It gets worse: Leap 42.1 has "LidSwitchIgnoreInhibited=" and "PowerKeyIgnoreInhibited=, SuspendKeyIgnoreInhibited= and HibernateKeyIgnoreInhibited= default to "off". LidSwitchIgnoreInhibited= defaults to "yes". This means that the lid switch does not respect suspend blockers by default, but the power and sleep keys do."; Leap 42.2 RC2 has something totally different.
    No, that's wrong. LidSwitchIgnoreInhibited=yes should *not* inhibit (KDE's e.g.) suspend blockers (inhibitions). This was a bug in the previous systemd update.
    The latest one restored the old state in this regard.
    See also: http://bugzilla.opensuse.org/show_bug.cgi?id=1001790
    And the default settings have not been changed at all.

    Code:
    My bets are still with KDE Plasma 5 PowerDevil -- I suspect that, the KDE PowerDevil folks haven't (yet) considered the case of Laptops which use Docking Stations . . .
    Nonsense. Especially if it worked as expected before (there hasn't been any update to KDE or powerdevil recently)
    Must be related to the systemd update I suppose.

    PS: apparently that latest systemd update has not been released for 42.1 yet (I got it on 13.2 yesterday...).
    Should be there in the next days then, I suppose...
    Last edited by wolfi323; 16-Nov-2016 at 04:24.

  7. #7
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    2,559

    Default Re: Recent update changed lid switch behaviour. How to undo?

    Quote Originally Posted by wolfi323 View Post
    No, that's wrong. LidSwitchIgnoreInhibited=yes should *not* inhibit (KDE's e.g.) suspend blockers (inhibitions). This was a bug in the previous systemd update.
    The latest one restored the old state in this regard.
    Reading the openSUSE and GitHub bug reports, it seems that the man page text has never reflected what SHOULD happen and, it caused an unnecessary code change which had to be reverted -- commit date of the reverted code: 2016-08-08. Hopefully this time around the systemd folks will correct the man page text to remove the confusion.

    Quote Originally Posted by wolfi323 View Post
    PS: apparently that latest systemd update has not been released for 42.1 yet (I got it on 13.2 yesterday...).
    It hit Leap 42.2 RC2 this morning and is presumably therefore also in the Leap 42.2 production release which occurred a couple of hours ago.
    I'll check my Leap 42.1 system before applying the Leap 42.2 update later today.

  8. #8
    Join Date
    Jun 2008
    Location
    Hessia
    Posts
    303

    Question Re: Recent update changed lid switch behaviour. How to undo?

    Thanks for all the replies.

    Changing the KDE settings did not change the behaviour: I have checked the KDE Powermodul and the settings are "ticked checkbox for what do to when the lid is closed with selection to <do nothing>" and also checked "even when an external monitor is connected".

    my logind.conf contains the following:
    Code:
     [Login]#NAutoVTs=6
    #ReserveVT=6
    #KillUserProcesses=no
    #KillOnlyUsers=
    #KillExcludeUsers=root
    #InhibitDelayMaxSec=5
    #HandlePowerKey=poweroff
    #HandleSuspendKey=suspend
    #HandleHibernateKey=hibernate
    #HandleLidSwitch=suspend
    #PowerKeyIgnoreInhibited=no
    #SuspendKeyIgnoreInhibited=no
    #HibernateKeyIgnoreInhibited=no
    #LidSwitchIgnoreInhibited=yes
    #IdleAction=ignore
    #IdleActionSec=30min
    ...so everything is set to default. I did not try to change anything here, as I do want the lid switch to have an effect when an opened lid is closed - i just don't want any action if the lid remains closed all the time?

  9. #9

    Default Re: Recent update changed lid switch behaviour. How to undo?

    Quote Originally Posted by dcurtisfra View Post
    Reading the openSUSE and GitHub bug reports, it seems that the man page text has never reflected what SHOULD happen and, it caused an unnecessary code change which had to be reverted -- commit date of the reverted code: 2016-08-08.
    Yes.
    Unfortunately that wrong behavior change made it into the systemd 231 release, and got backported to all supported openSUSE releases too.

    Hopefully this time around the systemd folks will correct the man page text to remove the confusion.
    Yes they have, and that has been included in the latest update too:
    Code:
    * Mon Oct 24 2016 fbui@suse.com
    - Import commit
      2ad9feb man: explain that *KeyIgnoreInhibited only apply to a subset of locks
      60ac1f8 Revert "logind: really handle *KeyIgnoreInhibited options in logind.conf" (bsc#1001790 bsc#1005404)
    It hit Leap 42.2 RC2 this morning and is presumably therefore also in the Leap 42.2 production release which occurred a couple of hours ago.
    I'll check my Leap 42.1 system before applying the Leap 42.2 update later today.
    Yes, the systemd followup update did still make it into 42.2 final apparently.

  10. #10

    Default Re: Recent update changed lid switch behaviour. How to undo?

    Quote Originally Posted by STurtle View Post
    Changing the KDE settings did not change the behaviour: I have checked the KDE Powermodul and the settings are "ticked checkbox for what do to when the lid is closed with selection to <do nothing>" and also checked "even when an external monitor is connected".
    Yes, that's exactly what that bug is about:
    systemd ignores KDE's lidswitch inhibition, and handles the lidswitch itself (without respecting KDE's settings of course).

    You can "fix" it by setting "LidSwitchIgnoreInhibited=no" in logind.conf (then KDE should be able to take over), or just wait for the update to be released which will hopefully be in the next days.

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •