Results 1 to 4 of 4

Thread: File './x86_64/libgcc_s1-debuginfo-4.8.5-169.1.x86_64.rpm' not found on medium

  1. #1

    Default File './x86_64/libgcc_s1-debuginfo-4.8.5-169.1.x86_64.rpm' not found on medium

    Hello,

    I am trying to install some of the gcc debug libraries to get the proper output from gdb but I am getting an error that yast cannot connect to the repository.

    Code:
    File './x86_64/libgcc_s1-debuginfo-4.8.5-169.1.x86_64.rpm' not found on medium
    The repository is listed as,

    Code:
    http://download.opensuse.org/repositories/devel:/gcc/openSUSE_13.2/
    The repository still seems to exist and I can access the url in my browser. The file libgcc_s1-debuginfo-4.8.5-169.1.x86_64.rpm is listed in the x86_64 directory, but I get a 404 error when I click on the link.


    I was able to install one of the missing libraries but when I went to install the second, I got the error.

    This is the output from zypper lr -d in case that is helpful.


    Code:
    #  | Alias                     | Name                               | Enabled | GPG Check | Refresh | Priority | Type   | URI                                                                                    | Service
    ---+---------------------------+------------------------------------+---------+-----------+---------+----------+--------+----------------------------------------------------------------------------------------+--------
     1 | devel:gcc                 | devel:gcc                          | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/devel:/gcc/openSUSE_13.2/                    |        
     2 | home:badshah400:gcc3      | home:badshah400:gcc3               | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/home:/badshah400:/gcc3/openSUSE_13.2/        |        
     3 | home:beyerle:playground   | home:beyerle:playground            | Yes     | (r ) Yes  | No      |   99     | rpm-md | http://ftp5.gwdg.de/pub/opensuse/repositories/home:/beyerle:/playground/openSUSE_13.2/ |        
     4 | repo-debug                | openSUSE-13.2-Debug                | Yes     | (r ) Yes  | Yes     |   99     | yast2  | http://download.opensuse.org/debug/distribution/13.2/repo/oss/                         |        
     5 | repo-debug-update         | openSUSE-13.2-Update-Debug         | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/debug/update/13.2/                                        |        
     6 | repo-debug-update-non-oss | openSUSE-13.2-Update-Debug-Non-Oss | No      | ----      | Yes     |   99     | NONE   | http://download.opensuse.org/debug/update/13.2-non-oss/                                |        
     7 | repo-non-oss              | openSUSE-13.2-Non-Oss              | Yes     | ( p) Yes  | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/13.2/repo/non-oss/                           |        
     8 | repo-oss                  | openSUSE-13.2-Oss                  | Yes     | ( p) Yes  | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/13.2/repo/oss/                               |        
     9 | repo-source               | openSUSE-13.2-Source               | No      | ----      | Yes     |   99     | NONE   | http://download.opensuse.org/source/distribution/13.2/repo/oss/                        |        
    10 | repo-update               | openSUSE-13.2-Update               | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/13.2/                                              |        
    11 | repo-update-non-oss       | openSUSE-13.2-Update-Non-Oss       | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/13.2-non-oss/
    Can I get this file from another source? Does anyone have any idea why it is missing from the repo?

    I was able to download the rpm from the older 13.1 repo but I am not sure if that file will be compatible or how to go about installing it.

    LMHmedchem


  2. #2
    Join Date
    Sep 2008
    Posts
    2,997

    Default Re: File './x86_64/libgcc_s1-debuginfo-4.8.5-169.1.x86_64.rpm' not found on medium

    the way download.opensuse.org works is it redirects you to the nearest mirror it's probably a mirror issue, as you said it can be found on other mirrors, files across mirrors are identical and this can be verified by the opensuse pgp signature, some mirrors don't carry the -debuginfo files if you can find it on a different mirror download it and install it with zypper if there's something wrong with the file zypper will inform you about it (missing or damaged digital signature)

  3. #3

    Default Re: File './x86_64/libgcc_s1-debuginfo-4.8.5-169.1.x86_64.rpm' not found on medium

    Quote Originally Posted by I_A View Post
    the way download.opensuse.org works is it redirects you to the nearest mirror it's probably a mirror issue, as you said it can be found on other mirrors, files across mirrors are identical and this can be verified by the opensuse pgp signature, some mirrors don't carry the -debuginfo files if you can find it on a different mirror download it and install it with zypper if there's something wrong with the file zypper will inform you about it (missing or damaged digital signature)
    I got the two files from here,
    http://rpm.pbone.net/

    I installed them with apper installer and not zypper. Will that create a problem?

    I am not getting the same messages when running gdb, so at least gdb seems to think things are ok.

    I am getting this warning,

    Code:
    warning: /etc/gdbinit.d/gdb-heap.py: No such file or directory
    but a search on that seems to suggest this is a harmless warning.

    I am also getting a message about,

    Code:
    Got object file from memory but can't read symbols: File truncated.
    I'm not sure what this is about but the gdb installation seems to be working at least.

    LMHmedchem

  4. #4
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,319
    Blog Entries
    15

    Default Re: File './x86_64/libgcc_s1-debuginfo-4.8.5-169.1.x86_64.rpm' not found on medium

    Hi
    Looks like a publishing issue, you need to contact the devel:gcc repository maintainers.
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •