Results 1 to 7 of 7

Thread: Could not start d-bus. can you call qdbus-qt5 ?

  1. #1

    Default Could not start d-bus. can you call qdbus-qt5 ?

    I'm using KDE and whenever i try to load my distro it gets to the login screen and everything looks like it's fine but when i type my pass and login it freezes and gives a message saying "Could not start d-bus. can you call qdbus-qt5 ?", Could someone please tell me how to fix it :/ ?

  2. #2

    Default Re: Could not start d-bus. can you call qdbus-qt5 ?

    Next time please search the forum first, there were at least two threads (and a bug report) about this problem recently, with exactly the same title...

    Apparently the "installers" of some software (Anaconda e.g.) break the system Qt5 installation.

    But ok: logout (press Ctrl+Alt+Backspace twice to kill the X session and get back to the login screen), choose IceWM at the login screen and login again. This will give you a graphical session to make debugging easier...

    Then post the output of these commands: (run as user)
    Code:
    qdbus-qt5
    qtpaths --binaries-dir
    which qtpaths

  3. #3

    Default Re: Could not start d-bus. can you call qdbus-qt5 ?

    Quote Originally Posted by wolfi323 View Post
    Next time please search the forum first, there were at least two threads (and a bug report) about this problem recently, with exactly the same title...

    Apparently the "installers" of some software (Anaconda e.g.) break the system Qt5 installation.

    But ok: logout (press Ctrl+Alt+Backspace twice to kill the X session and get back to the login screen), choose IceWM at the login screen and login again. This will give you a graphical session to make debugging easier...

    Then post the output of these commands: (run as user)
    Code:
    qdbus-qt5
    qtpaths --binaries-dir
    which qtpaths
    Sorry, next time i will check before posting

    Oh yes i did install Anaconda before closing the last time

    output:
    Code:
    > qdbus-qt5
    :1.1
    :1.10
     org.kde.konsole
    :1.11
    :1.2
    :1.3
     org.gnome.GConf
    :1.4
     org.a11y.Bus
    :1.5
    :1.6
     org.gtk.vfs.Daemon
    :1.7
    :1.8
     org.PulseAudio1
     org.pulseaudio.Server
    :1.9
    org.freedesktop.DBus
    
    > qtpaths --binaries-dir
    /home/haib/anaconda3/bin
    
    > which qtpaths
    /home/haib/anaconda3/bin/qtpaths

  4. #4

    Default Re: Could not start d-bus. can you call qdbus-qt5 ?

    That's exactly the problem:
    Quote Originally Posted by haib610 View Post
    Oh yes i did install Anaconda before closing the last time

    output:
    Code:
    > qtpaths --binaries-dir
    /home/haib/anaconda3/bin
    
    > which qtpaths
    /home/haib/anaconda3/bin/qtpaths
    This means that startkde tries to find qdbus-qt5 in /home/haib/anaconda3/bin, where it doesn't exist.
    You basically have these options to fix it:
    - remove the PATH= line that the Anaconda installer added from your ~/.bashrc and set the path manually before running Anaconda
    - copy or symlink qdbus-qt5 in /home/haib/anaconda3/bin
    - modify /usr/bin/startkde and add the explicit path to the call to qtpaths, i.e. replace qtpaths with /usr/bin/qtpaths

    See also https://forums.opensuse.org/showthre...dbus-qt5/page3 for the previous discussion...

    Btw, I submitted the second change to openSUSE's Plasma5 packages recently so this should not happen any more in Tumbleweed and Leap 42.2, but not yet as update for 42.1.
    Though, I still think it's a bug in Anaconda's installer that might break other things as well.

  5. #5

    Default Re: Could not start d-bus. can you call qdbus-qt5 ?

    Quote Originally Posted by wolfi323 View Post
    That's exactly the problem:

    This means that startkde tries to find qdbus-qt5 in /home/haib/anaconda3/bin, where it doesn't exist.
    You basically have these options to fix it:
    - remove the PATH= line that the Anaconda installer added from your ~/.bashrc and set the path manually before running Anaconda
    - copy or symlink qdbus-qt5 in /home/haib/anaconda3/bin
    - modify /usr/bin/startkde and add the explicit path to the call to qtpaths, i.e. replace qtpaths with /usr/bin/qtpaths

    See also https://forums.opensuse.org/showthre...dbus-qt5/page3 for the previous discussion...

    Btw, I submitted the second change to openSUSE's Plasma5 packages recently so this should not happen any more in Tumbleweed and Leap 42.2, but not yet as update for 42.1.
    Though, I still think it's a bug in Anaconda's installer that might break other things as well.
    sorry :/ ..
    I did remove the PATH= line from ~/.bashrc
    but for copying qdbus-qt5, i don't know where to find it so i can copy it :/ ?
    and for modifying /usr/bin/startkde what is the exact line i should replace with /usr/bin/qtpaths ?

  6. #6

    Default Re: Could not start d-bus. can you call qdbus-qt5 ?

    Quote Originally Posted by haib610 View Post
    sorry :/ ..
    I did remove the PATH= line from ~/.bashrc
    Well, then Plasma should start again, no?
    Nothing else should be necessary.

    but for copying qdbus-qt5, i don't know where to find it so i can copy it :/ ?
    /usr/bin/, or /usr/lib64/qt5/bin, or use Anaconda's copy in the same folder (shouldn't really matter in this case).

    and for modifying /usr/bin/startkde what is the exact line i should replace with /usr/bin/qtpaths ?
    Search for "qtpaths --binaries-dir" and replace "qtpaths" with "/usr/bin/qtpaths" there.
    I have the latest version 5.8.3 installed, where the line numbers likely changed.

    But again, this and the previous change are only necessary if you want to keep the PATH= in ~/.bashrc. And only one of them would be necessary either.

  7. #7

    Default Re: Could not start d-bus. can you call qdbus-qt5 ?

    It Worked thank you so much !

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •