Results 1 to 3 of 3

Thread: gvim V8 display problem

  1. #1
    Join Date
    Aug 2008
    Location
    Belgium
    Posts
    187

    Default gvim V8 display problem

    Hello,

    when I try to open a text file with gvim i receive a window with the command bar but no text displayed: It is impossible to enter any character. But the commands work! typing ":q" and gvim exits.
    If I start it in console I receive a lot of error
    Code:
    philippe@hpprol2:~> gvim a
    
    ** (gvim:25564): WARNING **: Couldn't register with accessibility bus: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
    philippe@hpprol2:~> 
    (gvim:25564): Gtk-CRITICAL **: gtk_widget_set_size_request: assertion 'width >= -1' failed
    *** BUG ***
    In pixman_region32_init_rect: Invalid rectangle passed
    Set a breakpoint on '_pixman_log_error' to debug
    
    *** BUG ***
    In pixman_region32_init_rect: Invalid rectangle passed
    Set a breakpoint on '_pixman_log_error' to debug
    
    
    (gvim:25564): Gtk-CRITICAL **: gtk_widget_set_size_request: assertion 'width >= -1' failed
    
    (gvim:25564): Gtk-CRITICAL **: gtk_widget_set_size_request: assertion 'width >= -1' failed
    *** BUG ***
    In pixman_region32_init_rect: Invalid rectangle passed
    Set a breakpoint on '_pixman_log_error' to debug
    I reinstalled gvim, vim and vim_data but the problem remains

    Anybody can confirm the problem?

    Regards
    Philippe
    Tumbleweed (x86_64) Kernel 5.2.1 with KDE plasma

  2. #2
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    10,823
    Blog Entries
    1

    Default Re: gvim V8 display problem

    From what you posted, I don't know what your problem has to do with V8...

    It looks like a QT problem,
    So especially since you're running on TW, this kind of problem (apps interacting with a display library like QT) can be expected from time to time.

    Recommend you submit a bug report (if one doesn't already exist) to https://bugzilla.opensuse.org.

    Be sure to include your TW version which if you don't know from your install media can be retrieved from the following
    Code:
    cat /etc/os-release
    And if you have any other repos installed besides the main TW repo... If no other repos are installed, then I'd assume that your gvim and QT are from the TW repo (if not, then be sure to include in your bug report).

    IMO,
    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

  3. #3
    Join Date
    Aug 2008
    Location
    Belgium
    Posts
    187

    Default Re: gvim V8 display problem

    Thanks,

    I found a bug report in bugzilla with the same problem
    https://bugzilla.opensuse.org/show_bug.cgi?id=1008800
    "gvim fails to render edit window"
    I'll wait the correction.

    Regards
    Philippe
    Tumbleweed (x86_64) Kernel 5.2.1 with KDE plasma

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •