Results 1 to 6 of 6

Thread: Authentication problem of Google Hangouts in Telepathy while re-connecting

  1. #1
    Join Date
    Jan 2016
    Location
    Manchester, UK
    Posts
    279

    Default Authentication problem of Google Hangouts in Telepathy while re-connecting

    Hi all,

    I found Telepathy to be an elegant client of IM after trying it last week. But I have a problem to make it automatically re-login with my Google Hangouts account. I hope someone could shed some light on how to debug it in openSUSE Tumbleweed with KDE Plasma 5.8.3 and KDE Framework 5.27.0. The Telepathy is installed from KDE Extra repo.

    The symptom is described as following,

    1. After installing KTp and relative packages, add Google account from Online Accounts in System Settings. A pop up windows will rise up for authenticating with Google server. This step is smooth even 2-step verification is enabled.

    2. Instant Messaging (in the task bar) will have no problem logon to enable Google Hangouts chatting. And it was set to automatically logon at startup.

    3. Reboot the system, Instant Messaging will report "There was a problem while trying to connect xxx@gmail.com - Authentication of your account failed (is your password correct?)". At the same time, other XMPP accounts are connected properly.

    4. Tick off Hangouts from Google account in Online Accounts in System Settings, and reboot the system.

    5. Ticking on Hangouts from Google account in Online Accounts in System Settings, and making Instant Messaging (in the task bar) offline and online again, Hangouts will connect correctly after a while.

    So the problem is, one cannot always try to connect Google Hangouts by rebooting the system and tick the Hangouts on and off all the time. I want to debug this and file a bug later on KDE bug list. But I am new to Linux and know very little about debug. Could anyone give me some hints on how to debug, or a nearest example of debugging on other apps could also help I think.

    Does anyone else run into the similar situation on Telepathy? If so, please share your findings/solutions. In case it helps, Kopete has no problem to re-connect my Google accounts after a reboot. But I want to learn how to debug and even solve the problem. I hope I can contribute to the communities after a while if possible.

    Thanks in advance. Any comment/suggestion is welcomed.
    openSUSE Tumbleweed (usually the latest snapshot) w/ KDE Plasma 5

  2. #2
    Join Date
    Jan 2016
    Location
    Manchester, UK
    Posts
    279

    Default Re: Authentication problem of Google Hangouts in Telepathy while re-connecting

    Sorry for 2 mistakes in upper post,

    1. Telepathy is installed from Tumblewedd OSS repo;
    2. It seems the procedure does NOT work always meaning that a successful logon of Hangouts cannot be guaranteed through disable/enable and reboot.

    Anyway, an intro for getting start to debug is appreciated.
    openSUSE Tumbleweed (usually the latest snapshot) w/ KDE Plasma 5

  3. #3
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,581
    Blog Entries
    14

    Default Re: Authentication problem of Google Hangouts in Telepathy while re-connecting

    Hi, welcome,

    Here's what I did:
    - Configured an online-account for my Google account
    - Set Instant Messaging to restore the previous state ( mind, the checkbox was semi-checked, clicking it changed that )
    - Logged out, logged back in
    The result was that, as soon as my wifi connection was established, the instant messaging went online.

    To make sure, I also rebooted, same result.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  4. #4
    Join Date
    Jan 2016
    Location
    Manchester, UK
    Posts
    279

    Default Re: Authentication problem of Google Hangouts in Telepathy while re-connecting

    Dear Knurpht,

    Thanks a lot for your response. The problem is solved now. I should've come here with this problem earlier.

    The problem seems to be caused by a missing package of `signon-kwallet-extension`. But I am not absolutely sure about this. Further investigation will done on this later.

    Here is what I have done. Because your Telepathy seems working very well. So I double checked my installation (and also a reinstallation). And I found that there is only the `patterns-openSUSE-kde_telepathy` that I thought would be no use and had not installed. So I installed this PATTERN in YaST2 (before this, I used zypper in cli to install the packages). And a suggested package of `signon-kwallet-extension` was installed with this pattern. (My KMail asked for password for my Gmail account after the installation of `signon-kwallet-extension` but only once. I am not sure is this relevant, or useful information.)

    After this reinstallation, I cleaned all the accounts in Online Accounts in System Settings, and added them back again.

    Of course, I ticked on `Restore last presence on login` through `General` tab in `Instant Message Settings ...`(by right clicking on the icon in task bar) by changing to full selected from half selected.

    Now, Google Hangouts account automatically logs on without problem.

    Thank you very much. And hope this information could be helpful to others.
    openSUSE Tumbleweed (usually the latest snapshot) w/ KDE Plasma 5

  5. #5
    Join Date
    Jan 2016
    Location
    Manchester, UK
    Posts
    279

    Default Re: Authentication problem of Google Hangouts in Telepathy while re-connecting

    Quote Originally Posted by cnzhx View Post
    The problem seems to be caused by a missing package of `signon-kwallet-extension`. But I am not absolutely sure about this. Further investigation will done on this later.
    I tested this on a fresh installed openSUSE Tumbleweed system based on snapshot 20161109 (in a virtual machine). The Telepathy was just installed by issuing the following command in console,

    Code:
    # zypper install telepathy-kde
    and 17 packages were installed including,

    Code:
    The following 17 NEW packages are going to be installed:
      ktp-approver ktp-auth-handler ktp-common-internals ktp-contact-list ktp-contact-runner
      ktp-desktop-applets ktp-filetransfer-handler ktp-icons ktp-kded-module ktp-send-file
      ktp-text-ui libKF5WebKit5 libtelepathy-logger3 libtelepathy-logger-qt5
      libtelepathy-qt5-service0 telepathy-kde telepathy-logger
    The truth is, in this new system without the package of `signon-kwallet-extension`, Telepathy works very well with Google Hangouts, meaning the account can automatically login after reboot.

    So maybe it finally works in my system just because I deleted and re-created all the accounts again. I am pretty sure that I had tried to (only) delete/re-create my Google account in this system before I finally posted this problem here.

    I am totally confused.
    openSUSE Tumbleweed (usually the latest snapshot) w/ KDE Plasma 5

  6. #6
    Join Date
    Jan 2016
    Location
    Manchester, UK
    Posts
    279

    Default Re: Authentication problem of Google Hangouts in Telepathy while re-connecting

    This problem is driving me crazy. The auto login of Google Hangouts fails now and then, sometimes with reboot, sometimes with resume from hibernate. But it seems totally no pattern after this long term observation. I never know when it will automatically login successfully or fail to do that.

    Anyone experiences the same symptom?
    openSUSE Tumbleweed (usually the latest snapshot) w/ KDE Plasma 5

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •