Results 1 to 2 of 2

Thread: Gnome Software and Discover not installing third party RPMs

  1. #1

    Default Gnome Software and Discover not installing third party RPMs


    I am currently trying out openSUSE tumbleweed in two virtual machines: two fresh installs, one with a Gnome desktop and one with Plasma desktop. I have tried using gnome-software and discover on their respective desktops to install third party RPMs that I had manually downloaded. However, it seems both are unable to do so (which make it look like it may be related to packagekit itself). From nautilus/dolphin, opening the RPM in with gnome-software/discover does nothing. From the command line, gnome-software has a --local-filename option to open a local package file, which opens up gnome-software saying "The file is not supported".
    Installing packages from the official repositories that are listed by gnome-software/discover, on the other hand, works perfectly.
    The problem does not come from the RPMs themselves I believe, as YaST can install them just fine and they seem to work properly when installed.
    The RPMs I tried to install are for Visual Studio Code and Ghetto-Skype.

    I know openSUSE has YaST for package installation, but it seems weird that those two packagekit applications seem to not be able to install third party RPMs, while I was able to do that in Fedora for example.
    I have no idea if this could be related, but something similar happened in Ubuntu a few months ago:

  2. #2

    Default Re: Gnome Software and Discover not installing third party RPMs

    And I forgot about package versions:
    gnome-software 3.22.1-1.1
    discover 5.8.3-1.1
    PackageKit 1.1.4-1.2

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts