Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: Mplayer crashes

  1. #1
    Join Date
    Aug 2008
    Location
    Mexico and Sweden
    Posts
    1,326

    Default Mplayer crashes

    Installed Mplayer with YaST. Yes, Packman is enabled. It crashes with...

    [CODEmplayer: error while loading shared libraries: libvdpau.so.1: cannot open shared object file: No such file or directory
    ][/CODE]

    I thought YaST was supposed to install dependencies.

    Any thoughts on a solution?

  2. #2
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    27,215
    Blog Entries
    15

    Default Re: Mplayer crashes

    Quote Originally Posted by ionmich View Post
    Installed Mplayer with YaST. Yes, Packman is enabled. It crashes with...

    [CODE]
    mplayer: error while loading shared libraries: libvdpau.so.1: cannot open shared object file: No suc
    h file or directory
    [/CODE]

    I thought YaST was supposed to install dependencies.

    Any thoughts on a solution?
    Hi
    Use zypper...
    Code:
    zypper se --file-list libvdpau.so.1
    Reading installed packages...
    
    S | Name      | Summary               | Type   
    --+-----------+-----------------------+--------
    i | libvdpau1 | VDPAU wrapper library | package
    I have it installed, you probably don't...
    Last edited by malcolmlewis; 08-Nov-2016 at 18:16.
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  3. #3
    Join Date
    Sep 2008
    Posts
    2,997

    Default Re: Mplayer crashes

    if you're on an intel gpu you might have removed it as vdpay causes trouble on intel machines,
    I think mplayer defaults to software rendering not hardware (vdpau) I thought mplayer was "replaced" with mpv?
    if you are using smplayer in options disable vdpau use software or vaapi (if on intel or ati gpu)

  4. #4
    Join Date
    Aug 2008
    Location
    Mexico and Sweden
    Posts
    1,326

    Default Re: Mplayer crashes

    Quote Originally Posted by malcolmlewis View Post
    Hi
    Use zypper...
    Code:
    zypper se --file-list libvdpau.so.1
    Reading installed packages...
    
    S | Name      | Summary               | Type   
    --+-----------+-----------------------+--------
    i | libvdpau1 | VDPAU wrapper library | package
    I have it installed, you probably don't...
    It's installed.

    Code:
    :~> sudo zypper se --file-list libvdpau.so.1
    root's password:
    Loading repository data...
    Reading installed packages...
    
    S | Name      | Summary               | Type    
    --+-----------+-----------------------+--------
    i | libvdpau1 | VDPAU wrapper library | package
    ion@linux-aj1s:~> mplayer
    mplayer: error while loading shared libraries: libvdpau.so.1: cannot open shared object file: No suc
    h file or directory
    ion@linux-aj1s:~> 
    
    

  5. #5
    Join Date
    Aug 2008
    Location
    Mexico and Sweden
    Posts
    1,326

    Default Re: Mplayer crashes

    Quote Originally Posted by I_A View Post
    if you're on an intel gpu you might have removed it as vdpay causes trouble on intel machines,
    I think mplayer defaults to software rendering not hardware (vdpau) I thought mplayer was "replaced" with mpv?
    if you are using smplayer in options disable vdpau use software or vaapi (if on intel or ati gpu)
    mpv crashes the same way. As for smplayer I could not find vdpau or vaapi in options>preferences. It crashes as well.

  6. #6
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    27,215
    Blog Entries
    15

    Default Re: Mplayer crashes

    Quote Originally Posted by ionmich View Post
    mpv crashes the same way. As for smplayer I could not find vdpau or vaapi in options>preferences. It crashes as well.
    Hi
    So is it intel graphics? Is the intel vaapi package installed too? Also which repos are they from?

    You could try starting with the vaapi driver?
    Code:
    mplayer -vo vaapi -va vaapi somevideo
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  7. #7
    Join Date
    Aug 2008
    Location
    Mexico and Sweden
    Posts
    1,326

    Default Re: Mplayer crashes

    Quote Originally Posted by malcolmlewis View Post
    Hi
    So is it intel graphics? Is the intel vaapi package installed too? Also which repos are they from?

    You could try starting with the vaapi driver?
    Code:
    mplayer -vo vaapi -va vaapi somevideo
    Thanks for the assistance.

    nVidia 6150 graphics. vaapi is installed from Leap-42.1-Oss

    Code:
    ~> mplayer -vo vaapi -va vaapi DATA/MOVIES/threetenors
    mplayer: error while loading shared libraries: libvdpau.so.1: cannot open shared object file: No suc
    h file or directory
    
    

  8. #8
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    27,215
    Blog Entries
    15

    Default Re: Mplayer crashes

    Quote Originally Posted by ionmich View Post
    Thanks for the assistance.

    nVidia 6150 graphics. vaapi is installed from Leap-42.1-Oss

    Code:
    ~> mplayer -vo vaapi -va vaapi DATA/MOVIES/threetenors
    mplayer: error while loading shared libraries: libvdpau.so.1: cannot open shared object file: No suc
    h file or directory
    
    
    Hi
    Nvidia driver or nouveau? I see an old thread here.. https://forums.opensuse.org/showthre...-find-libvdpau
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  9. #9
    Join Date
    Sep 2008
    Posts
    2,997

    Default Re: Mplayer crashes

    post your repo list
    Code:
    zypper lr -d
    did you try and install libvdpau1
    Code:
    zypper in libvdpau1

  10. #10
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,384

    Default Re: Mplayer crashes

    Quote Originally Posted by ionmich View Post
    Installed Mplayer with YaST. Yes, Packman is enabled.
    Which does not mean that it is installed from the Packman repo. It may be when the version number on Packman is higher, or when the Packman repo's priority is higher (lower number) or when you explicitly choose the Packman version from the Version tab.
    Henk van Velden

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •